Issue when creating "rails new simpleblog" - rubyzip 2.0.0 requires ruby>=2.4.x.

46 views
Skip to first unread message

Avinash Kumar

unread,
Oct 31, 2019, 2:17:45 PM10/31/19
to RailsInstaller
I installed the latest railsinstaller from the site which is railsinstaller-3.4.0.exe. But that only supports 2.3.3 ruby. But when doing a bundle install command, it fails with the error saying rubyzip 2.0.0 needs ruby>=2.4 and it fails. How do i get pass this?

muganda dizo

unread,
Nov 18, 2019, 1:01:42 AM11/18/19
to railsin...@googlegroups.com
You could use rvm or rbenv to manage ruby

On Thu, Oct 31, 2019, 9:17 PM Avinash Kumar <avi...@gmail.com> wrote:
I installed the latest railsinstaller from the site which is railsinstaller-3.4.0.exe. But that only supports 2.3.3 ruby. But when doing a bundle install command, it fails with the error saying rubyzip 2.0.0 needs ruby>=2.4 and it fails. How do i get pass this?

--
You received this message because you are subscribed to the Google Groups "RailsInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to railsinstalle...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/railsinstaller/341e590f-8d9e-486c-9e5a-fcc6a33e6227%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages