bitrate jitter

50 views
Skip to first unread message

Paulh002

unread,
Jul 28, 2023, 10:48:56 AM7/28/23
to Radioberry
Hi,

I am curious if other people also experience a high bitrate jitter when running the radioberry in 384 Khz samplerate. I am using an old radioberry which was bought from aliexpress, so I am not sure if the oscillator is a high quality tcxo. But the tcxo is closely positioned to the ad converter which can get quite hot, so this can also be an issue, like with the pluto. But it also can be an software issue in my code.

73 Paul
PA0PHH  

pa3gsb

unread,
Jul 28, 2023, 11:42:35 AM7/28/23
to Radioberry
Paul,

Running at the edge with 384K


Be sure only one channel is used (powersdr is by default running with 2 channels)

For higher bandwith the juice board is beter : https://www.pa3gsb.nl/2021/05/31/radioberry-juice/


73 Johan


Op vrijdag 28 juli 2023 om 16:48:56 UTC+2 schreef paul.hol...@gmail.com:

Paulh002

unread,
Jul 28, 2023, 12:00:01 PM7/28/23
to pa3gsb, Radioberry
Hi Johan,
Long time no see.
I run my own sdr software on the pi, which works now quite well now even does FT8 and FT4. But did not use the radioberry for a long time. So i swapped out my SDR (a tayloe based one) for the radioberry but noticed a lot of variation in the bit rate.
When I load the older gateware it seems better. I try to use small buffer sizes about 8k but increasing to 32 K gave me still a lot of buffer underruns.
I will do some more test.

Thanks,
Paul



Op vr 28 jul 2023 om 17:42 schreef pa3gsb <pa3...@gmail.com>:
--
You received this message because you are subscribed to the Google Groups "Radioberry" group.
To unsubscribe from this group and stop receiving emails from it, send an email to radioberry+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/radioberry/77f6e97c-1d7c-4b90-a088-946bab7e5fc2n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages