My Radioberry does not transmit...

309 views
Skip to first unread message

Jose Berrios

unread,
Aug 18, 2023, 9:43:06 PM8/18/23
to Radioberry
My Radioberry installation consists of the Radioberry board currently sold via AliExpress.
It is running the service on a 4-gig Raspberry Pi with a 7-inch touchscreen display, and wireless keyboard running the latest 64-bit Raspbian distribution.  I installed it using the instructions on the GIT board. 

I can access Radioberry across my network using SDR Console on Windows 10 or SParkSDR on Linux.  I installed a TR/RX switch which I purchased on Banggood. The installation went well since receiving is working. However, whenever I try to transmit no rf is detected at all on my tuner or on my Yaesu FT-991A. I'm not generating a signal at all.

I am wondering if I missed a step or omitted some tasks to enable transmission.

Any guidance the group can provide is appreciated. 

Thanks,

Joe (aka Jose) Berrios, WB2BWU


Kristofer Danner

unread,
Aug 19, 2023, 1:14:21 PM8/19/23
to Radioberry
I would connect a milliwatt meter between the TX port and the TX/RX switch if I was troubleshooting this.

What kind of support has the person who sold you the hardware been providing? I have to wonder, do they expect to just sell hardware and then have this group do the support for them?

wb2bwu

unread,
Aug 20, 2023, 10:27:59 AM8/20/23
to Kristofer Danner, radio...@googlegroups.com
AliExpress or the Chinese vendors don't usually provide support like vendors like Yaesu, ICOM, or Kenwood. That kind of support just doesn't exist. The buy is referred to the GitHub pages for Radioberry which is why I'm posting this issue on this group. There's simply no power coming out of the unit. 
I'm still seeking answers from this group, if possible.

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu




--
You received this message because you are subscribed to a topic in the Google Groups "Radioberry" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/radioberry/NMowE-BhSq0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to radioberry+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/radioberry/95a8b9c2-4a3c-483c-bd91-decfeab8d4cbn%40googlegroups.com.

pa3gsb

unread,
Aug 20, 2023, 10:59:55 AM8/20/23
to Radioberry
Hi Joe,


Tx can be handled via the SDR program but also within the gateware.

Avoiding to setup errors in your SDR program i suggest you to use the key (CW) function in the gateware.


Use pin 14 of the radioberry io connector (switch to ground).

Hope you are seeing output power.

73 Johan
PA3GSB

Op zondag 20 augustus 2023 om 16:27:59 UTC+2 schreef wb2...@gmail.com:

wb2bwu

unread,
Aug 20, 2023, 11:21:53 AM8/20/23
to pa3gsb, Radioberry
This is what I see when I run the check commands:
image.png

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu



wb2bwu

unread,
Aug 20, 2023, 11:37:51 AM8/20/23
to pa3gsb, Radioberry


Transmission commands seem to be working fine. But not RF out. I am puzzled greatly.

image.png

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu



wb2bwu

unread,
Aug 20, 2023, 12:16:59 PM8/20/23
to pa3gsb, Radioberry
While I'm not hearing a signal, I'm seeing indications of an output signal as shown below. I ensured that the remote microphone was working and saw this:

image.png
Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu



wb2bwu

unread,
Aug 20, 2023, 1:37:53 PM8/20/23
to pa3gsb, Radioberry
I have a follow up question. When I installed the Radioberry software soft I chose the 'CL016' option instead of 'CL025'.
What were the implications of this choice? I seemed to recall that I had issues with the 'CL025' option on my initial attempt.

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu



wb2bwu

unread,
Aug 20, 2023, 4:54:04 PM8/20/23
to Paulh002, Radioberry, Jose Berrios
Thanks, I'll check it out.  
Since I am using an 'RX/TX' switch from Banggood, I changed the internal dip-pin setting on the RX/TX switch so that the antenna port is available to both RX/TX ports.
Now I am hearing my signal on the other HF radios. It isn't a great signal, but I know that the board is working. Unfortunately, the board doesn't put out a sufficient signal to drive an amplifier; however, I know the Radioberry board is working. 

Thank you for your assistance!


Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu




On Sun, Aug 20, 2023 at 3:59 PM Paulh002 <paul.hol...@gmail.com> wrote:
image.pngthe output is on pin 50 and 46 of the ad9866 it should measure 3.3 volt on both pins.
The complete schematic is available on github I included a pdf .
Also the power supply on the pins 43, 58, 35, 40 ,17, 60, 64 can be loose. Or even the ground pins 



Op zo 20 aug 2023 om 21:26 schreef wb2bwu <wb2...@gmail.com>:
I do see some issues with the quality of the soldering. The receiver works ok and it seems to be transmitting but no signal is heard.
How can I check the connection between the ADC and the output transformer?

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu




On Sun, Aug 20, 2023 at 3:01 PM wb2bwu <wb2...@gmail.com> wrote:
Ok, thanks for the clarification. 

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu




On Sun, Aug 20, 2023 at 2:05 PM Paulh002 <paul.hol...@gmail.com> wrote:
The board will only support one version. I thought on aliexpress it was the 10cl016 version. My guess is that the board has an hardware issue. Like a bad connection from adc to the output transformer. 
From software point of view you can download the release version from github. (The zip file from releases) or dev version download the install script direct. There were some changes in the transmit function. But your screen shot did not show any error. That's why a hardware issue is possible. Normally the board can transmit and receive at the same time. Best to use a scope and check the output pin of the adc if you see any output. Or ask someone to reflow the adc. 

Op zo 20 aug. 2023 19:55 schreef wb2bwu <wb2...@gmail.com>:
Could I reinstall the Radioberry software with the CL25 option if the board supports both options?

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu




On Sun, Aug 20, 2023 at 1:44 PM wb2bwu <wb2...@gmail.com> wrote:
Thank you for the clarification. 

Joe (aka Jose) Berrios, B.S., M.S., RETIRED
 WB2BWU

MY Cell Phone: 646-634-2789
Google Voice: (917)-930-4036 - please leave a message.
Skype: live:wb2bwu




On Sun, Aug 20, 2023 at 1:42 PM Paulh002 <paul.hol...@gmail.com> wrote:
It should match the type of fpga on the board, there are 2 types used.

Op zo 20 aug. 2023 19:37 schreef wb2bwu <wb2...@gmail.com>:
You received this message because you are subscribed to the Google Groups "Radioberry" group.
To unsubscribe from this group and stop receiving emails from it, send an email to radioberry+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/radioberry/CAO6iVTpgcxA7SiuX%3DatG0EG1RMCjx3dS3w-aWFbhuQ9X55UaNg%40mail.gmail.com.

pa3gsb

unread,
Aug 21, 2023, 2:25:54 AM8/21/23
to Radioberry
Joe,

The radio card uses an Intell Cyclone 10LP FPGA, supporting the 10CL16 and 10CL25. The firmware will be loaded via the raspberry pi.

It depends which board you have ? wich FPGA is installed?; you need to make a selection because the firmware (or also called gateware ) is specific compiled for the tartget CL016 or CL025 chip;  by choosing during installation this choice becomes visible.

But you need to follow the instruction; use pin 14 to see if your issue is software or hardware related.

73 Johan

Op zondag 20 augustus 2023 om 19:37:53 UTC+2 schreef wb2...@gmail.com:
Reply all
Reply to author
Forward
0 new messages