ANN RabbitMQ HOP 3.5.0 Release Candidate 1 is released

11 views
Skip to first unread message

Arnaud Cogoluègnes

unread,
Oct 1, 2019, 5:50:54 AM10/1/19
to rabbitm...@googlegroups.com
On behalf of the RabbitMQ team I'm happy to announce that RabbitMQ HOP
3.5.0 Release Candidate 1, a preview release, is available for
community testing. This preview release is likely to be the last
before a GA release in the next few days.

HOP [1] is a RabbitMQ HTTP API client for Java, Groovy, and other JVM languages.

This pre-release contains dependency upgrades only (Spring 5.2.0 for
the blocking client, Reactor 3.3.0 and Reactor Netty 0.9.0 for the
reactive client). See the changelog [2] for more details.

Users of previous versions are encouraged to test this pre-release.

Dependency (Maven artifact)

Maven:

<dependency>
<groupId>com.rabbitmq</groupId>
<artifactId>http-client</artifactId>
<version>3.5.0.RC1</version>
</dependency>

Gradle:

compile 'com.rabbitmq:http-client:3.5.0.RC1'

This new version is available on Spring Milestone repository. You need
to add this repository explicitly to your dependency manager
configuration file.

Maven:

<repositories>
<repository>
<snapshots>
<enabled>false</enabled>
</snapshots>
<id>spring-milestone</id>
<name>spring-milestone</name>
<url>https://repo.spring.io/libs-milestone-local</url>
</repository>
</repositories>

Gradle:

repositories {
maven {
url "https://repo.spring.io/libs-milestone-local"
}
}

[1] https://github.com/rabbitmq/hop
[2] https://github.com/rabbitmq/hop/releases/tag/v3.5.0.RC1
Reply all
Reply to author
Forward
0 new messages