Error loading "unicly"

7 views
Skip to first unread message

Robert Goldman

unread,
Mar 12, 2021, 4:34:31 PMMar 12
to Quicklisp
When I try to quickload unicly ( #<URL "http://beta.quicklisp.org/archive/unicly/2021-01-24/unicly-20210124-git.tgz">), I get the following error:


; caught ERROR:
;   READ error during COMPILE-FILE:
;   
;     Lock on package SB-IMPL violated when interning +MIN-HASH-TABLE-SIZE+ while
;     in package UNICLY.
;   See also:
;     The SBCL Manual, Node "Package Locks"
;   
;     (in form starting at line: 148, column: 0, position: 7485)
;


My guess is that this is happening because unicly is poking around in un-exported SBCL internals.  Maybe best to remove it from quicklisp? Looks unmaintained (unless it's been adopted by quicklispers or something).

Zach Beane

unread,
Mar 12, 2021, 4:44:01 PMMar 12
to quicklisp
I don't see the same result. What version of SBCL are you using?

Zach

--
You received this message because you are subscribed to the Google Groups "Quicklisp" group.
To unsubscribe from this group and stop receiving emails from it, send an email to quicklisp+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/quicklisp/693ba741-9b04-4e02-903e-02fc2ff53e89n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages