ServerAccessObject POST requests

1 view
Skip to first unread message

Claire Theyers

unread,
Nov 29, 2011, 4:27:56 PM11/29/11
to QuickConnect
Hi Lee,

I've been using QuickConnect iphone (quickconnectFamily version 2.1.1)
for a few months now and its working brilliantly for me. I've got qc
communicating with a django web server using JSON and so far all has
gone well using GET requests. I've become stuck on a problem using
POST requests from Quick Connect. Whatever parameters I set when I
send a ServerAccessObject.transact I still get it sending a GET
request. I've been investigating the ServerAccessObject.js trying to
find out what's going on but so far haven't had much luck. I feel it
might be to do with the request headers (I don't know much about
these) but have tried every option and had no joy.

Thanks
Claire

Lee Barney

unread,
Nov 29, 2011, 5:51:28 PM11/29/11
to quickconn...@googlegroups.com
Claire,

When you call qc.transact the first parameter should be either 'GET' or 'POST'. Are you passing 'POST' ?

Lee

> --
> You received this message because you are subscribed to the Google Groups "QuickConnect" group.
> To post to this group, send email to quickconn...@googlegroups.com.
> To unsubscribe from this group, send email to quickconnectiPh...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/quickconnectiPhone?hl=en.
>

Claire Theyers

unread,
Nov 30, 2011, 3:24:24 PM11/30/11
to QuickConnect
Hi Lee,

Yes I am sending "POST",

addCommentService.transact("POST", ServerAccessObject.TEXT, false,
parameterString, data);

I've also checked in the http.open call in ServerAccessObject.js and
this is also passing in "POST" as the call type.

Thanks,
Claire

Reply all
Reply to author
Forward
0 new messages