HCL - CF-31 Mk1

190 views
Skip to first unread message

Andrew Callahan

unread,
Nov 13, 2016, 8:45:48 PM11/13/16
to qubes...@googlegroups.com
Notations:

VT-d- Chipset has this capability according to intel (http://ark.intel.com/products/43544/Intel-Core-i5-540M-Processor-3M-Cache-2_53-GHz). Examination of BIOS shows no chipset option; assumption- motherboard does not support.

GPU- Unit features discreet ATI Radeon HD7750 card on board. Current testing has not shown it to work yet with a variety of Linux flavors; testing was minimal and should not be considered even slightly investigatory. To overcome, force economy mode in BIOS; this forces onboard chipset

TPM- Fitted. Chipset v1.2 default for CF-31 early Mk series units where equipped. (Not enabled)

TXT- Fitted on early Mk series units where equipped. (Not enabled)

Touchpad is a P/S2 unit. Requires i8042.nopnp notification added to /boot/grub2/grub.cfg file. Insert i8042.nopnp under 20_linux_xen at end of first module line

Notes- Unit will fully realize two VMs (browser, email client, file browser, and text editor for each) simultaneously in addition to net/firewall/whonix VMs. No more than two with default RAM mem settings.

Touchscreen not calibrated correctly. I have used xinput_calibrator in other Linux platforms to perform permanent calibration but have not tried yet for Qubes.

Occasional issues with wifi if discreet switch not set to 'on' prior to system startup. Initial setups of VPN configuration and wifi performance show slow/spotty performance. After setup and reboot, system performs well.

Worked with 3.1 for a while, getting comfortable. Attempt to wipe and install 3.2 met with issues. VMs would show booting in manager but no window for requested browser/file mgr/etc would ever show. System felt slightly more sluggish. Also, attempts to import VM backups abject failure. Did not explore situation in further depth but instead returned to 3.1.

Additional personal notes:
If the CF-31 is your first toughbook of the series, F2 to BIOS and set screen brightness to half power setting. At full brightness (under 1/2 pwr setting) in strong sunlight, a clean screen is still easily visible. Indoors, 20-40% power much more comfortable.

Buttons- following Function/FN buttons known working: Screen brightness (20% increments) controls [F1 F2], Mute [F3], Sound (5% increments) [F4 F5], and emissive keyboard brightness [F12]. Never use other FN key combos.

Multi-Purpose Drive bay (DVD), PCMCIA, SD card, etc all function fine. LUKS-encrypted systems give a post-removal error but no evident issues.

CANNOT BOOT from SD card or USB. Requires hi-cap DVD for install.

Battery packs are a default 87wh- sufficient for 3 hours straight use w/ wifi on, screen 80% brightness, constant use (no breaks). Example- second seat in car running continuous web surf/mail client. Battery actual capacity used in test 80wh (my oldest battery). CF-30 batteries and harddrive caddies are interchangeable.

SSD compatible. No special PAE flags required.

Many BIOS settings possible but no settings changed from use with other common with other Linux flavors like Ubuntu, Mint, Arch, etc.

Additional help w/ CF-31 and other toughbook models can be found at toughbooktalk forums.

Welcome information for installing xinput_calibrator or similar software package for calibration of touchscreen. Will answer all questions to best of ability.
Qubes-HCL-Panasonic_Corporation-CF_31.yml

m1el...@gmail.com

unread,
Jun 14, 2017, 2:01:01 PM6/14/17
to qubes-users, rest...@mailbox.org
Op maandag 14 november 2016 02:45:48 UTC+1 schreef Andrew Callahan:

A 31 Mk1 does not have the 7750M GPU, that'll be the Mk4 Performance Model. The Mk1 had a iGPU or ATI HD5650M dGPU.

That said, might aswell try Qubes on my 31 Mk3 Standard (i5 3320M, HD 4000 iGPU, 16GB RAM, GPS)

ftm...@gmail.com

unread,
Apr 27, 2020, 5:56:05 PM4/27/20
to qubes-users
if someone ever  reed this:

My Problenmm:  Brigtness locked.

What does it mean, what you write about BIOS ?

Resp:  If it is set to max - in the BIOS:
Does that mean, that i can't change it with F1 and F2  ???????
Because, it's set to max in the BIOS?

If so, than i have a problem - BIOS password is lost.....

If soemone can answer to me:   Bildkon...@gmail.com
Reply all
Reply to author
Forward
0 new messages