Qubes OS 3.2 has been released!

231 views
Skip to first unread message

Joanna Rutkowska

unread,
Sep 29, 2016, 7:11:23 AM9/29/16
to qubes...@googlegroups.com, qubes...@googlegroups.com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hello,

We have just released Qubes OS 3.2:
https://www.qubes-os.org/news/2016/09/29/qubes-32/

Enjoy!
joanna.
-----BEGIN PGP SIGNATURE-----

iQIcBAEBCAAGBQJX7PbOAAoJEDOT2L8N3GcYxCwP/15v8dVR0gfevXUefHLCuZFF
22Fv/g9oWj7ADB5ZVPYjBl9Bcl2F5oqPCrXBbeGkEAyIUcL8nl8MNegTnw7cy4lu
ZGoYFBdSkhEtRvx+u3Cv/C7zbKjsunTzXdnH0kI4AM4yM7BCXaJR4G53K2b+cUDV
h2E3TuVJEas93YxGmuFPrdGOq3MVPPGR90jDbtR5CKrwCDYvJkTtNxvpLG8y3ZLK
+8LODohB/RtrUJYX0d+DI+zu3I3+WEJpW2k2KtRAQWsKBqk2CQI6qBJJPfeU1Dmt
XGthzXzs6eTDaYGom/3LjKCjJoCXj+uJ1BiZWLytjy9PTecruD2nc7dmbacCklJ6
hWwPWZ2AxLvri0lhEEqA84tFgxWFf5IVNa9QQwgoZjPMD+jx6nnevDNEnd73Pk2a
tyFiXr6lWxrMkwrvlBWX6pOjZQI4hGuGOVU7cRZzsmjCy6jyGK/mLno2JNUDBiQG
RDAT2Xuj+zBV43KYNMikMSXFYBwkC15X79pZIlX5kW8qCD8Y0Khw/OKy4ukG8lfs
sV71BqrGDh3ZgR2vMzwf1EZ03SZcGvnyW+bJhHWWBDnslTElbtnnFyWzyKpQ4fAU
k4Z4E0JlG6BjqSkxug0IjKbnDvnYwmtjMXBVkA2q9Jot0g+1h8R8Xf8ks0zlG/Jt
tbM2e8cD5/yV9BW1hwVT
=ihNH
-----END PGP SIGNATURE-----

Robert Mittendorf

unread,
Sep 29, 2016, 9:42:03 AM9/29/16
to qubes...@googlegroups.com
Nice!
Btw: You did not update the "Download & Install" Button on the main page.


Andrew David Wong

unread,
Sep 29, 2016, 9:46:36 AM9/29/16
to Robert Mittendorf, qubes...@googlegroups.com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

On 2016-09-29 06:42, Robert Mittendorf wrote:
> Nice!
> Btw: You did not update the "Download & Install" Button on the main page.
>

Updated. Thanks!

- --
Andrew David Wong (Axon)
Community Manager, Qubes OS
https://www.qubes-os.org
-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJX7RsMAAoJENtN07w5UDAwfiQQALUUFnSFxQivUvH5qZErleOH
6XHk1exM02ORXDAyZbQF7Yzv+eUEnRCkDmgtV2EelfE+naFzN2O7S4W+Eujn1Jxx
34pZnGlvVBIKxSIl812xkhELo7bbNQh2Nu7hwQ5SE5CwZzqyPo1eA0FPHPbmJGTU
znvYXOkhxqkDskuvv3i7hMyRYYSRUSnAgmSrIiIms7FCqDq70m69Zi8HytKY2bmP
g3Mc1qr00bgSMyQKHaRUq+MKKd8aXXd2yyCUF1b2ykVJwmcIl+MXbWy0onlK2/vH
nxWVt0L0YkgXdVH3KJ2qqFsONAm4UBy3xfFNvfEDfW/aFf+Ay/9LoLL20YFu1LYV
R5lbhwuWtCmN3AIgkj1j7g4AO+Ykp0ZhVAPLTNMHEmd3iFUe+pf3SO9aMoMmpj4U
+Ax9Kj2jK2JWJbq/hDTnX169LVMCvPgyprFneBXbtJHiI0YWJS/bWcAzHeSjfzvM
RHVWS8JFKWHbd6TimzaKpc542IH9RsTehPNkphbhzjzBUteQpIxGntapZLmGTyvC
6LvuQm2FEF9fNU+m0mDiIdb7zVWij6tglsvaJlnP8XSeE2pd4EgGa09R8FEROoMH
dEHDoWflZgJlzVZP4pcp7U3nCACWKF9fFi4XYbUVww8iIilRHlG0v9m3szOjPFJy
ydIfyLJsv/YdyrCEC+G2
=MCnY
-----END PGP SIGNATURE-----

raah...@gmail.com

unread,
Sep 29, 2016, 3:18:29 PM9/29/16
to qubes-users, mitte...@digitrace.de
when doing in place upgrade from 3.1,

I get failed: xen-runtime.x86_64 2001:4.6.1-20fc23

Also qubes-core-dom0 is 3.2.10 not 3.2.3 even after --clean option.

raah...@gmail.com

unread,
Sep 30, 2016, 12:56:54 PM9/30/16
to qubes-users, mitte...@digitrace.de, raah...@gmail.com

I just did a clean install from a usb. restored my vms and custom templates from my 3.1 backup everything working good.

My mother appreciates the restart button so now she doesn't have to use terminal to restart the sys-usb lol. Tks for all your hard work.

Franz

unread,
Sep 30, 2016, 1:06:16 PM9/30/16
to cooloutac, qubes-users, mitte...@digitrace.de
On Fri, Sep 30, 2016 at 1:56 PM, <raah...@gmail.com> wrote:
On Thursday, September 29, 2016 at 3:18:29 PM UTC-4, raah...@gmail.com wrote:
> when doing in place upgrade from 3.1,
>
> I get failed: xen-runtime.x86_64 2001:4.6.1-20fc23
>
> Also qubes-core-dom0 is 3.2.10 not 3.2.3  even after --clean option.

I just did a clean install from a usb.  restored my vms and custom templates from my 3.1 backup everything working good.

thanks, I was really wondering if it was possible to restore 3.1 templates. Documentation only mentions applVMs
Best
Fran
 

My mother appreciates the restart button so now she doesn't have to use terminal to restart the sys-usb lol.  Tks for all your hard work.

--
You received this message because you are subscribed to the Google Groups "qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users+unsubscribe@googlegroups.com.
To post to this group, send email to qubes...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/qubes-users/446d6027-bbd0-4d21-bd90-6bcba33f76a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

raah...@gmail.com

unread,
Sep 30, 2016, 11:30:52 PM9/30/16
to qubes-users, raah...@gmail.com, mitte...@digitrace.de
On Friday, September 30, 2016 at 1:06:16 PM UTC-4, Francesco wrote:
> On Fri, Sep 30, 2016 at 1:56 PM, <raah...@gmail.com> wrote:
> On Thursday, September 29, 2016 at 3:18:29 PM UTC-4, raah...@gmail.com wrote:
>
> > when doing in place upgrade from 3.1,
>
> >
>
> > I get failed: xen-runtime.x86_64 2001:4.6.1-20fc23
>
> >
>
> > Also qubes-core-dom0 is 3.2.10 not 3.2.3  even after --clean option.
>
>
>
> I just did a clean install from a usb.  restored my vms and custom templates from my 3.1 backup everything working good.
>
>
>
> thanks, I was really wondering if it was possible to restore 3.1 templates. Documentation only mentions applVMs
>
> Best
>
> Fran
>
>  
>
>
>
> My mother appreciates the restart button so now she doesn't have to use terminal to restart the sys-usb lol.  Tks for all your hard work.
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "qubes-users" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users...@googlegroups.com.
>
> To post to this group, send email to qubes...@googlegroups.com.
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/qubes-users/446d6027-bbd0-4d21-bd90-6bcba33f76a0%40googlegroups.com.
>
>
>
> For more options, visit https://groups.google.com/d/optout.

I don't do the default ones, just cloned custom ones. for default ones I just reinsall the software i need on it.

raah...@gmail.com

unread,
Sep 30, 2016, 11:32:22 PM9/30/16
to qubes-users, raah...@gmail.com, mitte...@digitrace.de
I did a fedora one, was huge update for it. then I did the instructions to install the updated qubes tools.

raah...@gmail.com

unread,
Sep 30, 2016, 11:33:21 PM9/30/16
to qubes-users, raah...@gmail.com, mitte...@digitrace.de
my backup was a month old.

Cube

unread,
Oct 1, 2016, 8:51:58 AM10/1/16
to qubes-users, qubes...@googlegroups.com, joa...@invisiblethingslab.com
Congratulations! The updated graphics driver is very welcome, finally my screen brightness works and I'm sure it'll be more stable.

One issue is my sys-wifi which uses an Intel wireless card. This worked perfectly in the 3.1 but now I get a kernel crash in the module responsible for my card, iwlwifi, attached. Looks like the intel firmware is missing?


[ 5.367324] iwlwifi 0000:00:00.0: Hardware error detected. Restarting.
[ 5.367335] iwlwifi 0000:00:00.0: CSR values:
[ 5.367338] iwlwifi 0000:00:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
[ 5.367347] iwlwifi 0000:00:00.0: CSR_HW_IF_CONFIG_REG: 0X00489204
[ 5.367355] iwlwifi 0000:00:00.0: CSR_INT_COALESCING: 0X80000040
[ 5.367364] iwlwifi 0000:00:00.0: CSR_INT: 0X20000000
[ 5.367370] iwlwifi 0000:00:00.0: CSR_INT_MASK: 0X00000000
[ 5.367378] iwlwifi 0000:00:00.0: CSR_FH_INT_STATUS: 0X00000000
[ 5.367386] iwlwifi 0000:00:00.0: CSR_GPIO_IN: 0X00000000
[ 5.367394] iwlwifi 0000:00:00.0: CSR_RESET: 0X00000009
[ 5.367401] iwlwifi 0000:00:00.0: CSR_GP_CNTRL: 0X080003c5
[ 5.367410] iwlwifi 0000:00:00.0: CSR_HW_REV: 0X00000144
[ 5.367420] iwlwifi 0000:00:00.0: CSR_EEPROM_REG: 0X00000000
[ 5.367429] iwlwifi 0000:00:00.0: CSR_EEPROM_GP: 0X80000000
[ 5.367436] iwlwifi 0000:00:00.0: CSR_OTP_GP_REG: 0X803a0000
[ 5.367443] iwlwifi 0000:00:00.0: CSR_GIO_REG: 0X00080046
[ 5.367450] iwlwifi 0000:00:00.0: CSR_GP_UCODE_REG: 0X00000000
[ 5.367456] iwlwifi 0000:00:00.0: CSR_GP_DRIVER_REG: 0X00000000
[ 5.367464] iwlwifi 0000:00:00.0: CSR_UCODE_DRV_GP1: 0X00000000
[ 5.367473] iwlwifi 0000:00:00.0: CSR_UCODE_DRV_GP2: 0X00000000
[ 5.367482] iwlwifi 0000:00:00.0: CSR_LED_REG: 0X00000018
[ 5.367490] iwlwifi 0000:00:00.0: CSR_DRAM_INT_TBL_REG: 0X00000000
[ 5.367500] iwlwifi 0000:00:00.0: CSR_GIO_CHICKEN_BITS: 0X27800200
[ 5.367510] iwlwifi 0000:00:00.0: CSR_ANA_PLL_CFG: 0Xd55555d5
[ 5.367517] iwlwifi 0000:00:00.0: CSR_MONITOR_STATUS_REG: 0X2bb7f747
[ 5.367527] iwlwifi 0000:00:00.0: CSR_HW_REV_WA_REG: 0X0001001a
[ 5.367538] iwlwifi 0000:00:00.0: CSR_DBG_HPET_MEM_REG: 0Xffff0000
[ 5.367543] iwlwifi 0000:00:00.0: FH register values:
[ 5.367564] iwlwifi 0000:00:00.0: FH_RSCSR_CHNL0_STTS_WPTR_REG: 0X29cb8e00
[ 5.367589] iwlwifi 0000:00:00.0: FH_RSCSR_CHNL0_RBDCB_BASE_REG: 0X029cb8f0
[ 5.367608] iwlwifi 0000:00:00.0: FH_RSCSR_CHNL0_WPTR: 0X000000f8
[ 5.367628] iwlwifi 0000:00:00.0: FH_MEM_RCSR_CHNL0_CONFIG_REG: 0X80801114
[ 5.367647] iwlwifi 0000:00:00.0: FH_MEM_RSSR_SHARED_CTRL_REG: 0X0000003c
[ 5.367665] iwlwifi 0000:00:00.0: FH_MEM_RSSR_RX_STATUS_REG: 0X07030000
[ 5.367683] iwlwifi 0000:00:00.0: FH_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
[ 5.367701] iwlwifi 0000:00:00.0: FH_TSSR_TX_STATUS_REG: 0X05ff0000
[ 5.367719] iwlwifi 0000:00:00.0: FH_TSSR_TX_ERROR_REG: 0X00000000
[ 5.367724] iwlwifi 0000:00:00.0: Not valid error log pointer 0x00000000 for Init uCode
[ 5.738101] fuse init (API version 7.23)
[ 7.094214] iwlwifi 0000:00:00.0: Failed to load firmware chunk!
[ 7.094243] iwlwifi 0000:00:00.0: Could not load the [0] uCode section
[ 7.094267] iwlwifi 0000:00:00.0: Failed to start INIT ucode: -110
[ 7.100815] iwlwifi 0000:00:00.0: Failed to run INIT ucode: -110
[ 7.101391] iwlwifi 0000:00:00.0: L1 Enabled - LTR Enabled
[ 7.325014] ------------[ cut here ]------------
[ 7.325014] WARNING: CPU: 4 PID: 475 at /home/user/rpmbuild/BUILD/kernel-4.4.14/linux-4.4.14/drivers/net/wireless/iwlwifi/pcie/trans.c:1552 iwl_trans_pcie_grab_nic_access+0xfb/0x110 [iwlwifi]()
[ 7.325014] Timeout waiting for hardware access (CSR_GP_CNTRL 0x080003dc)
[ 7.325014] Modules linked in: fuse xt_nat xen_netback xt_REDIRECT nf_nat_redirect ip6table_filter ip6_tables xt_conntrack ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iwlmvm(+) mac80211 iwlwifi cfg80211 rfkill intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp crct10dif_pclmul crc32_pclmul crc32c_intel pcspkr xen_pcifront dummy_hcd udc_core u2mfn(O) xen_blkback xenfs xen_privcmd xen_blkfront
[ 7.325014] CPU: 4 PID: 475 Comm: modprobe Tainted: G O 4.4.14-11.pvops.qubes.x86_64 #1
[ 7.325014] 0000000000000000 00000000ffa653d9 ffff88000012fa40 ffffffff813b06f3
[ 7.325014] ffff88000012fa88 ffffffffa01693e8 ffff88000012fa78 ffffffff8109f402
[ 7.325014] ffff88000df14000 0000000000000000 ffff88000df175f0 ffff88000012fb28
[ 7.325014] Call Trace:
[ 7.325014] [<ffffffff813b06f3>] dump_stack+0x63/0x90
[ 7.325014] [<ffffffff8109f402>] warn_slowpath_common+0x82/0xc0
[ 7.325014] [<ffffffff8109f49c>] warn_slowpath_fmt+0x5c/0x80
[ 7.325014] [<ffffffffa015c81b>] iwl_trans_pcie_grab_nic_access+0xfb/0x110 [iwlwifi]
[ 7.325014] [<ffffffffa014d459>] iwl_set_bits_prph+0x39/0x90 [iwlwifi]
[ 7.325014] [<ffffffffa015ccae>] iwl_pcie_apm_stop+0x36e/0x430 [iwlwifi]
[ 7.325014] [<ffffffffa015ce0c>] iwl_trans_pcie_op_mode_leave+0x9c/0x130 [iwlwifi]
[ 7.325014] [<ffffffffa0264d6d>] iwl_op_mode_mvm_start+0x73d/0x810 [iwlmvm]
[ 7.325014] [<ffffffffa0122000>] ? 0xffffffffa0122000
[ 7.325014] [<ffffffffa014e6ea>] _iwl_op_mode_start.isra.8+0x4a/0xa0 [iwlwifi]
[ 7.325014] [<ffffffffa014e7ac>] iwl_opmode_register+0x6c/0xd0 [iwlwifi]
[ 7.325014] [<ffffffffa0122035>] iwl_mvm_init+0x35/0x1000 [iwlmvm]
[ 7.325014] [<ffffffff81002123>] do_one_initcall+0xb3/0x200
[ 7.325014] [<ffffffff811a7837>] ? free_hot_cold_page+0x117/0x180
[ 7.325014] [<ffffffff811ff176>] ? kmem_cache_alloc_trace+0x196/0x210
[ 7.325014] [<ffffffff8119e680>] ? do_init_module+0x27/0x1cb
[ 7.325014] [<ffffffff8119e6b8>] do_init_module+0x5f/0x1cb
[ 7.325014] [<ffffffff8111e32e>] load_module+0x151e/0x1a70
[ 7.325014] [<ffffffff8111a9c0>] ? __symbol_put+0x60/0x60
[ 7.325014] [<ffffffff812255d0>] ? kernel_read+0x50/0x80
[ 7.325014] [<ffffffff8111eac4>] SYSC_finit_module+0xb4/0xe0
[ 7.325014] [<ffffffff8111eb0e>] SyS_finit_module+0xe/0x10
[ 7.325014] [<ffffffff8175692e>] entry_SYSCALL_64_fastpath+0x12/0x71
[ 7.325014] ---[ end trace e745130f97ee5f49 ]---
[ 7.686993] ------------[ cut here ]------------

7820945782094578092435780927845

unread,
Oct 1, 2016, 2:22:54 PM10/1/16
to qubes-users, joa...@invisiblethingslab.com, qubes...@googlegroups.com
Wow, cool it look really great!

Thanks

yaqu

unread,
Oct 2, 2016, 3:59:57 PM10/2/16
to qubes...@googlegroups.com
On Fri, 30 Sep 2016 14:06:14 -0300, Franz <169...@gmail.com> wrote:

> On Fri, Sep 30, 2016 at 1:56 PM, <raah...@gmail.com> wrote:
> > I just did a clean install from a usb. restored my vms and custom
> > templates from my 3.1 backup everything working good.
> >
>
> thanks, I was really wondering if it was possible to restore 3.1
> templates. Documentation only mentions applVMs

Upgrading templates is documented there:
https://www.qubes-os.org/doc/upgrade-to-r3.2/

BTW I was restoring my fedora templates from R3.0 to R3.2 and it worked
well. All I had to do was upgrade templates to 3.1, then upgrade to 3.2,
and then install missing packages:

$ sudo dnf install qubes-upgrade-vm
$ sudo dnf update
$ sudo dnf install qubes-upgrade-vm
$ sudo dnf update
$ sudo dnf install qubes-img-converter qubes-input-proxy-sender
qubes-mgmt-salt-vm-connector qubes-usb-proxy

Regards,

--
yaqu
Reply all
Reply to author
Forward
0 new messages