HCL - Dell Precision M6800

190 views
Skip to first unread message

Richard Horan

unread,
Feb 23, 2017, 10:42:36 PM2/23/17
to qubes...@googlegroups.com
Hi,

I am new to Qubes and have only used Linux on virtual machines before
now. It is the first time I installed Linux directly. I installed
Qubes 3.2 on a Dell Precision M6800 which worked with a few problems.

First of all I installed Anti-Evil-Maid as I have a TPM and it caused
the boot configuration file to become corrupt. I changed a grub file to
fix grub and it worked fine after that. I included the fixed file as an
attachment. I did multiple installs before I found the problem's
solution. I ran the Grub configuration command as listed in the online
documentation for multiboot sudo grub2-mkconfig -o
/etc/grub.d/19_Linux_xen_tboot after fixing the file. As it changed
multiboot to module which I switched back for the xen boot. And added
back in --nounzip to the last module loader which anti-evil-maid
removed. This only affected the AEM grub entry and it still worked with
the regular boot entry even with AEM installed, but not with the AEM
boot entry.

Next the WiFi did not work. I downloaded and compiled the drivers for
BCM4352 from broadcom.com website using a wired connection. I noticed
that the kernel-devel files for Fedora don't match the version in the
fedora-23 machine when upgraded to 4.4.14-38-11 as only 4.4.14-36-11
devel tools are available, but 4.4.14-11 version is still available for
a downgraded kernel to build the files. I followed a post in a Qubes
user group post to do the following before building the files

su

cp -a /lib/modules /rw/modules

mount -B -rw /rw/modules /lib/modules

systemctl restart systemd-udevd

Notice that mount -bind with no -rw as in the user group post does not
work. -rw is needed.

I then created a /rw/config/rc.local file as attached to remount and
remove bcma b43 and load the broadcom driver each start-up. I also
built and installed the broadcom wl driver in dom0, but don't know if
that is required for it to work. I also attached that file. It is
basically.

sudo mount -B -rw /rw/modules /lib/modules

sudo rmmod b43

sudo rmmod bcma

sudo modprobe wl

I needed to restart the machine to get the driver working. Restarting
the VM was not enough as dmesg reported kernel tait due to proprietary
driver which locked the driver. I don't know how to get the Bluetooth to
work. It simply does not work. I only got the wireless working. And
the wired connection works with no added work.

I can't build the NVIDIA drivers as the kernel-devel files that match
dom0 are not available in the Fedora template, but as the duel graphics
include Intel graphics I am relying on the Intel graphics for now. I'm
unsure of the corresponding yumdonloader commands to use in dom0 in the
documentation so I have not tired to build it in dom0.

There are problems with Suspend and Hibernate and Log Out. If I log out
and back in the Qubes VM Manager stops and wont start via the GUI. The
check box for save session seams to have no function. Suspend saves the
session to the hard drive, but when it wakes there is only a white
screen and it takes over 15 minutes to recover. I it is quicker to shut
down and restart the computer. Hibernate saves the session to memory
and works. The screen saver works. When the laptop cover is closed it
Suspends to disk with the over 15 minute delay. The Suspend and
Hibernate functions are the reverse of what they should be.

The laptop has rpm driver files on the Dell website under Red Hat, but
they won't install. This includes the provided NVIDIA driver for Red Hat.

I have all the regular VMs plus all the experimental features
installed. That includes the TOR and USB VM. They seem to be working.
I had no problems with USB VM so far, but restarting the TOR networking
VM has had problems until restarting the machine. There were a few times
it complained of a already used MAC address after restarting. Still it
is still early, and I have not used it much.

I'm still have not tried all the features, and besides from the above I
upgraded the Fedora and Debian VMs. I am still working on configuring
my machine. I have not yet installed other features such as installing
Windows 7 or other templates. I hope support for Windows 10 happens soon.

Richard

Qubes-HCL-Dell_Inc_-Precision_M6800-20170223-205729.yml
19_linux_xen_tboot
rc.local

1xa...@gmail.com

unread,
Mar 7, 2018, 11:44:09 AM3/7/18
to qubes-users
Dear Richard,

did you try to install Qubes 4.0-rc5?
If so, is it full working?

Kind regards,
Sören
Reply all
Reply to author
Forward
0 new messages