HCL - Lenovo X1 Carbon 2nd Gen i7-4600U Touchscreen - Qubes R3

Skip to first unread message

Thomas Fleming

Dec 7, 2015, 4:16:30 PM12/7/15
to qubes...@googlegroups.com
tl;dr; Everything required to run Qubes "out of the box" works. The X1
Carbon 2nd Gen is pretty close to being worthy of the label "Qubes
Certified". There are some minor issues and some things not tested.
Below are my notes.

Setup: Lenovo X1 Carbon 2nd Gen i7-4600U with High DPI Multi touch
screen. Latest version of Lenovo BIOS (1.23), Intel VT-x and VT-d

Breakdown of what's working, not tested and finally not working.

Sound (speakers): working
Sound (headphone jack): working
Wifi: working. According to "dmesg | grep iwlwifi" firmware version was loaded, which from
https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi is
iwlwifi-7260-10.ucode if anyone is interested. The note on the HCL
page about needing iwlwifi-260 can probably be removed.
Ethernet NIC (via micro adapter): working
HDMI: working. However, there seems to be some issue with how the
extended desktop is displayed. I will do some more testing when I have
2xUSB 3.0: working
Display: working. However, neither KDE 4 or Xfce work well with the
HDPI screen. Everything is tiny, to the point of being difficult to
see. I can't see any simple way to configure this in either desktop
environment, short of reducing the resolution.
Display Single touch: working
Keyboard: working
Trackpoint: working
Touchpad: working
Touchpad buttons: working. However, touchpad "tap to click" not
working out of the box but can be configured in both KDE and Xfce.
There is no "PalmCheck" feature
(https://support.lenovo.com/gb/en/documents/ht062696) which makes
typing without pressing the touchpad really difficult.
Sleep/Resume: Working
Sleep on lid close: Working
Resume(wake?) on lid opening: Wasn't working initially. Updated Qubes
and now seems to be working.

WWAN: not tested. would be nice to have...
Webcam: not tested. never use. Any idea how I can quickly test it?
Mic: not tested. same question as webcam.
NFC: not tested
DisplayPort: not tested.
Docking connector: not tested.
Fingerprint reader: not tested.
Bluetooth: not tested. not supported?

Display Multi touch: not working. I think this may be a limitation of
KDE 4 and Xfce?
Light sensor: not working. In windows the light sensor is used to
dynamically adjust the brightness of the screen. It either doesn't
work or is just not used in Qubes.
Hibernate: not working. Just seems to behave the same as "lock",
requiring me to enter my password.

Adaptive keys: partially working, including all of the important
buttons. In windows there are 5 modes; Home, Web Browser, Web
Conference, Function and Lay-flat. In Qubes, only Function and Home
are available. They are also not context sensitive like in windows
i.e. if using a browser the displayed buttons do no change.

Function Mode: The "FN" and F[1-12] keys work. The keyboard backlight
button works, and cycles though differing brightnesses. The following
buttons do nothing: tapping the brightness button to decrease to the
minimum, wireless/airplane mode, "settings". Projector button is

Home mode: The volume up, down and mute button work. The brightness up
and down work. The search, view open apps, view all apps, snipping
tool, cloud, voice recognition and camera gestures do nothing.

Summary: Virtually everything that the average Qubes user would need
appears to work without any configuration. The only real usability
issues stems from the HDPI display and the lack of "PalmCheck" which
negatively affects typing. I have tried the X1 Carbon on GNOME, which
has marginally better support for HDPI than KDE 4 (not sure about KDE
5). However, Gnome is still pretty frustrating so I'm not sure I'd
advocate it at this point. Also, there is no coreboot support, which
is a shame given Lenovo's recent escapades.

Additional: I tried Qubes with the "Live" distro 3.1 alpha but it
wouldn't boot successfully. Same problem as described here:

Reply all
Reply to author
0 new messages