"Upgrading" by installing

6 views
Skip to first unread message

Ulrich Windl

unread,
Sep 3, 2022, 8:57:19 AMSep 3
to qubes...@googlegroups.com
Hi !

So eventually I decided to upgrade my Qubes OS installation by backup, install, then restore.
Unfortunately I'm stuck, and here is my negative experience:
First when using a custom disk layout, i.e.: reuse VG and LV from the current installation, I noticed that I van only assign swap if I select to reformat it. Then it's selected automatically; otherwise it's ignored.
Next it's recommended to reformat the root snd boot filesystems, but noting got the LVs. So ehen trying to install the debian-11 template it failed, template installation was aborted, snd I found to way to resume or restart. See attachment. So I restarted everything, also deleting the LVs for the VMs (which is not easy from the installation environment).
When installation had finished eventually, I tried to restore my VMs, but I'm offered just the basic net and firewall VMs. So I wonder how to do that.
Also I wondered why there is no "import VM" function when the LVs for the VM are still (already) there. I didn't delete the LVs of one of my VMs.

So in summary the installer snd the documentation should be improved.

Regards,
Ulrich
P.S.: Typed on my mobile, so there are probably several typing errors I did not detect.
IMG20220903001428_BURST000_COVER.jpg

Ulrich Windl

unread,
Sep 5, 2022, 8:01:28 AMSep 5
to qubes...@googlegroups.com
Hi!

I could really need some help on how to restore my v4.0 backups into v4.1.1 ...

Regards,
Ulrich

>>> Ulrich Windl <Ulrich...@rz.uni-regensburg.de> schrieb am 03.09.2022 um 14:56
in Nachricht <8d882b46-f189-41da...@rz.uni-regensburg.de>:
> --
> You received this message because you are subscribed to the Google Groups
> "qubes-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to qubes-users...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/qubes-users/8d882b46-f189-41da-91a0-c0db11d
> 8ff4a%40rz.uni-regensburg.de.




Andrew David Wong

unread,
Sep 5, 2022, 11:10:45 AMSep 5
to Ulrich...@rz.uni-regensburg.de, qubes...@googlegroups.com
I don't really know anything about custom disk layouts, but have you tried restoring by following these instructions?

https://www.qubes-os.org/doc/how-to-back-up-restore-and-migrate/#restoring-from-a-backup

If so, where exactly did you encounter a problem (i.e., which step)?
OpenPGP_signature

Ulrich Windl

unread,
Sep 14, 2022, 6:38:42 PMSep 14
to qubes...@googlegroups.com
Hi!

As it turned out I needed just an extra boot. At least when having mounted the backup volume in Dom0 manually I was able to restore when I couldn't before.
Another confusing thing is that when leaving the first screen nothing seems zo happen, but I noticed the CPU fan spinning up for a few seconds until the next screen appears. Maybe add some progress indicator...

Regards
Ulrich
Reply all
Reply to author
Forward
0 new messages