Fwd: Re: [qubes-users] Re: Trouble with Lenovo X200 Tablet UPDATE

117 views
Skip to first unread message

pake...@openmailbox.org

unread,
Feb 16, 2015, 3:43:58 PM2/16/15
to Qubes Users

On 2014-10-22 11:25, Zrubi wrote:

>> qubes-hcl-report dom0
>>
>> shows that -
>> VT-x: Active
>> VT-d: Not Active
>
> Yo can double check these results by issuing this command in a dom0
> terminal:
>
> xl info |grep virt_caps
> xl dmesg |grep -i "HVM: \(VMX\|SVM\)"
> xl dmesg |grep -i "I/O virtualisation"
>
>
> If you still see that no VT-d is active, but it should be according to
> your BIOS settings: means that your BIOS (and/or your device) is buggy.

Hello again.

Tried that bash script and still no VT-x.

HCL is attached.

Says its got a L9400 Processor
Listed as a SL9400 on the model specifications on the Lenovo support
website when searching by the model
Intel Ark shows
http://ark.intel.com/products/36689/Intel-Core2-Duo-Processor-SL9400-6M-Cache-1_86-GHz-1066-MHz-FSB?q=l9400
That page says it supports VT-x, but interestingly doesnt mention VT-d
(where as the pages on Intel ARC for the i5 and i7 (but not the Celeron)
processors fitted to the later Thinkpad X201 tablets show they do have
VT-d and VT-x. That makes things a bit confusing considering my results
- something is not listed correctly?

I was looking at http://www.thinkwiki.org/wiki/Category:X200_Tablet and
http://www.thinkwiki.org/wiki/Category:X201_Tablet for lists of
processors.

Looks like its may have a GM45 chipset.
On the Lenovo website listing the drivers for the model shows a'Intel
GM45 Display Driver' and the graphics is integrated in this chipset
package.
http://ark.intel.com/products/35134
thinkwiki only mentions 'Intel GM45' under the X200 tablet catagories
Intel ark
shows it which supports VT-d
I did find an add for a X200 tablet that said it had a G965 chipset. Not
sure what model that was (or if they were correct?)
Still not 100% certain which chipset mine has but thinking its more than
likely GM45. Anyway I can find out for sure?

thinkwiki only mentiona 'Intel QM57' under the X201 tablet catagories
which is listed on Intel ARK as being VT-x compatible.

So I guess that tells a story that might help some others who are
looking at Lenovos. All though its all a bit confusing still too.

Also I'm guessing as a rule of thumb, if its got VT-x it will have VT-d
capabilities also?
Qubes-HCL-LENOVO-7450B34-20141007-011753.txt

pake...@openmailbox.org

unread,
Feb 16, 2015, 3:58:51 PM2/16/15
to Qubes Users
On 2015-02-16 20:43, pake...@openmailbox.org wrote:
.
>
> Hello again.
>
> Tried that bash script and still no VT-x.


Sorry that should read 'still no VT-d'.

I just had a major brain malfunction so apologies for any email misuse I
just committed.

cprise

unread,
Feb 16, 2015, 5:11:48 PM2/16/15
to pake...@openmailbox.org, Qubes Users
I discovered on the Coreboot wiki, the X200s and X200 Tablet has GS45 chipset, not GM45:

http://www.coreboot.org/Board:lenovo/x200#X200S_and_X200_Tablet

And according to Intel, GS45 does support VT-d:

http://ark.intel.com/products/35505/Intel-82GS45-Graphics-and-Memory-Controller-Hub

(The regular X200 uses GM45. You can see the specs in this Lenovo psref p.128: http://www.lenovo.com/psref/pdf/psref354.pdf )

This appears to eliminate the CPU and chipset from being the cause of the problem. Maybe the BIOS does not support VT-d? Perhaps that feature was considered too new at the time to include support in firmware...

Which leads me to ask if maybe you are better off with Coreboot (query them first to see if they support VT-d). This is an interesting clue:
https://gitorious.org/gnutoo-for-coreboot/coreboot/commit/0da92863a754828eb807f1a15927f0dc288a1788


pake...@openmailbox.org

unread,
Feb 16, 2015, 6:55:43 PM2/16/15
to Qubes Users
To further clarify the situation as I was getting confused and longer
email above is slightly misleading.

As I stated Intel ARK lists (what I think is) my chipset as supporting
VT-d but does not mention VT-x.
Later chipsets (all used in Lenovo x201 Tablet) are listed as supporting
both VT-d and VT-x

But VT-x works on my machine and VT-d does not.
My CPU is listed as supporting VT-x but not VT-d.

I have not tested anti-evil maid capabilities




Reply all
Reply to author
Forward
Message has been deleted
0 new messages