If you change "sys-net" from Fedora to Debian template, will it break anything..?

90 views
Skip to first unread message

neilh...@gmail.com

unread,
Sep 22, 2016, 1:32:38 PM9/22/16
to qubes-users
I may need to change "sys-net" from the Fedora template VM, to the Debian template VM.

If I did this, would it break anything..? Or does it simply have to be Fedora..?

Thanks

Chris Laprise

unread,
Sep 22, 2016, 1:40:29 PM9/22/16
to neilh...@gmail.com, qubes-users
A number of us have been doing this for a while and it works fine.

Chris

neilh...@gmail.com

unread,
Sep 22, 2016, 2:12:44 PM9/22/16
to qubes-users, neilh...@gmail.com, tas...@openmailbox.org
Can I also ask

Is it true to say

"enp0s1" is the sys-net equivalent of "eth0"

and "wlp0s0" is the sys-net equivalent of "wlan0"

Thanks

jd.sch...@gmail.com

unread,
Sep 22, 2016, 8:04:37 PM9/22/16
to qubes-users
Those interface names come from systemd, which renames interfaces during boot based on their bus and location on that bus (which USB port, for example) from "eth0" to what you're seeing. You can think of them as effectively equivalent.

Jonathan

neilh...@gmail.com

unread,
Sep 22, 2016, 8:56:27 PM9/22/16
to qubes-users, jd.sch...@gmail.com
OK, now, I had real problems trying to switch to debian8.

I shut down sys-net and sys-firewall

Switched them both over to debian8

First thing, it said "Internet disconnected" in network manager, and simply wouldn't show any WiFi networks at all.

Second thing, it wouldn't even open the terminal for "sys-net".

So, this really did not work for me.

Chris Laprise, what did you do, other than shutting down VMs and changing to debian..?

Did you have to shut down sys-usb as well..?

Or do I have to do a bunch of other VMs or other stuff..?

This certainly didn't work smoothly for me at all. I've switched back over to Fedora just to type this.

Franz

unread,
Sep 22, 2016, 10:34:59 PM9/22/16
to neilh...@gmail.com, qubes-users, jd.sch...@gmail.com
for me it worked with no problem at all. Well I rebooted the computer immediately after the change because I always had problems restarting these sys VM without rebooting, independently from the distribution of the template.
Best
Fran
--
You received this message because you are subscribed to the Google Groups "qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users+unsubscribe@googlegroups.com.
To post to this group, send email to qubes...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/qubes-users/7bacb435-a9d7-466e-a4f3-30c21f7ee570%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

neilh...@gmail.com

unread,
Sep 22, 2016, 10:37:45 PM9/22/16
to qubes-users, neilh...@gmail.com, jd.sch...@gmail.com
Yeah, what actually happened to me, is that Ethernet DOES work just fine.

But WiFi doesn't.

So this is actually I think related to this issue:

https://github.com/QubesOS/qubes-issues/issues/1526

Wifi no longer recognised in Debian-based sys-net VM after 3.0 -> 3.1 upgrade

I have an Intel 3165 WiFi chip.

There is something where Debian in Qubes no longer works with WiFi or something. They say to downgrade to a lower kernel.. Errgh

neilh...@gmail.com

unread,
Sep 22, 2016, 11:22:59 PM9/22/16
to qubes-users, neilh...@gmail.com, jd.sch...@gmail.com
OK. You need to install the jessie-backports verison of the Intel driver in order for it to work in Debian 8.

See my post here where I solved it:

https://groups.google.com/forum/#!topic/qubes-users/BJRnCNcDtoo

Reply all
Reply to author
Forward
0 new messages