Trezor error with qubes

15 views
Skip to first unread message

taran1s

unread,
Aug 31, 2021, 10:54:20 AM8/31/21
to qubes-users
Hello,

In my last message I mentioned my attempts to start using the Trezor
with qubes.

I try to follow this guide, from the official trezor website:
https://wiki.trezor.io/Qubes_OS

I use the sys-usb based on debian-10 and tried the same with sys-usb
based on debian-10-minimal with similar error. My online AppVM in
anon-whonix.

After I finished the procedures described in the guide, I installed the
trezor Bridge and Udev rules in the sys-usb, and the Trezor Suite in the
anon-whonix, with sudo dpkg -i required-package.

Once I start both sys-usb and anon-whonix and attach the trezor-T I get
following error (suite is seen by the sys-usb):

2021-08-31T14:38:06.967Z - ERROR(process-trezord): Status error: request
to http://127.0.0.1:21325/ failed, reason: connect ECONNREFUSED
127.0.0.1:21325

Do you see any workarounds to make it work?

tetra...@danwin1210.me

unread,
Sep 4, 2021, 4:51:51 PM9/4/21
to taran1s, qubes-users
have you seen this?
https://github.com/Qubes-Community/Contents/blob/e7443c960228c1abec9b97f2c2027dbc01f45f63/docs/common-tasks/setup-trezor-cryptocurrency-hardware-wallet.md
>--
>You received this message because you are subscribed to the Google Groups "qubes-users" group.
>To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users...@googlegroups.com.
>To view this discussion on the web visit https://groups.google.com/d/msgid/qubes-users/753fdebf-f149-5ba4-8f24-f19802a0b525%40mailbox.org.

taran1s

unread,
Sep 5, 2021, 6:28:42 AM9/5/21
to tetra...@danwin1210.me, qubes-users
Actually I did do the process based on this guide. Everything is set up
except bridge verification. The issue is that once I download the bridge
from https://wallet.trezor.io/#/bridge I cannot verify it with gpg2
--verify It returns:

[user@fedora-33-min-trezor ~]$ gpg2 --verify
trezor-bridge-2.0.27-1.x86_64.rpm
gpg: no valid OpenPGP data found.
gpg: the signature could not be verified.
Please remember that the signature file (.sig or .asc)
should be the first file given on the command line.

If I try to use rpm directly, it returns this:

[user@fedora-33-min-trezor ~]$ sudo rpm -i trezor-bridge-2.0.27-1.x86_64.rpm
warning: trezor-bridge-2.0.27-1.x86_64.rpm: Header V4 RSA/SHA256
Signature, key ID b9a02a3d: NOKEY
package trezor-bridge-2.0.27-1.x86_64 does not verify: Header V4
RSA/SHA256 Signature, key ID b9a02a3d: NOKEY

Fedora min template has following packages installed: gnome-keyring
qubes-core-agent-nautilus qubes-mgmt-salt-vm-connector qubes-usb-proxy
and of course trezor-common

tetra...@danwin1210.me

unread,
Sep 25, 2021, 10:23:04 AM9/25/21
to taran1s, qubes...@googlegroups.com
Ah, I think I forgot to verify. You need to install the public key so
you can verify the trezor-bridge RPM file.

Unfortunately I don't remember how to do this.


On Fri, Sep 24, 2021 at 01:58:34PM +0000, taran1s wrote:
>Dear tetrahedra,
>
>I am just resending the email in case it didn't catch your attention
>last time.
>
>Could you please have a look at the issue and guide me a little? I
>tried everything but wasn't able to make it run.
>
>Thank you a ton!
>taran1s
>
>taran1s:
>--
>Kind regards
>taran1s
>
>gpg: 12DDA1FE5FB39C110F3D1FD5A664B90BD3BE59B3
Reply all
Reply to author
Forward
0 new messages