HCL - Surface Pro 3 (i5-4300U 4Gb)

1865 views
Skip to first unread message

Johannes Zipperer

unread,
Nov 19, 2016, 9:48:31 PM11/19/16
to qubes...@googlegroups.com
I tested Qubes 3.2 with the Fedora 24 template for about 5 hours intensely.

Installation: No problems during install. Bootable USB is only accepted
when the Secure Boot keys are removed (hit ESC or DEL during boot for
uefi). TPM Module seems not to be identified but I did put not much
effort into diagnosing the problem.

Connect wifi: After some trouble of finding the network manager in the
sys-net qube I successfully connected. Oddly the reception bars are red
while there is no issue using the web.

Whonix: Following the installation wiki for whonix it worked out of the
box to connect to the TOR network verified by check.torproject.org. I
was able to watch a youtube clip with smooth playback and with working
sound. HighDPI scaling has to be configured manually. The performance
concerning web browsing is not much worse from firefox from the
fedora-24 template.

Windows: using in dom0 the command qvm-start Windows-10
--cd-rom=fedora-24:/home/user/Downloads/Windows.iso was not successful.
So I gave up for now on that.

Touchscreen and stylus: both work out of the box. Stylus connected not
very reliably, but drawing lines and writing after that is fine.
Onscreen keyboard is missing and I didn't get florence to type anything.
Annotating PDFs works fairly well in Okular. Volume rocker and power button works out of the box

USB-Devices and microSD: Mounted a FAT formatted USB drive successfully. Cherry DW5000 works out of the box but media keys and super key need
configuring. I have no original type or touch cover to test. exFAT
microSD didn't work. But the same microSD card worked in the built-in
reader when formatted in NTFS (tested transfering and opening a JPG).
Using a USB hub with SD cardreader worked out of the box.

High DPI scaling: works generally well for touch control. Firefox opens
first time after restart with too big UI elements and text. Icons in
some applications like in Gimp are not scaled and kind of small. The
dom0 and template applications are generally not scaled.

Audio and Video: sound output works out of the box, playing mp3 in vlc
as well, mp4 in vlc in software decoding mode very choppy. youtube
videos are more fluid but no fullscreen support. streaming youtube
videos in vlc didn't work. Recording audio from the microphone with
pulsecaster works out of the box.

installing software: I was able to install and use vlc, Okular,
LibreOffice, Inkscape (bad stylus support), Gimp (better stylus
support), Thunderbird, Darktable, I changed the language and keyboard
layout to german sucessfully. Since I installed, tested and configured
everything in the template I have to say something about the use inside
a qube. I didn't test the pulsecaster, florence, Okular successfully in
the "personal" qube.

suspend reboot and shutdown: shutdown works, but is slow. device shows
black screen after suspending and wakes up when a key is pressed, but I
don't know if it really gets into the lower C states inbetween. reboot
does not work.

File manager: starting the file manager needs a second click in 50% of
the cases when I wanted to start it. Copying files works.

Performance and battery life: I assume that it is all rendered in
software, so considering that, I think the performance is decent, maybe
as a 1,3 GHz quad core Android phone regarding application start and tabbed browsing (sorry for the comparison =/). Battery life is lower
than under windows, I didn't find the brightness controls and the
brightness sensor did not work out of the box, so my battery life was
only around 3 hours.

Reverting back to windows: I successfully tested installing again Windows 10, which was previously tied to this device on a certain Microsoft account (important because of the license server, that works without keys). It was installed by a USB stick previously formatted by the media creation tool. The risk is not so high to try Qubes, although I recommend getting accustomed before using it in production. I hope this helps others.

Life is good, Jesus is better!
Johannes
Qubes-HCL-Microsoft_Corporation-Surface_Pro_3-20161119-225602.cpio.gz
Qubes-HCL-Microsoft_Corporation-Surface_Pro_3-20161119-225602.yml

gawe...@gmail.com

unread,
Apr 7, 2017, 12:22:25 PM4/7/17
to qubes-users, z1...@mailbox.org

Thank you for your efforts. I've been attempting to install Qubes 3.2 on a Surface Pro 4, but I've been unable to get past EFI errors. I'm hoping you can help me.

First of all, I downloaded and verified the 3.2 ISO. Following the qubes install guide I used Rufus to transfer the iso to a usb stick. I selected the iso, set the partition scheme to GPT for UEFI, the File system to Fat32, and finally selected dd image to create the bootable disk.

On the Surface Pro 4, I entered into the UEFI menu and disabled Secure Boot (None), and prioritized USB Storage in the boot order. I then attached the bootable usb device and restarted the machine.

The Surface Pro loads into the grub menu - but fails to install the image. During "Test the media and install Qubes" and "Install Qubes" (approx wording) the process stalls at a screen with 4 penguins and the message: "EFI_MEMMAP is not enabled". Qubes site has a troubleshooting guide for UEFI, which I followed. The suggestion to edit the "Troubleshoot" grub entry and add "/noexitboot /mapbs" at the end of the chainloader line did not resolve my problem. Further investigations online was unfruitful.

My hope is that I may have simply missed a critical step when building the boot image usb stick. Perhaps I need to use a different partition scheme or file system? Did you use Rufus to install Qubes on the Surface Pro 3? What settings did you use? From your writeup, it doesn't sound like you encountered any of the issues I'm having, but then they are different machines. Do you have any suggestions? I appreciate anything you can share. Have great day!

ludwig jaffe

unread,
Apr 8, 2017, 4:43:36 PM4/8/17
to qubes-users, z1...@mailbox.org

Nice, but what do you do with only 4GB of RAM.
Qubes is a RAM eater, my old workstation got pimped with 40GB of RAM
and is now nice to use.
I started with 8GB which it had in the beginning before installing Qubes
and decided to go for 4 bars of 8GB, as 8GB is not useable at all if one has more then 2 or three machines running at a time.
So a M$ surface is the wrong machine as the memory can not be extended, as
I guess. How to open that thing an plug more RAM?

Qubes is an evil memory eating paranoid system ;-)

jimmy....@gmail.com

unread,
Apr 8, 2017, 8:48:22 PM4/8/17
to qubes-users, z1...@mailbox.org
On Saturday, November 19, 2016 at 9:48:31 PM UTC-5, Johannes Zipperer wrote:
> I tested Qubes 3.2 with the Fedora 24 template for about 5 hours intensely.

I have been using Qubes 3.2 for about two months on a Surface Pro 2 (8GB RAM.) Most of my observations have been in line with yours. Overall, it works quite well and has become my full-time portable setup. Nice to see someone else trying Qubes on Surface Pro!

Johannes Zipperer

unread,
Apr 9, 2017, 1:27:03 AM4/9/17
to gawe...@gmail.com, qubes-users
Hi to all,

@gawehner: it has been some time now since I did that crazy thing with the surface pro, so my memory is not fresh about how I did it.

But I remember using Unetbootin, Rufus and in some cases the linux tool dd at the time. I didn't worry about file system.
But try the ISO and DD method. Otherwise I used the standard options for starting the USB Stick.

I hope you succeed. As long as you keep the VMs to a minimum it is quite fun to use. Even with 4 Gb ;-p
--
Johannes Zipperer
📬 Kolpingstr. 46
73732 Esslingen
📱 017696615686


lamhu...@gmail.com

unread,
Apr 26, 2017, 4:54:50 PM4/26/17
to qubes-users, z1...@mailbox.org

Could you describe how you got Qubes to install on your Surface Pro 2? I'm having the same booting problems as the poster above (installer stalls at 4 penguins screen with "EFI_MEMMAP is not enabled" etc. message).

I followed the instructions from the Qubes website, using Rufus and dd mode to prepare the bootable USB but not working so far.

Help?!

seans...@gmail.com

unread,
May 3, 2017, 10:54:50 AM5/3/17
to qubes-users
I got Qubesos 3.2 installed on my Surface Pro 3, however the newer touch cover (the one made for the pro 4,but works on pro 3) doesn't work out of the box and as such I can't type anything, nor login, since the on-screen keyboard doesn't come up either. Any guidance on this?

Eric Duncan

unread,
Jun 8, 2017, 3:51:11 AM6/8/17
to qubes-users, seans...@gmail.com
On Wednesday, May 3, 2017 at 10:54:50 AM UTC-4, seans...@gmail.com wrote:
> I got Qubesos 3.2 installed on my Surface Pro 3, however the newer touch cover (the one made for the pro 4,but works on pro 3) doesn't work out of the box and as such I can't type anything, nor login, since the on-screen keyboard doesn't come up either. Any guidance on this?

Maybe related, but the Type Cover for the Surface 3 (non-Pro) has to be kernel-patched and recompiled to enable. Back when the Surface Pro 3 first came out, the same kernel-patching had to be done to enable the type cover.

A quick search found this Surface Pro 4 Type Cover kernel patch: https://ubuntuforums.org/showthread.php?t=2300868

anguil...@gmail.com

unread,
Aug 28, 2017, 11:38:43 PM8/28/17
to qubes-users, z1...@mailbox.org

I just tried installing Qubes 4 RC and it looks like VT is not enabled on my SP3 on first boot after installation. In the EFI settings, I don't see a way to enable it either.

How did you get past this? XEN just gives me a CPU 0 error. Any idea how to enable VT?

Johannes Zipperer

unread,
Sep 1, 2017, 7:08:50 PM9/1/17
to anguil...@gmail.com, qubes-users

Hi Anguilla1980,
now after some time I question my attempt to install Qubes, which relies on GPU passtrough and lots of RAM, on a Surface Pro with just an IGP. This is what I suppose: Since this is a not common use case for Xen it denies its service. See the latest changelog from Xen. https://lists.gt.net/xen/changelog/489651?page=last
If you like to go ahead, wait for the Qubes 4.0 final. It will probably include this upstream fix for your problem.
By the way, I did the install as well successfully using rufus and a microSD. The Boot manager correctly chooses the microSD OS by default. But I get the same error as you do.

Alex Claytor

unread,
Sep 1, 2017, 7:33:56 PM9/1/17
to Johannes Zipperer, qubes-users

Thanks for the info. I was able to install 3.2 no problem I’m sure you are correct. I'll wait then to give 4 another try until the final release. I was only going to use my SP3 to check out 4 anyway, I have another machine which is currently my full time 3.2 laptop.

 

Thanks!

tibor....@gmail.com

unread,
May 10, 2019, 2:24:37 PM5/10/19
to qubes-users
Thanks for info and your time.

Question:
Should I go with Surface Pro 6?

Intel Core i5-8250U
Intel UHD Graphics 620

sbh2...@gmail.com

unread,
Sep 17, 2019, 1:02:14 AM9/17/19
to qubes-users
Installed 4.0.1 to a surface pro 6. Used rufus to load a 'dd' file instead of the default. Set up a simple "black" partition using Windows "computer management" console. Had upgraded os to win pro. Had to deal with bitdefender before shutting off windows defaults in the UEFI.

The Qubes installation went straight in with a default install. Wifi worked. Firefox worked. Updates worked. Does anyone know how to get the text to show in a larger font? Also, if your wifi is cut off by your provider, you get to reboot.

This the most straightforward install I have ever done with Linux in 25 years.

Reply all
Reply to author
Forward
0 new messages