HCL - Razer Blade Stealth (Late 2016 Model)

645 views
Skip to first unread message

Krasi

unread,
Dec 14, 2016, 5:03:48 PM12/14/16
to qubes-users
I have tested Qubes Release 3.2 on Razer Blade Stealth (no model number). Here are some details other then the HCL report.

Installation and BIOS/UEFI:

I had to disable secure boot in the firmware before my USB stick would boot.

I was able to install in UEFI mode only, in legacy mode I had some problems with the graphics and Qubes would load the text installer which was unable to partition drives with encryption.

Graphics and resolution:

First book was good but the resolution was only 800x600, had to update kernel to 4.8 and then edit the xen.cfg file inside the EFI system partition. The kernel boot files had to be copied from /boot to the EFI partition under the qubes directory to force it to use the 4.8 kernel but after that the graphics work great and the sound got fixed.

LAN/WLAN:

Was unable to test LAN, no LAN port but wifi was broken initially, had to use a USB adapter to update the kernel, after the update wifi is working correctly.


Webcam:

Not working, the device is not found by cheese.

Sound:
Sounds appears to be working, have not testes the microphone but the speakers are working.

Trackpad:
Its working but you cannot mouse click without physically pressing the pad. I am guessing gestures are not working.

Keyboard:
Everything appears to be working, backlight is on, and the function (FN) keys are working, can change volume and so on...

Suspend/sleep/poweroff:
Suspending/sleeping when the lid is closed appears to be broken, when I open the laptop I can see the keyboard light-up but the screen in black. No problem rebooting and turning off.


Summary:
Most things work with the new kernel (4.8), camera is not working and the sleep/suspend function are broken.


Let me know if you have any questions :) I should be getting updates from this post.

Qubes-HCL-Razer-Blade_Stealth-20161214-110949.yml

rtia...@gmail.com

unread,
Dec 14, 2016, 5:09:07 PM12/14/16
to qubes-users
On Wednesday, December 14, 2016 at 3:03:48 PM UTC-7, Krasi wrote:
>
> Trackpad:
> Its working but you cannot mouse click without physically pressing the pad. I am guessing gestures are not working.
>


Make sure to double-check the Mouse and Trackpad system settings. I don't know about gesture support, but there was a box I had to enable under the Touchpad section labeled "Tap touchpad to click" before tapping to click worked.

Krasi

unread,
Dec 14, 2016, 5:19:29 PM12/14/16
to qubes-users, rtia...@gmail.com


Awesome, that fixed it :) Thank you

Guerlan

unread,
Nov 16, 2017, 9:42:11 PM11/16/17
to qubes-users
How did you install in UEFI mode? Mine will show a terminal with some text for less than 1 second and turn back to the installation menu. Secure boot is disabled. The far I get is the first menu that appears
Reply all
Reply to author
Forward
0 new messages