HCL submission : Dell Precision 5510

149 views
Skip to first unread message

Tomas Vondra

unread,
Nov 26, 2016, 4:03:23 PM11/26/16
to qubes...@googlegroups.com
Hi,

I've just installed Qubes 3.2 on a new Dell Precision 5510 laptop, and
it seems to be working fine. I've just had to disable secure boot and
UEFI, then it went smoothly. The touchpad did not work in the installer,
but after that it works OK. I've also had to disable wake on USB-C, to
make suspend work.

regards
Tomas
Qubes-HCL-Dell_Inc_-Precision_5510-20161126-214715.yml

Brian Skinner

unread,
Nov 29, 2016, 12:10:26 AM11/29/16
to qubes-users, t...@fuzzy.cz
On Saturday, November 26, 2016 at 1:03:23 PM UTC-8, Tomas Vondra wrote:
> Qubes 3.2 on a new Dell Precision 5510 ... seems to be working fine

Hi Tomas,

Thank you for posting your HCL report. I'm planning to buy a Dell 5510 laptop soon and it's great to have some reassurance that Qubes 3.2 will run smoothly on it!

Did you get your laptop with the PCIe NVMe drive? I've heard that those drives can be a problem for some Linux installations, so I'm hoping you can reassure me on that too.

How has the battery life been for you with the Dell Precision 5510? I'll be curious to see how the battery life compares when running Qubes 3.2 vs. Ubuntu 16.04 vs. Windows.

Thanks,
Brian


Tomas Vondra

unread,
Nov 29, 2016, 5:54:21 AM11/29/16
to Brian Skinner, qubes-users


Dne 11/29/2016 v 06:10 AM Brian Skinner napsal(a):
> On Saturday, November 26, 2016 at 1:03:23 PM UTC-8, Tomas Vondra wrote:
>> Qubes 3.2 on a new Dell Precision 5510 ... seems to be working fine
>
> Hi Tomas,
>
> Thank you for posting your HCL report. I'm planning to buy a Dell 5510 laptop soon and it's great to have some reassurance that Qubes 3.2 will run smoothly on it!
>
> Did you get your laptop with the PCIe NVMe drive? I've heard that those drives can be a problem for some Linux installations, so I'm hoping you can reassure me on that too.

Yes, I have the NVMe drive, and it seems to be working fine. I suspect
it might be related to the UEFI issues (unable to boot from NVMe or
something), but I might bee wrong. In any case, it works for me.

>
> How has the battery life been for you with the Dell Precision 5510? I'll be curious to see how the battery life compares when running Qubes 3.2 vs. Ubuntu 16.04 vs. Windows.
>

No idea, I only really have the laptop since saturday, so a bit early to
judge. In any case, I generally see ~6h estimae in the panel, with the
6-cell battery.

regards
Tomas

Brian Skinner

unread,
Nov 29, 2016, 12:04:46 PM11/29/16
to qubes-users, brian....@skinnerhome.org, t...@fuzzy.cz
> >> Qubes 3.2 on a new Dell Precision 5510 ... seems to be working fine
>
> Yes, I have the NVMe drive, and it seems to be working fine.

Great! Thanks for the info. I'll go ahead with my own order from Dell now.


> > How has the battery life been for you with the Dell Precision 5510?
>

> No idea, I only really have the laptop since saturday, so a bit early to
> judge. In any case, I generally see ~6h estimae in the panel, with the
> 6-cell battery.

A 6h estimate sounds good. That's an encouraging sign.

Thanks for sharing your experiences.

:o) Brian


rosselet...@gmail.com

unread,
Nov 23, 2017, 12:27:15 PM11/23/17
to qubes-users
Hello Tomas,

Did you try to use your USB-C connector ?

I can't use it with my ethernet adaptor and neither with my Hub : I don't see my devices...
Rdgs,

Laurent

mtmor...@gmail.com

unread,
Feb 16, 2018, 4:20:58 PM2/16/18
to qubes-users
Has anyone been able to get the USB-C Ethernet adapter working on the Precision 5510, either with the small dongle, or the Lightning Dock?

Thanks
Mike

Reply all
Reply to author
Forward
0 new messages