HCL - Lenovo Y50-70

162 views
Skip to first unread message

Thia Tosini

unread,
Jun 3, 2016, 9:26:33 PM6/3/16
to qubes...@googlegroups.com
I have successfully installed Qubes on my Lenovo Y50-70
Working: Display, HDMI, Intel graphics, HVMs, Ethernet, Wi-Fi, USB mass storage, audio output, trackpad, keyboard
Untested: Bluetooth, Audio input, card reader, camera
Broken: Nvidia graphics (I have thus disabled it in the BIOS), UEFI booting

Since Qubes HiDPI support is poor and I have the 4K version of the laptop, I generally run:
xrandr --output eDP1 --scale .5x.5 --right-of HDMI1
which also sets up my external HDMI monitor.

Thia
Qubes-HCL-LENOVO-20378-20160603-202829.yml

bobby.the.j...@gmail.com

unread,
Jun 28, 2016, 3:01:09 PM6/28/16
to qubes-users
does the nvidia display work with qubes 3.2?

from what i gather it should due to the newer linux hernel.

so far its the only reasonably priced qubes compatable 4k, 16gb, backlit kb, 15" laptop i found yet even without tpm

cant find a 17" the w450, p50, p70 are over $2k easy

the big risk with the y50-70 is bad reviews with build quality there were more than a few bad batches aparently thus at worst i may have to return one before i get another

george...@gmail.com

unread,
Jul 14, 2016, 12:23:39 AM7/14/16
to qubes-users, m...@thia.re
Thia:

Can you list the steps that you used to accomplish this? I also have a Y50-70 and I get the initial splash screen, I get error messages in regards to the pane, and then it just hangs until I press the power button.

Thanks,

George

Thia

unread,
Jul 14, 2016, 1:44:24 AM7/14/16
to george...@gmail.com, qubes-users
I can't mess around with my computer right now, so I will just say what I remember from o while ago and hopefully that is helpful:

Try disabling UEFI boot (or at least boot the drive in legacy mode). I think I needed to do this for it to work properly
Boot the installer from a flash drive, not a DVD
Try with different USB ports. I have noticed weird things with USB booting, especially when using a hub.

I hope you can get it working. I will try 3.2 when I have time and may report on that.
--
Thia
Sent from my Android device with K-9 Mail. Please excuse my brevity.

george...@gmail.com

unread,
Jul 15, 2016, 10:01:02 PM7/15/16
to qubes-users
Thanks! I got it to work with 3.1 RC2. However, I got it to work via legacy USB boot. Whenever I tried UEFI I never got the Qubes installer splash screen so I went back to legacy boot support and did a legacy USB boot and it worked.

Now, those pesky 4K optimizations. Fedora is beast at 4K, wish they could copy that functionality in regard to the display.

And then I'll look at the WLAN card, etc.

george...@gmail.com

unread,
Jul 20, 2016, 10:41:28 PM7/20/16
to qubes-users, m...@thia.re
On Friday, June 3, 2016 at 9:26:33 PM UTC-4, Thia Tosini wrote:

Thia:

https://groups.google.com/forum/#!msg/qubes-users/GQOLttJeJTg/wa29hJEaBAAJ

Works within the AppVMs on our HiDPI displays. Fortunately, Qubes Team is working on addressing HiDPI.

Reply all
Reply to author
Forward
0 new messages