HCL - Asus Laptop F556UA-UH71 i7-7500U Intel HD 620

348 views
Skip to first unread message

Mike Freemon

unread,
Apr 29, 2017, 6:37:00 PM4/29/17
to qubes...@googlegroups.com
Hello,

I'm a big fan of Qubes.  Keep up the excellent work.

My initial contribution to the cause is this HCL.

Qubes is working great on the titular laptop, but there were some challenges to overcome during installation.

1.  UEFI.  Installing from USB.  I found that I had to disable CSM and select boot partition 1 to get the installation media to boot.

2.  Touchpad.  The touchpad was not working.  To install with a USB mouse, I set qubes.InputMouse to pass mouse events to Dom0.  Of course, the USB mouse only works when sys-usb is running.

3.  Wireless.  I had to get the wireless working by using nmcli commands (e.g. nmcli device wifi connect <ssid>).  I should add that some of this was when I was trying to install via text only, which requires a little more background info:  My initial install attempts were from legacy booting, which failed to launch the graphical interface.  I tried to continue with the installation via the text interface, which I never did get working.  That's when I went back to step 1 and got it working via UEFI / partition 1 with CSM disabled.

4.  Display Resolution.  The display was only 800x600.

The short version:  The display issues were caused by using a kernel that is "too old" (for this hardware).

This hardware requires kernel 4.8.12 (to be more precise, all I can say at the moment is that the minimum kernel version for this hardware is > 4.4.55 and <= 4.8.12).

Kernel 4.8.12 is only available from the unstable repository, so I had to get Qubes installed in a "degraded" way before I could issue the magic command:

> qubes-dom0-update --enablerepo=qubes-dom0-unstable kernel kernel-qubes-vm

- Mike


Sent with ProtonMail Secure Email.

Qubes-HCL-ASUSTeK_COMPUTER_INC_-X556UAK-20170429-162956.yml

Mike Freemon

unread,
May 15, 2017, 1:33:21 AM5/15/17
to qubes...@googlegroups.com
A quick follow up on this hardware.

I found that the wireless NIC failed to work after suspend/resume.

The hardware is: Qualcomm Atheros QCA9377 802.11ac Wireless Network
Adapter (rev 31)

There are several reports of this hardware having problems with
suspend/resume.

https://bugs.archlinux.org/task/53389?project=5&cat=

https://forums.kali.org/showthread.php?31444-No-wireless-connection-after-sleep-suspend

http://jfcarter.net/~jimc/hardware/acer-e5-573g/setup.shtml

On this last one, the following is mentioned: "Update: S3 becomes
reliable if you leave it asleep or awake for at least 5 mins between
state transitions." This is potentially interesting (as a diagnostic
test, not as a solution). I have not confirmed this myself.

As will come as no surprise to readers of this list, unloading/reloading
the kernel module did work around the problem. Described here:

https://www.qubes-os.org/doc/wireless-troubleshooting/

In my case, the drivers to include in suspend-module-blacklist are:

ath10k_pci
ath10k_core
ath

Note: I also tried disabling VT-d as a test, which did not change/fix
anything in my case.



Mike Freemon

unread,
May 20, 2017, 2:47:19 PM5/20/17
to qubes...@googlegroups.com
On 04/29/2017 05:36 PM, 'Mike Freemon' via qubes-users wrote:
Reply all
Reply to author
Forward
0 new messages