Intel i7-1065G7 (10 Generation Support) - APIC Patches

219 views
Skip to first unread message

Dylanger Daly

unread,
Dec 11, 2019, 11:24:09 PM12/11/19
to qubes-devel
Hi Guys,


I'm trying to get Qubes 4.0.1RC2 running on a Surface Laptop 3, however I appear to be getting the error

IO-APIC + timer doesn't work! Boot with apic_verbosity=debug and send a report. Then try booting with the 'noapic' option


When adding 'noapic' to the options line (Not CMDLINE) I can see it try to bring up dom0, then I think it resets and hangs at the OEM UEFI Logo, I think this has something to do with the fact that Xen 4.8 doesn't support the 10th Gen Intel CPU (Perhaps the ACPI Tables for the 10th Gen Intel specifically)

I also think the APIC is related to the IOMMU and must be enabled to run Qubes / Xen.

Fedora 31 boots perfectly with the APIC Enabled, however it appears to be something specific to Xen, I can see past patches to support AMD's APIC (https://github.com/QubesOS/qubes-vmm-xen/blob/a4fc8004dd903e60f37db7b20caf1b95993b0a46/patch-xen-AMD-IOMMU-Support-IOAPIC-IDs-larger-than-128.patch)

So I think I just need to add support/patches for Intel's latest 10th Gen (i7-1065G7 Specifically) APIC.

Any help with this would be greatly appreciated.

Dylanger Daly

unread,
Dec 12, 2019, 12:34:27 AM12/12/19
to qubes-devel
So I managed to get a little more info out of Xen during boot

Enabling IO-APIC IRQs
...
MP
-BIOS bug: 8254 timer not connected to IO-APIC
... trying to set up timer (IRQ0) through the 8259A ... failed.
... trying to set up timer as Virtual Wire IRQ ... failed.
... trying to set up timer as ExtINT IRQ...spurious 8259A interrupt: IRQ7.
CPU0
: No irq handler for vector e7 (IRQ -8)

K. L

unread,
Jan 25, 2020, 5:28:29 PM1/25/20
to qubes-devel
Hi, so i don't have anymore information to help you, but i do have the same issue with the last dell xps 13 7390, i7 1051OU inside, it is impossible to boot, i tried noapic, nolapic and quite few more testing. So i am wondering, is it the 10th generation cpus not compatible with Qubes yet ? And can we hope to get some support for it in the futur ?

Choosing a good laptop that  support qubes is hard, no nvidia or high end gpu support makes it impossible to find a good recent 15" laptop, and now it looks like the support for latest cpus is also an issue. I really hope this will get solved cause i fell in love with this OS and not being able to use it is just frustrating.

My message is not helpful but i just want to generate some activity around this so maybe someone would come up with a answer/solution.

Marek Marczykowski-Górecki

unread,
Jan 25, 2020, 5:31:59 PM1/25/20
to K. L, qubes-devel
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
You can try booting development builds of Qubes 4.1, which include much
newer Xen version (4.13). Here is the latest one:
https://openqa.qubes-os.org/tests/5493/asset/iso/Qubes-4.1-20200113-x86_64.iso

- --
Best Regards,
Marek Marczykowski-Górecki
Invisible Things Lab
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEhrpukzGPukRmQqkK24/THMrX1ywFAl4swdcACgkQ24/THMrX
1yx2fAf/TlV/sSrzsqOoIZq/utlae7lefrbooU+wkee5xElrvneRMZPwZCBO+9Sz
T/9Pf60xHItEIUaVvoCXdPdAPW76l0FS3cdtTEis62c9ux2sat/b7imTszSsGvKh
SdkIXPl5dvySJQ5HMHZpjqWWzqTgE+b1cwZvtPo3ItDxBdXLpsOBEkO6mBrOWVl7
pse6W9wzHie0A0MH0Liq4novh1ur4+LJmnDGuHp4LUYy2+3YCKSMUY8NBVFjjAhX
x6GqdFpELcf61iz8UEu8DELF7SLgQMdYqUhTCREMg1SrrUzt+mM1my9hMrrzuIbF
TRQ7EMNR5hWjdTf5yCEIO4uMlzRvnA==
=/W7p
-----END PGP SIGNATURE-----

K. L

unread,
Jan 26, 2020, 7:40:44 AM1/26/20
to qubes-devel
So just to give some feedback, using the 4.1 development builds did the trick, i was able to boot the installer but i laways got some errors, after 3 rows i was able to install qubes, too bad that the 4.1 is unusable for now but as a proof of concept i find it reassuring. Also to avoid apic timer errors i had no choice but to disable sleep (S3) in the bios. Lets see if the 4.1 stable will solve that too.

Last thing that worries me is that running qubes on an ultrabook is maybe not the best idea, the worst part is that dell choosed to let the fan kick in only at the very last time so when the machine is very hot with the cpu around 90C.
Reply all
Reply to author
Forward
0 new messages