GraalVM with Java 17 - A few issues in our QuickStarts

28 views
Skip to first unread message

clement escoffier

unread,
Nov 15, 2021, 6:13:47 AM11/15/21
to Quarkus Development mailing list

Hello,


I’ve tried to build all our QuickStarts with Java 17 and the Java 17 support from GraalVM 21.3.0.

There are a few failures that would need to be investigated. The most impacting one is a PostgreSQL JDBC issue. Another one seems to be a Mac OS issue (related to sun.lwawt.macosx.CInputMethod), but it would need verification from another OS.


You can find the whole set of issues using:

https://github.com/quarkusio/quarkus-quickstarts/issues?q=is%3Aissue+is%3Aopen+%5BGraalVM+21.3.0.r17%5D


While these issues are reported in the QuickStart repo, most of them will need to be fixed in Quarkus Core, Kogito, or Optaplanner repositories.


Clement

Reply all
Reply to author
Forward
0 new messages