usearch error

38 views
Skip to first unread message

SG

unread,
Oct 18, 2016, 5:47:39 AM10/18/16
to Qiime 1 Forum
Hi,
i am trying to install usearch and after installation i got an error.



shashank@shashank-HP-Z620-Workstation:~$  identify_chimeric_seqs.py -i Output_SplitQC/seqs.fna -m usearch61 -o usearch_checked_chimeras/ -r ~/gg_13_8_otus/rep_set/97_otus.fasta
Traceback (most recent call last):
  File "/home/shashank/anaconda2/bin/identify_chimeric_seqs.py", line 354, in <module>
    main()
  File "/home/shashank/anaconda2/bin/identify_chimeric_seqs.py", line 350, in main
    threads=threads)
  File "/home/shashank/anaconda2/lib/python2.7/site-packages/qiime/identify_chimeric_seqs.py", line 774, in usearch61_chimera_check
    log_lines, verbose, threads)
  File "/home/shashank/anaconda2/lib/python2.7/site-packages/qiime/identify_chimeric_seqs.py", line 891, in identify_chimeras_usearch61
    consout_filepath=output_consensus_fp)
  File "/home/shashank/.local/lib/python2.7/site-packages/bfillings/usearch.py", line 2280, in usearch61_smallmem_cluster
    app_result = app()
  File "/home/shashank/.local/lib/python2.7/site-packages/burrito/util.py", line 285, in __call__
    'StdErr:\n%s\n' % open(errfile).read())
burrito.util.ApplicationError: Unacceptable application exit status: 1
Command:
cd "/home/shashank/Desktop/Pedigree_Data/D_2016_07_20_01_55_03_flxpluspc_signalProcessingLongAmplicons1_LA1/sff/J34EUJL01/usearch_checked_chimeras/"; usearch61 --maxaccepts 1 --consout "/home/shashank/Desktop/Pedigree_Data/D_2016_07_20_01_55_03_flxpluspc_signalProcessingLongAmplicons1_LA1/sff/J34EUJL01/usearch_checked_chimeras/seqs.fna_consensus_with_abundance.fasta" --usersort --id 0.97 --sizeout --minseqlength 64 --wordlength 8 --uc "/home/shashank/Desktop/Pedigree_Data/D_2016_07_20_01_55_03_flxpluspc_signalProcessingLongAmplicons1_LA1/sff/J34EUJL01/usearch_checked_chimeras/seqs.fna_consensus_with_abundance.uc" --cluster_smallmem "/home/shashank/Desktop/Pedigree_Data/D_2016_07_20_01_55_03_flxpluspc_signalProcessingLongAmplicons1_LA1/sff/J34EUJL01/Output_SplitQC/seqs.fna" --maxrejects 8 --strand plus --log "/home/shashank/Desktop/Pedigree_Data/D_2016_07_20_01_55_03_flxpluspc_signalProcessingLongAmplicons1_LA1/sff/J34EUJL01/usearch_checked_chimeras/seqs.fna_smallmem_clustered.log" > "/tmp/tmpyt0lmVwYndHphFGbu3Wc.txt" 2> "/tmp/tmpGMCzTH1EPGSd4FJSznMz.txt"
StdOut:

StdErr:

Invalid command line
Option --minseqlength is invalid
For list of command-line options use --help.


FYI

shashank@shashank-HP-Z620-Workstation:~$ print_qiime_config.py -t

System information
==================
         Platform:    linux2
   Python version:    2.7.12 |Anaconda custom (64-bit)| (default, Jul  2 2016, 17:42:40)  [GCC 4.4.7 20120313 (Red Hat 4.4.7-1)]
Python executable:    /home/shashank/anaconda2/bin/python

QIIME default reference information
===================================
For details on what files are used as QIIME's default references, see here:
 https://github.com/biocore/qiime-default-reference/releases/tag/0.1.3

Dependency versions
===================
          QIIME library version:    1.9.1
           QIIME script version:    1.9.1
qiime-default-reference version:    0.1.3
                  NumPy version:    1.11.1
                  SciPy version:    0.18.0
                 pandas version:    0.18.1
             matplotlib version:    1.4.3
            biom-format version:    2.1.5
                   h5py version:    2.6.0 (HDF5 version: 1.8.17)
                   qcli version:    0.1.1
                   pyqi version:    0.3.2
             scikit-bio version:    0.2.3
                 PyNAST version:    1.2.2
                Emperor version:    0.9.51
                burrito version:    0.9.1
       burrito-fillings version:    0.1.1
              sortmerna version:    SortMeRNA version 2.0, 29/11/2014
              sumaclust version:    SUMACLUST Version 1.0.00
                  swarm version:    Swarm 1.2.19 [May 26 2016 19:59:57]
                          gdata:    Installed.

QIIME config values
===================
For definitions of these settings and to learn how to configure QIIME, see here:
 http://qiime.org/install/qiime_config.html
 http://qiime.org/tutorials/parallel_qiime.html

                     blastmat_dir:    None
      pick_otus_reference_seqs_fp:    /home/shashank/.local/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/rep_set/97_otus.fasta
                         sc_queue:    all.q
      topiaryexplorer_project_dir:    None
     pynast_template_alignment_fp:    /home/shashank/.local/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/rep_set_aligned/85_otus.pynast.fasta
                  cluster_jobs_fp:    start_parallel_jobs.py
pynast_template_alignment_blastdb:    None
assign_taxonomy_reference_seqs_fp:    /home/shashank/.local/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/rep_set/97_otus.fasta
                     torque_queue:    friendlyq
                    jobs_to_start:    1
                       slurm_time:    None
            denoiser_min_per_core:    50
assign_taxonomy_id_to_taxonomy_fp:    /home/shashank/.local/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/taxonomy/97_otu_taxonomy.txt
                         temp_dir:    /tmp/
                     slurm_memory:    None
                      slurm_queue:    None
                      blastall_fp:    blastall
                 seconds_to_sleep:    1

QIIME base install test results
===============================
.........
----------------------------------------------------------------------
Ran 9 tests in 0.018s

OK

shashank@shashank-HP-Z620-Workstation:~$ which usearch
/home/shashank/anaconda2/usearch/usearch

shashank@shashank-HP-Z620-Workstation:~$ usearch --version
usearch v5.2.236

shashank@shashank-HP-Z620-Workstation:~$ which uclust
/home/shashank/anaconda2/bin/uclust

shashank@shashank-HP-Z620-Workstation:~$ uclust --version
uclust v1.2.22q

Any suggestion ?

SG

Jamie Morton

unread,
Oct 18, 2016, 1:43:07 PM10/18/16
to Qiime 1 Forum
Hmm.  It looks like you are trying to use an outdated version of usearch.  From here, it looks like that option is enabled in a newer version of usearch.

So, I'd try installing a newer version of usearch to see if that problem disappears.

Best,
Jamie

SG

unread,
Oct 18, 2016, 11:42:35 PM10/18/16
to Qiime 1 Forum
Hi,
yes, it works now.

Newer version works i.e. usearch_i86linux32 v6.1.544

Thanks.
Reply all
Reply to author
Forward
0 new messages