How to install QIIME in a Centos based HPC

42 views
Skip to first unread message

Carlos Lijeron

unread,
Jul 28, 2016, 6:15:28 PM7/28/16
to Qiime 1 Forum
Everyone,

I'm trying to install QIIME 1.9 in a CENTOS 6.5 based cluster, but keep getting errors with MatPlotLib.  Has anyone encountered this before and was able to resolve it ?  Please advise.

INSTALLING QIIME USING PIP



[root@compute011 ~]# pip install qiime

Collecting numpy>=1.9.0 (from qiime)

  Using cached numpy-1.11.1.zip

Collecting scipy>=0.14.0 (from qiime)

  Using cached scipy-0.18.0.tar.gz

Collecting cogent==1.5.3 (from qiime)

  Using cached cogent-1.5.3.tgz

Collecting natsort<4.0.0 (from qiime)

  Using cached natsort-3.5.6-py2.py3-none-any.whl

Collecting matplotlib!=1.4.2,>=1.1.0 (from qiime)

  Using cached matplotlib-1.5.1.tar.gz

    Complete output from command python setup.py egg_info:

    ============================================================================

    Edit setup.cfg to change the build options

    

    BUILDING MATPLOTLIB

                matplotlib: yes [1.5.1]

                    python: yes [2.6.6 (r266:84292, Jan 22 2014, 09:42:36)  [GCC

                            4.4.7 20120313 (Red Hat 4.4.7-4)]]

                  platform: yes [linux2]

    

    REQUIRED DEPENDENCIES AND EXTENSIONS

                     numpy: yes [version 1.7.1]

                  dateutil: yes [using dateutil version 1.4.1]

                      pytz: yes [using pytz version 2010h]

                    cycler: yes [cycler was not found. pip will attempt to

                            install it after matplotlib.]

                   tornado: yes [tornado was not found. It is required for the

                            WebAgg backend. pip/easy_install may attempt to

                            install it after matplotlib.]

                 pyparsing: yes [pyparsing was not found. It is required for

                            mathtext support. pip/easy_install may attempt to

                            install it after matplotlib.]

                    libagg: yes [pkg-config information for 'libagg' could not

                            be found. Using local copy.]

                  freetype: no  [The C/C++ header for freetype2 (ft2build.h)

                            could not be found.  You may need to install the

                            development package.]

                       png: no  [pkg-config information for 'libpng' could not

                            be found.]

                     qhull: yes [pkg-config information for 'qhull' could not be

                            found. Using local copy.]

    

    OPTIONAL SUBPACKAGES

               sample_data: yes [installing]

                  toolkits: yes [installing]

                     tests: yes [nose 0.11.1 or later is required to run the

                            matplotlib test suite. Please install it with pip or

                            your preferred tool to run the test suite / mock is

                            required to run the matplotlib test suite. Please

                            install it with pip or your preferred tool to run

                            the test suite]

            toolkits_tests: yes [nose 0.11.1 or later is required to run the

                            matplotlib test suite. Please install it with pip or

                            your preferred tool to run the test suite / mock is

                            required to run the matplotlib test suite. Please

                            install it with pip or your preferred tool to run

                            the test suite]

    

    OPTIONAL BACKEND EXTENSIONS

                    macosx: no  [Mac OS-X only]

                    qt5agg: no  [PyQt5 not found]

                    qt4agg: no  [PySide not found; PyQt4 not found]

                   gtk3agg: no  [Requires pygobject to be installed.]

                 gtk3cairo: no  [Requires pygobject to be installed.]

                    gtkagg: no  [Requires pygtk]

                     tkagg: no  [TKAgg requires Tkinter.]

                     wxagg: no  [requires wxPython]

                       gtk: no  [Requires pygtk]

                       agg: yes [installing]

                     cairo: yes [installing, pycairo version 1.8.6]

                 windowing: no  [Microsoft Windows only]

    

    OPTIONAL LATEX DEPENDENCIES

                    dvipng: no

               ghostscript: yes [version 8.70]

                     latex: no

                   pdftops: no

    

    OPTIONAL PACKAGE DATA

                      dlls: no  [skipping due to configuration]

    

    ============================================================================

                            * The following required packages can not be built:

                            * freetype, png

    

    ----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-MqgKd6/matplotlib/




[root@compute011 ~]# pip install MatPlotLib==1.3.1


Same error as above.


I can't seem to get this installed at all.  First I wanted to install in a shared location, but this gave me too many errors.  Then I decided to deploy in every node of our cluster, but I keep getting stuck at the MatPlotLib.


Any help will be greatly appreciated.



Carlos.



justink

unread,
Jul 29, 2016, 3:43:48 AM7/29/16
to Qiime 1 Forum
oh sigh, installing matplotlib. Have you tried the miniconda approach at http://qiime.org/install/install.html ?
Reply all
Reply to author
Forward
0 new messages