SEXTANTE NO QGIS

835 views
Skip to first unread message

Helder Gramacho

unread,
Apr 3, 2012, 5:29:25 PM4/3/12
to qgisb...@googlegroups.com
Olá pessoal,

Instalei o plugin que que permite acessar os algoritmos do SEXTANTE no QGIS entretanto quando utilizo algum algoritmo o mesmo apresenta erro informando que é necessário realizar  um configuração de pastas ou então informa que o layer de saída que foi salvo não é possível carregar.

Alguém já instalou o plugin SEXTANTE e está tendo sucesso? Sabe como resolver estes problemas acima apresentados?

Desde já obrigado,

--
Hélder Gramacho
held...@hotmail.com

Sidney - Geosaber

unread,
Apr 3, 2012, 7:41:01 PM4/3/12
to qgisb...@googlegroups.com
Poxa, eu estava esses dias acompanhando o blog do Vitor Olaya, desenvolvedor do Sextante para saber de novidades, mas não tinha ouvido nada sobre plugin para o QGIS.
Eu estou usando o Sextante no ArcGIS e no gvSIG CE, onde se baixa ele para o QGIS, nos repositórios experimentais?
Se eu achar eu vou tentar usar o Sextante no QGIS, já estava esperando por ele faz tempo.
Obrigado,
--
Sidney Goveia

Helder Gramacho

unread,
Apr 3, 2012, 8:26:47 PM4/3/12
to qgisb...@googlegroups.com
Olá Sidney,

Para ter acesso ao SEXTANTE é preciso adicionar o seguinte repositório aos já existentes:


Teste aí e veja se o SEXTANTE funciona corretamente,

AgroHélder

--
---
Você recebeu esta mensagem do Grupo "QGISBrasil"
Para postar neste grupo, envie um e-mail para qgisb...@googlegroups.com
Para cancelar a sua inscrição neste grupo, envie um e-mail paragisbrasi...@googlegroups.com
Para ver mais opções, visite este grupo em
http://groups.google.com/group/qgisbrasil?hl=pt?hl=pt-BR



--
Hélder Gramacho 
held...@hotmail.com

Geovane Tavares Cavalcante

unread,
Apr 3, 2012, 9:11:35 PM4/3/12
to qgisb...@googlegroups.com
Amigos,

E qual o nome do plugin? Depois de adicionar o repositório busco pela palavra Sextante e não me aparece algum que pareça ser o correto.

[]'s
--
Geovane

Helder Gramacho

unread,
Apr 3, 2012, 9:29:34 PM4/3/12
to qgisb...@googlegroups.com
Olá Geovane,

O nome é Sextante mesmo. A opção "Mostrar todos os complementos, mesmo aqueles marcados como experimentais" deverá estar marcada.

Falou,

AgroHélder



--
---
Você recebeu esta mensagem do Grupo "QGISBrasil"
Para postar neste grupo, envie um e-mail para qgisb...@googlegroups.com
Para cancelar a sua inscrição neste grupo, envie um e-mail paragisbrasi...@googlegroups.com
Para ver mais opções, visite este grupo em
http://groups.google.com/group/qgisbrasil?hl=pt?hl=pt-BR



--

Geovane Tavares Cavalcante

unread,
Apr 3, 2012, 9:33:04 PM4/3/12
to qgisb...@googlegroups.com
Obrigado cara!

[]'s

Sidney - Geosaber

unread,
Apr 3, 2012, 9:45:17 PM4/3/12
to qgisb...@googlegroups.com
Obrigado Hélder, nessa Páscoa você acaba de fazer mais uma criança feliz, a muito tempo eu esperava poder usar o SEXTANTE no QGIS, inclusive cansei de ouvir de alguns chatos que o gvSIG era muito melhor porque tinha o SEXTANTE (que sempre foi um projeto independente do gvSIG).
Aqui funcionou direitinho, peguei uma camada de polígonos e testei a ferramenta de calcular centróides, rodou super bem e no final carregou nas camadas, talvez você tenha que ver melhor nas opções de configuração, no menu SEXTANTE > options and configurations.


Sidney - Geosaber

unread,
Apr 3, 2012, 10:02:00 PM4/3/12
to qgisb...@googlegroups.com
No caso dos algoritmos do SAGA está no manual (em pdf, chama pelo help) o Victor Olaya diz que é preciso ter o SAGA instalado na máquina, dai na configuração é preciso colocar o caminho completo da pasta onde está instalado ele.
Algumas ferramentas deu pau, disse que não podia abrir o folder, mas outras funcionaram direito, inclusive acrescentando ao QGIS no final do processo. O mais interessante é que o SAGA-GIS no meu computador é a versão 64bits, ou seja, o QGIS é 32bits e consegue realizar o processo invocando um módulo 64bits!
Vou continuar a testar todas as ferramentas, já estava brincando com o Orfeo Toolbox no Processing Framework, mas nunca consegui fazer o SAGA funcionar junto, agora com o SEXTANTE toolbox vou conseguir usar o SAGA. 

Helder Gramacho

unread,
Apr 4, 2012, 6:15:08 AM4/4/12
to qgisb...@googlegroups.com
Valeu Sidney,

Funcionou aqui também, era isso mesmo, vou passar a Pascoa alegre também!!!

Abraço!

AgroHélder


--
---
Você recebeu esta mensagem do Grupo "QGISBrasil"
Para postar neste grupo, envie um e-mail para qgisb...@googlegroups.com
Para cancelar a sua inscrição neste grupo, envie um e-mail paragisbrasi...@googlegroups.com
Para ver mais opções, visite este grupo em
http://groups.google.com/group/qgisbrasil?hl=pt?hl=pt-BR



--
Hélder Gramacho 
held...@hotmail.com

Andrè Bossan

unread,
Apr 4, 2012, 9:25:53 AM4/4/12
to qgisb...@googlegroups.com
Caros,

Instalei o sextante no Qgis, mas percebo que ele é bem diferente da versão do gvSIG. Essas ferramentas do ftools não podem ser usadas no Qgis? Está ocorrendo erro... Talvez por não saber como usar...

Andrè.

Sidney - Geosaber

unread,
Apr 4, 2012, 3:59:45 PM4/4/12
to qgisb...@googlegroups.com
Com certeza não tem todas ferramentas ainda, o módulo de análise espacial SEXTANTE tem mais de 300 algoritmos de geoprocessamento tanto de vetor como raster, e no caso do gvSIG CE, a nova plataforma base para o SEXTANTE segundo o próprio Victor Olaya, tem em conjunto uma centena de outros  módulos do GRASS GIS e do SAGA GIS.
É um pequeno passo para o homem, mas um gigantesco passo para a Comunidade do QGIS, que agora poderá contar com esse incrível recurso que tenho a carteza que só tende a crescer, tanto em quantidade de algoritmos quanto em qualidade de processamento.
Quanto ao fTools, que já vem incorporado ao core do QGIS desde a versão 1.0 se não me engano, e sempre funcionou perfeitamente, agora foi integrado ao SEXTANTE Toolbox como forma de unir todos os módulos de geoprocessamento em um conjunto integrado, como já vinha sendo tentado pelo pessoal que está desenvolvendo o Processing Framework, que agrega os módulos de PDI do OTB (Orfeo Toolbox - que funciona corretamente) com os módulos do SAGA GIS (que eu nunca consegui configurar para funcionar nessa toolbox).
A ultima curiosidade é que o SEXTANTE Toolbox é um esforço conjunto do Victor Olaya (SEXTANTE) com o Carson Farmer (desenvolvedor do fTools), ou vocês ainda não foram no help para ver que está por trás dessa maravilhosa novidade?

Felipe Dantas

unread,
Apr 10, 2012, 11:33:02 AM4/10/12
to qgisb...@googlegroups.com
Ei Sidney, eu instalei o pluguin sextante no qgis, instalei o saga, mas nao consegui achar essa opção de configurar as ferramentas do saga pra poder pegar no quantum...se vc puder me ajudar , cara. abraços.

--

Anderson Medeiros

unread,
Apr 11, 2012, 12:13:30 PM4/11/12
to qgisb...@googlegroups.com
Felipe,

Não sou o Sidney mas estou enviando em anexo duas imagens que, em sequência, mostram o caminho para configurar o uso do SAGA.

Espero ter ajudado.

Abraço!
--
Anderson Maciel Lima de Medeiros
Tecnólogo em Geoprocessamento
Consultor em Geotecnologias Livres
Site: http://www.clickgeo.com.br/
Blog: http://andersonmedeiros.wordpress.com/
Twitter: http://twitter.com/ClickGeo
sext01.PNG
sext02.PNG

Sidney - Geosaber

unread,
Apr 11, 2012, 12:42:27 PM4/11/12
to qgisb...@googlegroups.com
Valeu por responder Anderson,
Meu Thunderbird anda com retardo mental e alguns e-mails só aparecem horas depois do que  deveriam ter chegado.
Só uma observação é que aqui no meu Win7 x64, os programas instalados SAGA e R estão instalados na versão 64bits, mesmo assim funcionou direitinho.
Outro detalhe é que após a primeira atualização, que saiu logo após a Pascoa, o plugin quebrou e não reinstalava pelo Plugin Installer, tive que remover totalmente o complemento para poder instala-lo novamente.
Esperemos que os complementos se tornem mais estáveis e que os plugins Python para de "se quebrar" tanto, assim teremos um SIG capaz de estar entre os melhores do mercado profissional.

FeLiPe RaMoS

unread,
Apr 18, 2012, 12:37:06 PM4/18/12
to qgisb...@googlegroups.com
Sidney, eu tinha o sextante instalo no meu qgis 1.7.0 e funcionava bacana, mas aí eu instalei a versao 1.7.4 e o pluguim do sextante nao está instalando. Está aparece esta mensagem:

eu ja remove o repositorio e instalei novamente, tentei instalar o pluguin mas nao ta dando certo, sempre aparece esse erro, dizendo que o complemento está quebrado...se você puder me ajudar para resolver este problema, te agradeço muito !
abraço !

 
Message has been deleted

FeLiPe RaMoS

unread,
Apr 20, 2012, 3:11:46 PM4/20/12
to qgisb...@googlegroups.com
Sidney, cara, eu fiz do jeito que vc falou e deu certo a instalação do complemento sextante.... agora apareceu outro erro, nao mais no sextante, mas no complemento de menor distancia. Nao sei se é apenas no meu pc, mas o complemento de caminhos mais curto está toltalmente impossibilitado de ser usado, porque as ferramentes dele estao todas agrupadas num só lugar... para esclarecer melhor coloquei com anexo uma imagem do erro da ferramenta ! se vc puder me ajudar novamente , agradeço muito !
forte abraço !
caminho mais curto.jpg

Vanessa Lacerda

unread,
Oct 9, 2013, 11:26:55 AM10/9/13
to qgisb...@googlegroups.com
Olá gente!
Alguém sabe dizer se o Plugin da Sextante funciona no QGIS 2.0?
Estou aqui "penando" pra usar o Semi-Automatic Classification e ele diz que precisa configurar o OTB folder. Vou lá, configuro e nada,,,
E o meu antigo QGIS 1.8 morreu... quando tento re-instalar ele não abre mais.. alguém sabe dizer o que aconteceu ?
Obrigada

André Brito

unread,
Oct 9, 2013, 2:17:40 PM10/9/13
to qgisb...@googlegroups.com
Vanessa, o Sextante meio q se integrou ao QGIS 2.0 e virou o item
"Processamento" no menu (meu QGIS está maneirissimamente traduzido
para pt-br). Em inglês deve ser Processing, ou algo do tipo. ;)

2013/10/9 Vanessa Lacerda <vanes...@gmail.com>:
> --
> --
> ---
> Você recebeu esta mensagem do Grupo "QGISBrasil"
> Para postar neste grupo, envie um e-mail para qgisb...@googlegroups.com
> Para cancelar a sua inscrição neste grupo, envie um e-mail
> paragisbrasi...@googlegroups.com
> Para ver mais opções, visite este grupo em
> http://groups.google.com/group/qgisbrasil?hl=pt?hl=pt-BR
>
> ---
> Você está recebendo esta mensagem porque se inscreveu no grupo "qgisbrasil"
> dos Grupos do Google.
> Para cancelar a inscrição neste grupo e parar de receber seus e-mails, envie
> um e-mail para qgisbrasil+...@googlegroups.com.
> Para obter mais opções, acesse https://groups.google.com/groups/opt_out.



--
André Filipe de Assunção e Brito
Coordenadoria de Articulação e Participação Social
Secretaria de Estado de Governo
Governo do Distrito Federal
61 78129408
ID: 55*133*2058

Alexandre Barberi

unread,
Oct 10, 2013, 8:04:16 PM10/10/13
to qgisb...@googlegroups.com
Vanessa
Já vi o Semi-Automatic Classification funcionando no 2.0, mas a instalação era da versão via OSGEOW4 com muitos complementos instalados
Quanto ao 1.8 pode tentar criar a instalação portatil, tem funcionado muito bem
Boa sorte
Reply all
Reply to author
Forward
0 new messages