pythonxy in ubuntu 12.04

2294 views
Skip to first unread message

Mario Rusev

unread,
Jun 15, 2013, 3:27:46 AM6/15/13
to pythonx...@googlegroups.com
Hi folks,

I've been trying to add a stable version of pythonxy on Ubuntu 12.04.
First, I followed the instructions for adding the ppa with

Then, I did the standard sudo apt-get install pythonxy

mario@ubuntu:~$ sudo apt-get install pythonxy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package pythonxy

Alas, to no success. I tried to locate the repositories under synaptic package manager and still nothing. Would anyone be willing to give me some hints to how do I put pythonxy under Ubuntu 12.04, or I would have to update to Saucy?

Thank you for your time.

Best regards,
Mario

Tim Michelsen

unread,
Jun 16, 2013, 3:02:17 AM6/16/13
to pythonx...@googlegroups.com
> I've been trying to add a stable version of pythonxy on Ubuntu 12.04.
> First, I followed the instructions for adding the ppa with
> https://launchpad.net/~pythonxy/+archive/pythonxy-stable
>
> Then, I did the standard sudo apt-get install pythonxy
>
> mario@ubuntu:~$ sudo apt-get install pythonxy
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> E: Unable to locate package pythonxy

Please check in synaptic, you need these packages
ppa:pythonxy/pythonxy-stable
-> python-xy-meta-current

for development code:
-> ppa:pythonxy/pythonxy-devel
python-xy-meta-devel


>or I would have to update to Saucy?
No


eje

unread,
Jun 16, 2013, 4:12:48 AM6/16/13
to pythonx...@googlegroups.com
Result of  sudo apt-get install python-xy-meta-current:

The following packages have unmet dependencies:
  python-xy-meta-current: Depends: python-enthought-traits but it can not be installed
                           Depends: python-enthought-traits-ui but it can not be installed
                           Depends: python-traitsbackendqt but it will not be installed
                           Depends: python-traitsbackendwx but it will not be installed
                           Depends: python-traitsgui but it will not be installed
                           Depends: python-psyco but it can not be installed
E: Unable to correct problems, you have shelved (held) broken packages.

Tim Michelsen

unread,
Jun 16, 2013, 5:09:00 AM6/16/13
to pythonx...@googlegroups.com
Please file this as a bug here:
https://bugs.launchpad.net/pythonxy

Aparently there was some renaming:
http://packages.ubuntu.com/search?suite=raring&section=all&arch=any&keywords=traits+python&searchon=names

I can not look after this before beginning of July.
Maybe you or anther team member could fix it?

Just commit a new version of the file
http://bazaar.launchpad.net/~pythonxy/pythonxy/python-xy-meta-current_debian/view/head:/control
with the corrections.

As a workaround
Install the individual packages:
See the "Depends " section of
http://bazaar.launchpad.net/~pythonxy/pythonxy/python-xy-meta-current_debian/view/head:/control
Reply all
Reply to author
Forward
0 new messages