eval_test_gen.py

6 views
Skip to first unread message

Guy Adini

unread,
Aug 29, 2012, 8:58:02 AM8/29/12
to pyth...@googlegroups.com
Hi Itsik,

I just tried running the tests on a newly cloned pythonect repository, and eval_test_gen.py breaks:
First of all, "import eval" doesn't work (since it doesn't sit in the internals dir), but even when I 
"from pythonect import eval", all I get is a bunch of raised exceptions.

Am I doing something wrong?

Itzik Kotler

unread,
Aug 29, 2012, 9:12:01 AM8/29/12
to pyth...@googlegroups.com
Hi Guy,

You are correct, I have reorganized the Pythonect module layout in 0.4.0 and forgot to update this file.

I will fix it in 0.4.1, in the meanwhile, see attached a quick patch.

To apply:

1. Copy `eval_import.patch` to `test` directory

2. Execute `patch < eval_import.patch`

Let me know if it solved your problem.

--
You received this message because you are subscribed to the Google Groups "pythonect" group.
To view this discussion on the web visit https://groups.google.com/d/msg/pythonect/-/E6j0Gn03_ocJ.
To post to this group, send email to pyth...@googlegroups.com.
To unsubscribe from this group, send email to pythonect+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/pythonect?hl=en.

eval_import.patch

Guy Adini

unread,
Aug 29, 2012, 9:20:31 AM8/29/12
to pyth...@googlegroups.com
Yep - that does it.
Thanks!

Itzik Kotler

unread,
Aug 29, 2012, 9:21:54 AM8/29/12
to pyth...@googlegroups.com
Great! Will include this patch in 0.4.1.
Reply all
Reply to author
Forward
0 new messages