Has Pesto stopped supporting Python 2.4?

7 views
Skip to first unread message

brianpeiris

unread,
Feb 22, 2011, 4:15:46 AM2/22/11
to Pesto
I've been going through the Getting Started documentation and I've
found that you use functools in core.py and the new conditional
operator in utils.py. Changing those to places in the code seems to
make it compatible with 2.4 again (at least for my simple toy
application). Are you discontinuing support for 2.4?

Thanks,

Brian.

Oliver Cope

unread,
Feb 22, 2011, 4:27:22 AM2/22/11
to python...@googlegroups.com
Hi Brian,

I'm really only targetting Python 2.6 and above these days � I stopped
using Python 2.4 for any projects quite a while ago so I don't really
have any personal interest in supporting this any more. But if the
changes aren't too far reaching and you want to contribute patches I'd
be happy to include them in a new release.

Cheers,

Olly.

brianpeiris

unread,
Feb 22, 2011, 5:17:27 AM2/22/11
to Pesto
Thanks for the fast response! The changes I made to get it working
were simple (perhaps too simple :P). I've sent you an email with the
patch for your consideration.

Oliver Cope

unread,
Feb 22, 2011, 7:41:22 AM2/22/11
to python...@googlegroups.com
On 22/02/2011 11:17, brianpeiris wrote:
> Thanks for the fast response! The changes I made to get it working
> were simple (perhaps too simple :P). I've sent you an email with the
> patch for your consideration.
>
Thanks Brian. I'll take a look at the patch as soon as I get a chance.

Olly.

Oliver Cope

unread,
Feb 22, 2011, 12:03:31 PM2/22/11
to python...@googlegroups.com
OK, so I've now applied your patch to the development version.

Running the test suite under python 2.4 still gives quite a few errors
though :-/
However most of the core functionality seems to be passing � so as long
as you stick only to the core functionality I think you should be able
to run a useful application.

You can grab a build of the latest version from
<http://darcs.redgecko.org/pesto/dist/pesto-22dev.tar.gz>. If there
aren't any problems with this I'll push a new release onto the PyPI
towards the end of the week.

Samuel Wan

unread,
Feb 22, 2011, 12:17:26 PM2/22/11
to python...@googlegroups.com
I'm looking into Google App Engine, which only supports Python 2.5. Is
compatibility with App Engine on the radar for Pesto?

-Sam

Oliver Cope

unread,
Feb 23, 2011, 4:15:14 AM2/23/11
to python...@googlegroups.com

On 22/02/2011 18:17, Samuel Wan wrote:
> I'm looking into Google App Engine, which only supports Python 2.5.
> Is compatibility with App Engine on the radar for Pesto?
>
Python 2.5 is already fully supported so there shouldn't be any problems
on that front.

Looking at the App Engine docs the only thing that looks like it
definitely won't work is the session store � but it shouldn't be too
hard to write a session storage backend that runs on the App Engine (or
just integrate something like beaker, which I think already supports GAE).

Olly.


Reply all
Reply to author
Forward
0 new messages