pylonsproject.org and trypyramid.com updates

23 views
Skip to first unread message

Steve Piercy

unread,
Feb 13, 2022, 6:29:35 PMFeb 13
to pylons-...@googlegroups.com
Does anyone care to update our marketing websites pylonsproject.org and trypyramid.com to the latest packages, including Bootstrap 4?

I gave it a shot, but entered a rabbit-hole of dependency and migration hell.

https://github.com/Pylons/trypyramid.com/pull/320
https://github.com/Pylons/pylonsproject.org/pull/103

--steve

Laurent Daverio

unread,
Feb 14, 2022, 12:09:32 AMFeb 14
to pylons-...@googlegroups.com
Hello Steve,

I will give it a look. Why not jump directly to Bootstrap 5? Current
version is 5.1.3

Laurent.

Le lun. 14 févr. 2022 à 02:29, Steve Piercy
<steve.pi...@gmail.com> a écrit :
> --
> You received this message because you are subscribed to the Google Groups "pylons-discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to pylons-discus...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/pylons-discuss/b9079c50-0527-d815-3019-069b21dd12d5%40gmail.com.

Steve Piercy

unread,
Feb 14, 2022, 12:55:10 AMFeb 14
to pylons-...@googlegroups.com
5 would be good, too. I tried 5 first, but hit a wall, so I assumed 4 would have better support.

The easiest route forward might be to start with a clean project, and build up packages as needed.

We use Hugo to generate the static sites.

--steve

Laurent Daverio

unread,
Feb 14, 2022, 2:43:33 AMFeb 14
to pylons-...@googlegroups.com
Well, I remained stuck at version 3 for a long time because of my
Pyramid projects, then 4 because that was the version offered by
react-bootstrap at the time (2019-2020). But 5 has been out for some
time now, so I guess it's both stable and supported. I made the switch
not too long ago, everything fine, nicer than 4, which was nicer than
3.

Laurent.

Le lun. 14 févr. 2022 à 08:55, Steve Piercy
<steve.pi...@gmail.com> a écrit :
>
> 5 would be good, too. I tried 5 first, but hit a wall, so I assumed 4 would have better support.
>
> The easiest route forward might be to start with a clean project, and build up packages as needed.
>
> We use Hugo to generate the static sites.
>
> --steve
>
>
> On 2/13/22 9:09 PM, Laurent Daverio wrote:
> > Hello Steve,
> >
> > I will give it a look. Why not jump directly to Bootstrap 5? Current
> > version is 5.1.3
> >
> > Laurent.
> >
> > Le lun. 14 févr. 2022 à 02:29, Steve Piercy
> > <steve.pi...@gmail.com> a écrit :
> >>
> >> Does anyone care to update our marketing websites pylonsproject.org and trypyramid.com to the latest packages, including Bootstrap 4?
> >>
> >> I gave it a shot, but entered a rabbit-hole of dependency and migration hell.
> >>
> >> https://github.com/Pylons/trypyramid.com/pull/320
> >> https://github.com/Pylons/pylonsproject.org/pull/103
> >>
> >> --steve
> >>
> >> --
> >> You received this message because you are subscribed to the Google Groups "pylons-discuss" group.
> >> To unsubscribe from this group and stop receiving emails from it, send an email to pylons-discus...@googlegroups.com.
> >> To view this discussion on the web visit https://groups.google.com/d/msgid/pylons-discuss/b9079c50-0527-d815-3019-069b21dd12d5%40gmail.com.
> >
>
> --
> You received this message because you are subscribed to the Google Groups "pylons-discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to pylons-discus...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/pylons-discuss/c84ccc6e-e188-de80-ff59-ffa8bb0baf88%40gmail.com.

Laurent Daverio

unread,
Feb 14, 2022, 3:07:11 AMFeb 14
to pylons-...@googlegroups.com
node-sass seems to be deprecated, and should be replaced with Dart
Sass (https://www.npmjs.com/package/node-sass).
If you do just that (yarn remove node-sass; yard add -D sass),
dependency problems just go away.

I'm on a boat on Bosphorus, need to land soon, so the rest will have
to wait a little...

Laurent Daverio

unread,
Feb 18, 2022, 5:51:40 PMFeb 18
to pylons-...@googlegroups.com
Hello Steve,

You can have a look at the current state of the works here:
https://github.com/ldaverio/trypyramid.com/.

Basically, I have upgraded all that I could upgrade:
- Bootstrap 3 -> 4 (I'll try 5 later, I came across a compatibility
problem, don't remember with what Node module)
- Webpack 4 -> 5
- Node-sass -> Sass
...

(Note: highlight.js needs to remain at version 10, apparently,
otherwise code expansion no longer works)

I have adapted the main page to work with Bootstrap 4 (updated the
navbar, updated the CSS), it's not 100% finished, or identical to the
Bootstrap 3 version, but it can already be shown "as is". I haven't
checked the other pages yet, or components like bootstrap-multiselect,
so they might not work with Bootstrap 4.

The commits are made so that the different steps of the upgrade are
easier to follow, I did some commit squashing on the way to keep the
log clean.

I think that's all for now, let me know what you think, and what I
should improve.

Cheers,
Laurent.

Laurent Daverio

unread,
Feb 18, 2022, 7:42:04 PMFeb 18
to pylons-...@googlegroups.com
Just added a "bootrstrap5" branch containing changes required to make
the front page work with Bootstrap 5.1.3

Steve Piercy

unread,
Feb 19, 2022, 1:52:29 AMFeb 19
to pylons-...@googlegroups.com
Hi Laurent,

First, thank you for your work and volunteering to move this forward.

Would you please consider submitting a PR against pylons/trypyramid.com? Then other people could more easily review and contribute.

I also want to try something: preview builds using Netlify under the Pylons organization. On each commit in a PR against a specified branch, a preview of the site can be built, deployed, and previewed by the public without cloning and building locally. I've been doing this while working on Plone 6 Documentation, and it saves a lot of time during reviews.

https://620ff8a3c2a27f00081bebf3--6-dev-docs-plone-org.netlify.app/glossary.html#term-fence

--steve

Laurent Daverio

unread,
Feb 19, 2022, 2:32:15 AMFeb 19
to pylons-...@googlegroups.com
Hi Steve,

sure, I was planning to do a PR, but I need to add a few finishing
touches to it first.

Most of the commits marked "WIP" (apart from the last one) are
probably not functional, because my attempts took me to many
directions in the same time, and I privileged the clarity of the
commit logs, so as to explain what I had done.

I spent the whole of 2021 working on a big site upgrade project, from
Plone 4.2 to 5.2. Now that this is over, I should start looking at
Plone 6, I guess :)

Le sam. 19 févr. 2022 à 09:52, Steve Piercy
<steve.pi...@gmail.com> a écrit :
>
> --
> You received this message because you are subscribed to the Google Groups "pylons-discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to pylons-discus...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/pylons-discuss/d9317248-5e91-0bf8-6ebd-f6c241fec2a6%40gmail.com.

Laurent Daverio

unread,
Feb 19, 2022, 10:50:32 AMFeb 19
to pylons-...@googlegroups.com
> Would you please consider submitting a PR against pylons/trypyramid.com? Then other people could more easily review and contribute.

Done :) Bootsrap 5 it is after all. But I realised at the very end
that `bootstrap-multiselect` was posing a problem... Not willing to
backtrack, I'll find a better solution.

https://github.com/Pylons/trypyramid.com/pull/324

Cheers,

Laurent.

Le sam. 19 févr. 2022 à 09:52, Steve Piercy
<steve.pi...@gmail.com> a écrit :
>
> --
> You received this message because you are subscribed to the Google Groups "pylons-discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to pylons-discus...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/pylons-discuss/d9317248-5e91-0bf8-6ebd-f6c241fec2a6%40gmail.com.

Laurent Daverio

unread,
Apr 17, 2022, 9:10:52 AMApr 17
to pylons-...@googlegroups.com
Hello list,

has anyone taken the time to look at the Bootstrap 5 port of the site?

Cheers,
Laurent.
Reply all
Reply to author
Forward
0 new messages