Troubles while installing PyF manually

436 views
Skip to first unread message

Juju

unread,
May 2, 2011, 5:29:22 AM5/2/11
to PyF Framework Users
According to the instructions provided in the WabSite's Getting
Started Section,
I tried to install PyF Manually on a debian.
I created a virtual env
but something goes wrong while building Mercurial.

The strange thing is that I already have a 1.6.4 HG installed on the
system.
Which is > 1.2, Why the script is not satisfied with this version and
tries to fetch 1.8.3 ?

Here are the error details :

Searching for pyf[fullstack]
Reading http://pypi.python.org/simple/pyf/
Reading http://pyfproject.org
Best match: pyf 2.0
Processing pyf-2.0-py2.6.egg
pyf 2.0 is already the active version in easy-install.pth

Using /home/edd/etlenv/lib/python2.6/site-packages/pyf-2.0-py2.6.egg
Processing dependencies for pyf[fullstack]
Searching for mercurial>=1.2
Reading http://pypi.python.org/simple/mercurial/
Reading http://mercurial.selenic.com/
Reading http://www.selenic.com/mercurial
Best match: mercurial 1.8.3
Downloading http://mercurial.selenic.com/release/mercurial-1.8.3.tar.gz
Processing mercurial-1.8.3.tar.gz
Running mercurial-1.8.3/setup.py -q bdist_egg --dist-dir /tmp/
easy_install-eJ1tc_/mercurial-1.8.3/egg-dist-tmp-fIZrxN
creating /tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-
d96qvQ/tmp
creating /tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-
d96qvQ/tmp/easy_install-eJ1tc_
creating /tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-
d96qvQ/tmp/easy_install-eJ1tc_/mercurial-1.8.3
creating /tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-
d96qvQ/tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp
creating /tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-
d96qvQ/tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-d96qvQ
cc -c /tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-d96qvQ/
funcname.c -o /tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-
d96qvQ/tmp/easy_install-eJ1tc_/mercurial-1.8.3/temp/hg-install-d96qvQ/
funcname.o
error: Setup script exited with Python headers are required to build
Mercurial

Could anybody advice ?

Jonathan Schemoul

unread,
May 2, 2011, 5:32:52 AM5/2/11
to pyf-...@googlegroups.com
Hi,

The fact it tries to get a newer version is because you are installing pyf in a virtualenv, disconnected from your system site-packages.

I recommend you to install "python-dev" package in ubuntu (sudo aptitude install python-dev).
Another required packages are:
 - libxml2-dev
 - libxslt-dev

There may be others, but I don't recall now.

Jon 

Juju

unread,
May 2, 2011, 8:36:03 AM5/2/11
to PyF Framework Users
Thanks,

I've just tried installing those packages. It's going further but
script is still having troubles :

install_dir /usr/local/lib/python2.6/dist-packages/
Searching for pyf[fullstack]
Reading http://pypi.python.org/simple/pyf/
Reading http://pyfproject.org
Best match: pyf 2.0
Downloading http://pypi.python.org/packages/2.6/p/pyf/pyf-2.0-py2.6.egg#md5=c906d4e1a65c9dd02cdf157bb6bedba9
Processing pyf-2.0-py2.6.egg
removing '/usr/local/lib/python2.6/dist-packages/pyf-2.0-
py2.6.egg' (and everything under it)
creating /usr/local/lib/python2.6/dist-packages/pyf-2.0-py2.6.egg
Extracting pyf-2.0-py2.6.egg to /usr/local/lib/python2.6/dist-packages
pyf 2.0 is already the active version in easy-install.pth

Installed /usr/local/lib/python2.6/dist-packages/pyf-2.0-py2.6.egg
Processing dependencies for pyf[fullstack]
Searching for py3o.template
Reading http://pypi.python.org/simple/py3o.template/
Couldn't find index page for 'py3o.template' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://pypi.python.org/simple/
No local packages or download links found for py3o.template
error: Could not find suitable distribution for
Requirement.parse('py3o.template')

Any idea ?
Regards

On 2 mai, 11:32, Jonathan Schemoul <jonathan.schem...@gmail.com>
wrote:
> Hi,
>
> The fact it tries to get a newer version is because you are installing pyf
> in a virtualenv, disconnected from your system site-packages.
>
> I recommend you to install "python-dev" package in ubuntu (sudo aptitude
> install python-dev).
> Another required packages are:
>  - libxml2-dev
>  - libxslt-dev
>
> There may be others, but I don't recall now.
>
> Jon
>
>
>
> On Mon, May 2, 2011 at 11:29 AM, Juju <julien.cheval...@gmail.com> wrote:
> > According to the instructions provided in the WabSite's Getting
> > Started Section,
> > I tried to install PyF Manually on a debian.
> > I created a virtual env
> > but something goes wrong while building Mercurial.
>
> > The strange thing is that I already have a 1.6.4 HG installed on the
> > system.
> > Which is > 1.2, Why the script is not satisfied with this version and
> > tries to fetch 1.8.3 ?
>
> > Here are the error details :
>
> > Searching for pyf[fullstack]
> > Readinghttp://pypi.python.org/simple/pyf/
> > Readinghttp://pyfproject.org
> > Best match: pyf 2.0
> > Processing pyf-2.0-py2.6.egg
> > pyf 2.0 is already the active version in easy-install.pth
>
> > Using /home/edd/etlenv/lib/python2.6/site-packages/pyf-2.0-py2.6.egg
> > Processing dependencies for pyf[fullstack]
> > Searching for mercurial>=1.2
> > Readinghttp://pypi.python.org/simple/mercurial/
> > Readinghttp://mercurial.selenic.com/
> > Readinghttp://www.selenic.com/mercurial
> > Best match: mercurial 1.8.3
> > Downloadinghttp://mercurial.selenic.com/release/mercurial-1.8.3.tar.gz

Florent Aide

unread,
May 4, 2011, 12:20:16 PM5/4/11
to pyf-...@googlegroups.com
Obviously pyf requires py3o.template

I don't see why this is an explicit dependency, this should not (last
time I looked into pyf packaging).... in the mean time please use:

https://bitbucket.org/faide/py3o.template

Which is a mercurial repository. Sorry for the inconvenience but we
will need to investigate why it became a direct dependency on PyF and
see if we can either remove it or do the first public release for the
py3o tools :)

Best regards,
Florent

On Mon, May 2, 2011 at 2:36 PM, Juju <julien.c...@gmail.com> wrote:

[...]

> No local packages or download links found for py3o.template
> error: Could not find suitable distribution for
> Requirement.parse('py3o.template')

[...]

Reply all
Reply to author
Forward
0 new messages