Unable to resolve hostname 'api.sandbox.push.apple.com'

61 views
Skip to first unread message

himanshu paliwal

unread,
Mar 24, 2021, 10:14:07 AM3/24/21
to pushy
Hi,

I have moved to Pushy to send push to Apple using new Http 2 API. 

I have added this dependency

<dependency>
<groupId>com.eatthepath</groupId>
<artifactId>pushy</artifactId>
<version>0.14.2</version>
</dependency>

I have installed both root certificates
GeoTrust Global CA root certificate
AAA Certificate Services root certificate

as mentioned in developer apple documentation

Tried both authentication types 
Token-Based Connection to APNs
Certificate-Based Connection to APNs

But I am getting following error every time sending a push

java.net.UnknownHostException: failed to resolve 'api.sandbox.push.apple.com' after 2 queries 
at io.netty.resolver.dns.DnsResolveContext.finishResolve(DnsResolveContext.java:1005) ~[netty-resolver-dns-4.1.53.Final.jar:4.1.53.Final]
at io.netty.resolver.dns.DnsResolveContext.tryToFinishResolve(DnsResolveContext.java:958) ~[netty-resolver-dns-4.1.53.Final.jar:4.1.53.Final]


I tried adding excluding netty dependencies, changed versions but I am unable to get rid of it.

Can any one suggest a solution?
Thanks.
Reply all
Reply to author
Forward
0 new messages