fstab not updated by mountpoint ensure absent

Skip to first unread message

Miriam Olmi

Jan 30, 2024, 2:36:06 PMJan 30
to Puppet Users
I mounted a shared file system on a couple of machines and it worked fine. 
Now I would like to remove such file system from those machines and I have some problems with this. 
I removed all puppet instructions related to the mounting operations and I added the following lines: 

   device: "/mnt/projects"
   ensure: absent

to the yaml file of the selected machines but this has no effect on the /etc/fstab file and therefore I still get the error notification in the log: 
/mnt/projects is not mounted on /projects

How can I solve this issue? 

Martin Alfke

Jan 31, 2024, 2:18:45 AMJan 31
to puppet...@googlegroups.com
Hi Miriam,

You showed us some yaml (I assume hiera) data.
We cannot say for sure what these data do.
Can you please also provide the puppet code which should use the data?


You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/435a4631-dea4-4727-9368-77f6bc8395a5n%40googlegroups.com.

Reply all
Reply to author
0 new messages