puppetshow with puppetmaster 0.24.6

14 views
Skip to first unread message

Rodney Quillo

unread,
Jan 7, 2009, 10:16:24 PM1/7/09
to Puppet Users
Hi,

I'm using Puppetmaster version 0.24.6 with rails v2.0.2
Followed the wiki instruction for puppetshow and storedconfiguration
enabled.
clone the repo for puppetshow to a directory.

When I execute on the puppet server:
$ rake production db:migrate

I got the following errors:

rake aborted!
uninitialized constant ActiveSupport::Dependencies

Thanks in advance,
Rodney

Luke Kanies

unread,
Jan 8, 2009, 1:49:16 AM1/8/09
to puppet...@googlegroups.com


That seems like a Rails thing; you probably are missing a gem or nine.

--
One of the Ten Commandments for Technicians:
(7) Work thou not on energized equipment, for if thou dost, thy
fellow workers will surely buy beers for thy widow and
console her in other ways.
---------------------------------------------------------------------
Luke Kanies | http://reductivelabs.com | http://madstop.com

Rodney Quillo

unread,
Jan 8, 2009, 3:59:33 AM1/8/09
to Puppet Users
Hi Luke,

I've tried to check the gems in my Ubuntu Hardy.
The trace also provided below, it seems Puppetshow is using older
gems?

Thanks again,
Rodney


$ gem list

actionmailer (2.2.2)
actionpack (2.2.2)
activerecord (2.2.2)
activeresource (2.2.2)
activesupport (2.2.2)
hobo (0.8.5)
hobofields (0.8.5)
hobosupport (0.8.5)
mislav-will_paginate (2.3.6)
rails (2.2.2)
rake (0.8.3)


$ rake production db:migrate --trace
(in /ebs1/puppetshow)
** Invoke production (first_time)
** Execute production
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
uninitialized constant ActiveSupport::Dependencies
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:266:in `load_missing_constant'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:453:in `const_missing'
/var/lib/gems/1.8/gems/hobofields-0.8.5/lib/hobo_fields.rb:3
/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:496:in `require'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:342:in `new_constants_in'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:496:in `require'
/var/lib/gems/1.8/gems/hobofields-0.8.5/lib/hobofields.rb:1
/usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in
`gem_original_require'
/usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in `require'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:496:in `require'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:342:in `new_constants_in'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/dependencies.rb:496:in `require'
/ebs1/puppetshow/vendor/plugins/hobo/init.rb:3:in `evaluate_init_rb'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/rails/plugin.rb:
79:in `evaluate_init_rb'
/ebs1/puppetshow/vendor/rails/activerecord/lib/../../activesupport/lib/
active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/rails/plugin.rb:
75:in `evaluate_init_rb'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/rails/plugin.rb:
39:in `load'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/rails/plugin/
loader.rb:33:in `load_plugins'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/rails/plugin/
loader.rb:32:in `each'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/rails/plugin/
loader.rb:32:in `load_plugins'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/initializer.rb:
189:in `load_plugins'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/initializer.rb:
105:in `process'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/initializer.rb:
49:in `send'
/ebs1/puppetshow/config/../vendor/rails/railties/lib/initializer.rb:
49:in `run'
/ebs1/puppetshow/config/environment.rb:42
/ebs1/puppetshow/vendor/rails/railties/lib/tasks/misc.rake:3:in
`require'
/ebs1/puppetshow/vendor/rails/railties/lib/tasks/misc.rake:3
/usr/lib/ruby/1.8/rake.rb:546:in `call'
/usr/lib/ruby/1.8/rake.rb:546:in `execute'
/usr/lib/ruby/1.8/rake.rb:541:in `each'
/usr/lib/ruby/1.8/rake.rb:541:in `execute'
/usr/lib/ruby/1.8/rake.rb:508:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:501:in `synchronize'
/usr/lib/ruby/1.8/rake.rb:501:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:518:in `invoke_prerequisites'
/usr/lib/ruby/1.8/rake.rb:1183:in `each'
/usr/lib/ruby/1.8/rake.rb:1183:in `send'
/usr/lib/ruby/1.8/rake.rb:1183:in `each'
/usr/lib/ruby/1.8/rake.rb:515:in `invoke_prerequisites'
/usr/lib/ruby/1.8/rake.rb:507:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:501:in `synchronize'
/usr/lib/ruby/1.8/rake.rb:501:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/rake.rb:494:in `invoke'
/usr/lib/ruby/1.8/rake.rb:1931:in `invoke_task'
/usr/lib/ruby/1.8/rake.rb:1909:in `top_level'
/usr/lib/ruby/1.8/rake.rb:1909:in `each'
/usr/lib/ruby/1.8/rake.rb:1909:in `top_level'
/usr/lib/ruby/1.8/rake.rb:1948:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:1903:in `top_level'
/usr/lib/ruby/1.8/rake.rb:1881:in `run'
/usr/lib/ruby/1.8/rake.rb:1948:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:1878:in `run'
/usr/bin/rake:28

Stasheck

unread,
Jan 8, 2009, 7:28:47 AM1/8/09
to Puppet Users
Maybe a bit off-topic, but since when storedconfig works with Rails
2.x? I'm asking because http://reductivelabs.com/trac/puppet/wiki/UsingStoredConfiguration
explicitly says that only Rails 1.x is supported.

/BR
Stanislaw

Rodney Quillo

unread,
Jan 8, 2009, 8:25:05 AM1/8/09
to Puppet Users

I've run puppet server with storedconfig enable with no problem.
The mysql db were populated with puppet information successfully.

I'm not sure why the doc says it requires Rails 1.x also, or it is
puppetshow that is not updated to for Rails 2.x?

Rodney


On Jan 8, 8:28 pm, Stasheck <stanislaw.kamin...@gmail.com> wrote:
> Maybe a bit off-topic, but since when storedconfig works with Rails
> 2.x? I'm asking becausehttp://reductivelabs.com/trac/puppet/wiki/UsingStoredConfiguration

Luke Kanies

unread,
Jan 8, 2009, 10:52:21 AM1/8/09
to puppet...@googlegroups.com
On Jan 8, 2009, at 6:28 AM, Stasheck wrote:

> Maybe a bit off-topic, but since when storedconfig works with Rails
> 2.x? I'm asking because http://reductivelabs.com/trac/puppet/wiki/UsingStoredConfiguration
> explicitly says that only Rails 1.x is supported.


Those docs are out of date. I'll fix them. StoreConfigs works fine
with 2.x, although possibly not with the absolute latest stuff.

--
To succeed in the world it is not enough to be stupid, you must also
be well-mannered. -- Voltaire

Blake Barnett

unread,
Jan 9, 2009, 10:57:20 PM1/9/09
to puppet...@googlegroups.com
On Jan 8, 2009, at 8:52 AM, Luke Kanies wrote:

>
> On Jan 8, 2009, at 6:28 AM, Stasheck wrote:
>
>> Maybe a bit off-topic, but since when storedconfig works with Rails
>> 2.x? I'm asking because http://reductivelabs.com/trac/puppet/wiki/UsingStoredConfiguration
>> explicitly says that only Rails 1.x is supported.
>
>
> Those docs are out of date. I'll fix them. StoreConfigs works fine
> with 2.x, although possibly not with the absolute latest stuff.

Most likely they've changed some internal dependencies in 2.2.x, 2.0.x
worked fine.

-Blake

Rodney Quillo

unread,
Jan 13, 2009, 3:00:33 AM1/13/09
to Puppet Users
Hi Blake and others,

I got it running with the following gems:

actionmailer (2.0.2)
actionpack (2.0.2)
activerecord (2.0.2)
activeresource (2.0.2)
activesupport (2.0.2)
daemons (1.0.10)
gem_plugin (0.2.3)
hobofields (0.7.5)
hobosupport (0.8.5)
rails (2.0.2)
rake (0.8.3)

It only needs the hobofields since hobo and others were already in the
plugin directory.

Cheers,
Rodney

On Jan 10, 11:57 am, Blake Barnett <sha...@gmail.com> wrote:
> On Jan 8, 2009, at 8:52 AM, Luke Kanies wrote:
>
>
>
> > On Jan 8, 2009, at 6:28 AM, Stasheck wrote:
>
> >> Maybe a bit off-topic, but since when storedconfig works with Rails
> >> 2.x? I'm asking becausehttp://reductivelabs.com/trac/puppet/wiki/UsingStoredConfiguration

jrojas

unread,
Jan 14, 2009, 8:49:49 PM1/14/09
to Puppet Users
Sorry if I am re-hashing this but this error is bugging the piss out
of me, first of the details:

My gems:
actionmailer (2.0.2)
actionpack (2.0.2)
activerecord (2.0.2)
activeresource (2.0.2)
activesupport (2.0.2)
daemons (1.0.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
hobofields (0.7.5)
hobosupport (0.8.5)
mysql (2.7)
passenger (2.0.6)
rack (0.9.1)
rake (0.8.3)
sources (0.0.1)

I agree that it does work (to an extent) with the above gems.
However, certain parts of it are not functioning (pagination and
search)

Here is the ugly error:

NameError (undefined local variable or method `superclass' for
#<HostsController:0x2aaaad7addc0>):
/vendor/plugins/hobo/lib/hobo/model_controller.rb:523:in
`not_found'
/vendor/rails/actionpack/lib/action_controller/rescue.rb:189:in
`call'
/vendor/rails/actionpack/lib/action_controller/rescue.rb:189:in
`rescue_action_with_handler'
/vendor/rails/actionpack/lib/action_controller/rescue.rb:201:in
`perform_action_without_caching'
/vendor/rails/actionpack/lib/action_controller/caching.rb:678:in
`passenger_orig_perform_action'
/usr/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
connection_adapters/abstract/query_cache.rb:33:in `cache'
/usr/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/
query_cache.rb:8:in `cache'
/vendor/rails/actionpack/lib/action_controller/caching.rb:677:in
`passenger_orig_perform_action'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/railz/
request_handler.rb:53:in `perform_action'
/vendor/rails/actionpack/lib/action_controller/base.rb:524:in
`send'
/vendor/rails/actionpack/lib/action_controller/base.rb:524:in
`process_without_filters'
/vendor/rails/actionpack/lib/action_controller/filters.rb:685:in
`process_without_session_management_support'
/vendor/rails/actionpack/lib/action_controller/
session_management.rb:123:in `process'
/vendor/rails/actionpack/lib/action_controller/base.rb:388:in
`process'
/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:
171:in `handle_request'
/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:
115:in `dispatch'
/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:
126:in `dispatch_cgi'
/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:9:in
`dispatch'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/railz/
request_handler.rb:38:in `process_request'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_request_handler.rb:165:in `main_loop'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/railz/
application_spawner.rb:321:in `start_request_handler'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/railz/
application_spawner.rb:282:in `handle_spawn_application'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/utils.rb:
163:in `safe_fork'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/utils.rb:
161:in `fork'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/utils.rb:
161:in `safe_fork'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/railz/
application_spawner.rb:280:in `handle_spawn_application'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/utils.rb:
163:in `safe_fork'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/utils.rb:
161:in `fork'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/utils.rb:
161:in `safe_fork'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/railz/
application_spawner.rb:279:in `handle_spawn_application'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:317:in `__send__'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:317:in `main_loop'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:168:in `start_synchronously'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:135:in `start'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:112:in `fork'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:112:in `start'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/railz/
application_spawner.rb:179:in `start'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
spawn_manager.rb:222:in `spawn_rails_application'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
spawn_manager.rb:217:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
spawn_manager.rb:217:in `spawn_rails_application'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
spawn_manager.rb:126:in `spawn_application'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
spawn_manager.rb:251:in `handle_spawn_application'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:317:in `__send__'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:317:in `main_loop'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/lib/passenger/
abstract_server.rb:168:in `start_synchronously'
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.6/bin/passenger-spawn-
server:46

Rendering /opt/puppetshow/public/500.html (500 Internal Server Error)
Rendering _list_inline_adapter
Rendered core/_messages (0.00020)


Anyone have ideas? Did I miss something?

Scott

unread,
Jan 16, 2009, 5:47:08 PM1/16/09
to Puppet Users
I had the exact same problem (the exceptions in pagination and search)
and gave up because it's not being developed at all and probably works
on much older versions of puppet.

Scott

jrojas

unread,
Jan 16, 2009, 9:02:29 PM1/16/09
to Puppet Users
Good. I am glad someone else has had the problem. I think I am going
to start beating on this with a hammer until it works :P

Rodney Quillo

unread,
Jan 17, 2009, 6:04:14 AM1/17/09
to Puppet Users
Jason,

I have the same errors too. :)

Rodney

Luke Kanies

unread,
Jan 19, 2009, 3:45:43 PM1/19/09
to puppet...@googlegroups.com
On Jan 16, 2009, at 8:02 PM, jrojas wrote:

> Good. I am glad someone else has had the problem. I think I am going
> to start beating on this with a hammer until it works :P


Please let me know (feel free to ping me personally if I don't respond
on the list fast enough) if there's anything I can do to help.

Blake Barnett did most of the actual development with PuppetShow, but
I can hopefully at least help.

--
In science, 'fact' can only mean 'confirmed to such a degree that it
would be perverse to withhold provisional assent.' I suppose that
apples might start to rise tomorrow, but the possibility does not
merit equal time in physics classrooms. -- Stephen Jay Gould

Larry Ludwig

unread,
Feb 2, 2009, 10:16:11 PM2/2/09
to Puppet Users


On Jan 13, 3:00 am, Rodney Quillo <imco...@gmail.com> wrote:
> Hi Blake and others,
>
> I got it running with the following gems:
>
> actionmailer (2.0.2)
> actionpack (2.0.2)
> activerecord (2.0.2)
> activeresource (2.0.2)
> activesupport (2.0.2)
> daemons (1.0.10)
> gem_plugin (0.2.3)
> hobofields (0.7.5)
> hobosupport (0.8.5)
> rails (2.0.2)
> rake (0.8.3)
>
> It only needs the hobofields since hobo and others were already in the
> plugin directory.
>

What did you do to fix the uninitialized constant
ActiveSupport::Dependencies error?

I'm still getting this error with the above gems.

-L

Rodney Quillo

unread,
Feb 3, 2009, 5:56:30 AM2/3/09
to Puppet Users
Hi Larry,

Install the older gems I've listed above using the command:

$ sudo gem install rails --version='2.0.2'
$ sudo gem install hobofields --version='0.7.5'
$ sudo gem install hobosupport
....etc

Also remove the newer version of rails 2.2.x and other dependency.
See man page for gems. Let us know how it goes.

Good luck,
Rodney

-----
http://imcocoy.blogspot.com

Larry Ludwig

unread,
Feb 3, 2009, 8:41:18 AM2/3/09
to Puppet Users
That did the trick. I thought you can have multiple versions of the
same gem installed and if it's locked in the RoR app it shouldn't
matter.

-L

On Feb 3, 5:56 am, Rodney Quillo <imco...@gmail.com> wrote:
> Hi Larry,
>
> Install the older gems I've listed above using the command:
>
> $ sudo gem install rails --version='2.0.2'
> $ sudo gem install hobofields --version='0.7.5'
> $ sudo gem install hobosupport
> ....etc
>
> Also remove the newer version of rails 2.2.x and other dependency.
> See man page for gems. Let us know how it goes.
>
> Good luck,
> Rodney
>
> -----http://imcocoy.blogspot.com
Reply all
Reply to author
Forward
0 new messages