Want to upgrade Puppet to 3.x on a CentOS 5.4 machine.

7 views
Skip to first unread message

Brian Gupta

unread,
May 16, 2014, 3:10:08 PM5/16/14
to puppe...@googlegroups.com
The only version of Ruby that is available in the standard repos is
1.8.5, so 2.7 is the highest supported version.

Although I certainly know how, I DO NOT want to use rbenv or rvm to
roll out a new version of Ruby just for Puppet. Are there any sorta
official/blessed ways to do this?

I'm taking a hard look at using this omnibus installer:
https://github.com/andytinycat/puppet-omnibus


Thanks
Brian

James Sweeny

unread,
May 16, 2014, 3:14:39 PM5/16/14
to puppe...@googlegroups.com
Puppet Labs ships Ruby 1.8.7 in their repos, and that's what's recommended.

http://docs.puppetlabs.com/guides/platforms.html#red-hat-enterprise-linux-and-derivatives

Do you have applications that require Ruby 1.8.5?


Brian

--
You received this message because you are subscribed to the Google Groups "puppet-nyc" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-nyc+...@googlegroups.com.
To post to this group, send email to puppe...@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-nyc.
For more options, visit https://groups.google.com/d/optout.

Brian Gupta

unread,
May 16, 2014, 3:31:28 PM5/16/14
to puppe...@googlegroups.com
Got it. As far as I know, no 1.8.5 needs in this particular case, so
those packages should be fine.

Very easy to use, and works as expected, as well!

rpm -ivh http://yum.puppetlabs.com/puppetlabs-release-el-5.noarch.rpm
yum install ruby
yum install rubygems
gem install facter --version 1.6.18 --no-ri --no-rdoc
gem install puppet --version 3.4.3 --no-ri --no-rdoc

(Yeah, I know.. we still sometimes use gem. We'll move away eventually.)

Thanks,
Brian
Reply all
Reply to author
Forward
0 new messages