Failing access to Jabber Server MacOS

53 views
Skip to first unread message

Max Panzer

unread,
Oct 12, 2020, 6:47:52 AM10/12/20
to Psi-Users
Hello everyone, 

i have a problem with accessing my Jabber XMPP-Server: jabber.de
If i want to connect to the server i get this following statement:  

There was an error communicating with the server.

Details: Authentication error: Unable to login

Offered mechanisms: GSSAPI, PLAIN


I also tried Gajim as a client with the same issue. 
Unfortunately on Windows it all works. 

Can anyone help me?

Sergey Ilinykh

unread,
Oct 12, 2020, 8:27:35 AM10/12/20
to psi-...@googlegroups.com
Hi,

PLAIN auth works for me. Even so I'm wondering why Psi selects it over SCRAM which was also offered to me. (SCRAM is definitely supported)
Wrt GSSAPI, I guess you need some cyrus-sasl or qca plugins to make it working, Usually just install them with your package manager in case of *nix.

Best Regards,
Sergey


пн, 12 окт. 2020 г. в 13:47, Max Panzer <maxpa...@gmail.com>:
--
You received this message because you are subscribed to the Google Groups "Psi-Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to psi-users+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/psi-users/b4e9b71b-59de-48b9-91dd-843d949369f0n%40googlegroups.com.

Boris Pek

unread,
Oct 13, 2020, 2:09:42 PM10/13/20
to psi-...@googlegroups.com
Hi,

> Wrt GSSAPI, I guess you need some cyrus-sasl or qca plugins to make it working, Usually just install them with your package manager in case of *nix.

As far as I see qca-cyrus-sasl plugin is present in app bundle:

$ ls /Applications/Psi+.app/Contents/PlugIns/crypto/ | grep .
libqca-cyrus-sasl.dylib
libqca-gnupg.dylib
libqca-logger.dylib
libqca-ossl.dylib
libqca-softstore.dylib

I do not know why it does not work in this case.

--
Boris

Sergey Ilinykh

unread,
Oct 13, 2020, 2:11:17 PM10/13/20
to psi-...@googlegroups.com
cyrus-sasl has its own plug-ins. Maybe some of them aren't installed

вт, 13 окт. 2020 г., 21:09 Boris Pek <tehn...@yandex.ru>:
--
You received this message because you are subscribed to the Google Groups "Psi-Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to psi-users+...@googlegroups.com.

Annette

unread,
Oct 13, 2020, 5:21:15 PM10/13/20
to psi-...@googlegroups.com
Thanks a lot for your advice!
I'll try it soon!
Best regards
annettefi


--
You received this message because you are subscribed to the Google Groups "Psi-Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to psi-users+...@googlegroups.com.

Annette

unread,
Oct 13, 2020, 5:21:46 PM10/13/20
to psi-...@googlegroups.com
Thanks a lot for your advice!
I'll try it soon!
Best regards
annettefi

Annette

unread,
Oct 13, 2020, 5:22:18 PM10/13/20
to psi-...@googlegroups.com
Thanks a lot for answer !
I'll try what you suggest.
Best regards
annettefi

Reply all
Reply to author
Forward
0 new messages