Process methods

0 views
Skip to first unread message

Floris Bruynooghe

unread,
Jun 28, 2009, 3:02:17 PM6/28/09
to psi-d...@googlegroups.com
Hi

You may have noticed I have added some methods to the Process class,
these are based on items in the issue tracker. The actual issues
could probably do with some updating on exactly which methods are
required (e.g. for #7 are .suspend() and .resume() really important
enough to get their own methods? Or maybe those actions are not
implemented with signals on some systems?). Anyway, they emit
FutureWarnings for now so lets wait till we've all used them and
formed an idea about them.

For now I'm just wondering about the .isalive(). Right now it returns
True as long as a process exists, even if it is in a zombie state. I
guess that's technically correct but might be unintuitive. Any
opinions on what would be preferable?

Regards
Floris


PS: I'm still waiting for more feedback on the TimeSpec type before
continuing implementing it.
http://bitbucket.org/chrismiles/psi/wiki/TimeAPI

--
Debian GNU/Linux -- The Power of Freedom
www.debian.org | www.gnu.org | www.kernel.org

Erick Tryzelaar

unread,
Jun 30, 2009, 3:21:58 PM6/30/09
to psi-d...@googlegroups.com
On Jun 28, 2009, at 12:02 PM, Floris Bruynooghe <floris.b...@gmail.com
> wrote:

>
> For now I'm just wondering about the .isalive(). Right now it returns
> True as long as a process exists, even if it is in a zombie state. I
> guess that's technically correct but might be unintuitive. Any
> opinions on what would be preferable?

I think it's okay to to do this. What about naming it exists()? Then
we have an isalive mean not zombied?

> PS: I'm still waiting for more feedback on the TimeSpec type before
> continuing implementing it.
> http://bitbucket.org/chrismiles/psi/wiki/TimeAPI

I liked this idea and I'd implement it myself if I had the time :)

Reply all
Reply to author
Forward
0 new messages