Errors in '' when installing Private Eye Pi - additional error

Skip to first unread message

Oct 1, 2022, 1:23:36 PM10/1/22
to PrivateEyePi
I am installing PrivateEyePi on Raspberry 3b with Raspian Buster installed. I ran into problems when I ran 'python' to test the installation and got the error message

Traceback (most recent call last):
  File "", line 28, in <module>
    import urllib.request, urllib.error, urllib.parse
ImportError: No module named request

This was due to having two versions of Python on the Pi and the default version was Python 2.

$ python --version
Python 2.7.16
$ python3 --version
Python 3.7.3

I ran the command:

$ sudo update-alternatives --install /usr/bin/python python /usr/bin/python3 10

This corrected the problem
$ python --version
Python 3.7.3
$ python3 --version
Python 3.7.3

NOW when I run 'python' to test the installationI get the error

Traceback (most recent call last):
  File "", line 223, in <module>
  File "", line 205, in main
  File "", line 49, in BuildGPIOList
    RecordSet = GetDataFromHost(2,[0])
  File "/home/pi/pep/", line 325, in GetDataFromHost
    l = find_all(temp,"/n");
  File "/home/pi/pep/", line 49, in find_all
    start = a_str.find(sub, start)
TypeError: argument should be integer or bytes-like object, not 'str'

Can you help me with this please ?

Reply all
Reply to author
0 new messages