Errors in '' when installing Private Eye Pi

Skip to first unread message

Sep 25, 2022, 9:34:40 AM9/25/22
to PrivateEyePi
I am installing PrivateEyePi on Raspberry 3b with Raspian Buster installed. Following the instructions from PrivateEyePi Project I ran

followed by sh

All went well until I got the error message
chmod: cannot access '': No such file or directory

I then ran python to test the installation and got the error message

Traceback (most recent call last):
  File "", line 28, in <module>
    import urllib.request, urllib.error, urllib.parse
ImportError: No module named request

I have tried this installation of PriveEyePi several times now, each time I get this error message.
Can you please help me?

Glenn Seaton

Sep 25, 2022, 2:17:30 PM9/25/22
to PrivateEyePi
I your Pi may have two versions of python and the default version is python 2 and not Python 3.
You can test version with: python -V  (capital V)

Try: python3


Sep 29, 2022, 10:59:48 PM9/29/22
to PrivateEyePi
python -V gave version 2.17.6

python3 gave no errors

So you are correct, my Pi has both Python 2 AND Python 3.

Next question is how do I remove Python 2 or can I make Python 3 the default and/or disable Python 2

Reply all
Reply to author
0 new messages