Windows Update cannot check for updates following using Portable Update Windows 7 On target offline PC after connecting back online

95 views
Skip to first unread message

David Wess

unread,
Mar 15, 2019, 7:55:19 AM3/15/19
to Portable Update
Hi
Can anyone help please?

I have searched ahead of asking this question.
I have HP Intel I5 laptop running 64bit Windows 7 Home Premium. It has not been used for maybe 9 months. So I decided to get it's window updates and virus/spyware up to date offline.
I used an identical pc (except for I7 processor) to download the required software (this may be relevant).
I first installed a new Avast free offline version with no problems.
I then chose, after some reading, Portable Update (PU) (specified to update an existing installation) to transfer and install all the required Windows updates that had occurred since the pc was used, because the process can be very slow. This involved running the program on my operational pc and filling the program's cache with all updates, as instructed. I then ran the program on the target offline pc, leaving it at night. In the morning the computer was rebooted, and all initially appeared ok. The PU log reported a normal termination on both pc's.I connected the target pc to the internet. I can provide the PU log for both the Source and Target (same file appended) if required by any kind person!
However, I next decided to open Windows Update to check for any further updates that may have been missed, and to check that all was well. Windows Update opened With the red X in the "Check for updates for your computer box" with the button "Check for updates", so I pressed it. The report came back "Windows update cannot currently check for updates, because the service is not running. You may need to restart your computer". I checked, and the service was running, so I restarted the pc and got the same result again. The Change Settings screen runs normally, the Update History does not populate at all, even after several minutes, and there are no Hidden Updates. Any assistance would be gratefully received.
I then searched for solutions. The only one that I felt I wanted to try without advice was the Windows update Troubleshooter (WUTS).
I ran it and it found two problems; "Problems installing recent updates - Not fixed" (the first time I ran the WUTS it reported that both issues we solved) and "Service registration is missing or corrupt - Fixed". However the WUTS detailed inf (like a log) gives the first problem a different title "Service registration is missing or corrupt" and logs it as fixed. So in the details, both issues are shown as resolved. I have run the WUTS several times to no avail, and rebooted. However the problem remains.
Please do allow me some time to reply if you post a reply, because my time schedule is a little stretched just now. Thank you in anticipation.
David ps I may as well attach the PU log... File: PortUpSource and Target.log
PortUpSource and Target.log
Reply all
Reply to author
Forward
0 new messages