using easy_install with Python 2.6.1

840 views
Skip to first unread message

FND

unread,
Nov 15, 2009, 3:38:44 AM11/15/09
to PortablePython
When using Portable Python 1.1 based on Python 2.5.4, I can use the
following:
App\python.exe App\Scripts\easy_install-script.py foo

The version based on Python 2.6.1 uses different locations, namely
App\easy_install.py (and also App\setuptools\command\easy_install.py).

Something doesn't seem quite right though - easy_install can't find
setuptools*.
Yet I can import it manually from the same working directory:
cd App
python.exe
>>> import setuptools # works

Am I perhaps Doing It Completely Wrong?


-- F.


* command and traceback:
> App\python.exe App\easy_install.py foo
Traceback (most recent call last):
File "App\easy_install.py", line 4, in <module>
from setuptools.command.easy_install import main
File "App\setuptools\command\easy_install.py", line 21, in
<module>
from setuptools.package_index import PackageIndex,
parse_bdist_wininst
File "App\setuptools\package_index.py", line
145, in <module>
urllib2.__version__, require('setuptools')[0].version
File "App\pkg_resources.py", line 626, in require
needed = self.resolve(parse_requirements(requirements))
File "App\pkg_resources.py", line 524, in res
olve
raise DistributionNotFound(req) # XXX put more info here
pkg_resources.DistributionNotFound: setuptools

Perica Zivkovic

unread,
Nov 15, 2009, 5:01:10 AM11/15/09
to PortablePython
Looks like a bug in PP 1.1 distribution based on Py 2.6

How to fix it:
- delete setuptools dir from [PProot]\App
- delete easy_install.py from [PProot]\App
- delete pkg_resources.py from [PProot]\App
- delete site.py from [PProot]\App
- download ez_setup.py from http://peak.telecommunity.com/dist/ez_setup.py
and place it in your [PProot]\App
- open command prompt and change dir to [PProot]\App
- type "python ez_setup.py"
- setup tools should be installed
- to use it type "Scripts\easy_install.exe [package_name]" while you
are in [PProot]\App

let me know if you have more problems. I will record this as a bug on
PP project site (http://www.PortablePython.com)

keep pythoning !

Perica

FND

unread,
Nov 16, 2009, 8:47:06 AM11/16/09
to PortablePython
> Looks like a bug in PP 1.1 distribution based on Py 2.6
> [...]
> I will record this as a bug on PP project site

Thanks Perica!
For the moment, I'm happy sticking with 2.5.4 for regular use.


-- F.
Reply all
Reply to author
Forward
0 new messages