How to use blackbox framework in plugin without wheel files?

12 views
Skip to first unread message

Noelia

unread,
Apr 22, 2021, 8:33:38 AMApr 22
to plove...@googlegroups.com
Hello:

Benoit-Pierre, kindly, created a testing framework for my plugin
(plover_spanish_mqd), to be use with Plover Python Dictionary 1 or
later.
But now, when I tried to publish releases with twine, GitHub Actions
complains and seems that extra dependencies are not allowed.
I can create a branch for releases, but do you think is there a better option?

Eliseo has fixed a reported issue and I'd like to release a new version.

Kind regards

Benoit Pierre

unread,
Apr 22, 2021, 3:46:47 PMApr 22
to ploversteno
On Thu, Apr 22, 2021 at 2:33 PM Noelia <nrm...@gmail.com> wrote:
Hello:

Benoit-Pierre, kindly, created a testing framework for my plugin
(plover_spanish_mqd), to be use with Plover Python Dictionary 1 or
later.
But now, when I tried to publish releases with twine, GitHub Actions
complains and seems that extra dependencies are not allowed.
I can create a branch for releases, but do you think is there a better option?

4.0.0.dev9 has been released to PyPI, you can depend on it for the tests.
 
Cheers,

--
A: Because it destroys the flow of conversation.
Q: Why is top posting dumb?

Noelia

unread,
Apr 22, 2021, 3:51:16 PMApr 22
to plove...@googlegroups.com
Benoit-Pierre wrote:

>

> 4.0.0.dev9 has been released to PyPI, you can depend on it for the tests.


Thanks so much! I'll release a new version of the plugin tomorrow.
> --
> You received this message because you are subscribed to the Google Groups
> "Plover" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to ploversteno...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/ploversteno/CA%2BSSzV3SE6wSE8i8aOj97C%2BRCJTYKN_%2B1t4MxG1GFWKC-RMLig%40mail.gmail.com.
>
Reply all
Reply to author
Forward
0 new messages