how to use blogging API

14 views
Skip to first unread message

hennaheto

unread,
Mar 1, 2010, 6:19:30 PM3/1/10
to Plone: quills
I have been trying to figure out how to use the remote blogging API in
quills and I cant seem to get it to work. Do i need to configure it?
Should I be using MetaWeblog? What is the URL I should use? Do i need
to check "use boolean for publish"? Will this work if I use CAS for
authentication?

Tim Knapp

unread,
Mar 1, 2010, 6:57:43 PM3/1/10
to plone-...@googlegroups.com
Hi,

Its just the quills blog URL and your plone username/password and you
need to enter the API Key but forgotten how to get that. Might need to
grep for that ;) I do recall this coming up on the ML in the past.

-Tim

hennaheto

unread,
Mar 1, 2010, 7:16:08 PM3/1/10
to Plone: quills
the error message that gives me is "Unexpected Zope exception:
ZExceoptions.NotFound - Site Error An error was encountered while
publishing this resource. Resource not found Sorry, the requested
resource does not exist. Check the URL and try again. Resource:
http://mysite.com/a/blogger Troubleshooting Suggestions The URL may be
incorrect. The parameters passed to this resource may be incorrect.
A resource that this resource relies on may be encountering an
error..................."

the blog is located at : http://mysite.com/a/ I don’t know where it is
getting /blogger from. I am trying the MetaWeblog API my API URL is :
http://mysite.com/a/ useboolean for publish is checked and I inserted
my API key (it is at the top of my blog when logged in)

> > authentication?- Hide quoted text -
>
> - Show quoted text -

Tim Knapp

unread,
Mar 1, 2010, 7:22:26 PM3/1/10
to plone-...@googlegroups.com
On Mon, 2010-03-01 at 16:16 -0800, hennaheto wrote:
> the error message that gives me is "Unexpected Zope exception:
> ZExceoptions.NotFound - Site Error An error was encountered while
> publishing this resource. Resource not found Sorry, the requested
> resource does not exist. Check the URL and try again. Resource:
> http://mysite.com/a/blogger Troubleshooting Suggestions The URL may be
> incorrect. The parameters passed to this resource may be incorrect.
> A resource that this resource relies on may be encountering an
> error..................."
>
> the blog is located at : http://mysite.com/a/ I don’t know where it is
> getting /blogger from. I am trying the MetaWeblog API my API URL is :
> http://mysite.com/a/ useboolean for publish is checked and I inserted
> my API key (it is at the top of my blog when logged in)

What client are you using and what version of Quills?

hennaheto

unread,
Mar 1, 2010, 7:27:34 PM3/1/10
to Plone: quills
Quills 1.7.0 and I am trying ScribeFire, should I try a different
client? Do you have a suggestion?

On Mar 1, 4:22 pm, Tim Knapp <duf...@kokorice.org> wrote:
> On Mon, 2010-03-01 at 16:16 -0800, hennaheto wrote:
> > the error message that gives me is  "Unexpected Zope exception:
> > ZExceoptions.NotFound - Site Error An error was encountered while
> > publishing this resource.  Resource not found Sorry, the requested
> > resource does not exist.  Check the URL and try again. Resource:

> >http://mysite.com/a/bloggerTroubleshooting Suggestions The URL may be


> > incorrect.  The parameters passed to this resource may be incorrect.
> > A resource that this resource relies on may be encountering an
> > error..................."
>

> > the blog is located at :http://mysite.com/a/I don’t know where it is


> > getting /blogger from.  I am trying the MetaWeblog API my API URL is :

> >http://mysite.com/a/useboolean for publish is checked and I inserted


> > my API key (it is at the top of my blog when logged in)
>
> What client are you using and what version of Quills?
>
>
>
>
>
> > On Mar 1, 3:57 pm, Tim Knapp <duf...@kokorice.org> wrote:
> > > Hi,
>
> > > Its just the quills blog URL and your plone username/password and you
> > > need to enter the API Key but forgotten how to get that. Might need to
> > > grep for that ;) I do recall this coming up on the ML in the past.
>
> > > -Tim
>
> > > On Mon, 2010-03-01 at 15:19 -0800, hennaheto wrote:
> > > > I have been trying to figure out how to use the remote blogging API in
> > > > quills and I cant seem to get it to work.  Do i need to configure it?
> > > > Should I be using MetaWeblog? What is the URL I should use? Do i need
> > > > to check "use boolean for publish"?  Will this work if I use CAS for
> > > > authentication?- Hide quoted text -
>

> > > - Show quoted text -- Hide quoted text -

Tim Knapp

unread,
Mar 1, 2010, 7:37:25 PM3/1/10
to plone-...@googlegroups.com
On Mon, 2010-03-01 at 16:27 -0800, hennaheto wrote:
> Quills 1.7.0 and I am trying ScribeFire, should I try a different
> client? Do you have a suggestion?

No, I'm using ScribeFire too and it works fine. I don't have the publish
is checked option selected, though, and I've got an older version of
Quills (1.5.0a3). Try deselecting that option. Also I find selecting the
'publish in drafts' option when publishing allows them to be
successfully published too.

Jan Hackel

unread,
Mar 2, 2010, 6:09:16 AM3/2/10
to plone-...@googlegroups.com
With ScribeFire try the following:
- launch the account wizard ("Add")
- enter the blog url
- ScribeFire will fail to detect the blog
- Choose "Configure Manually"
- Select Metaweblog API" as blog system type, and re-enter the blog URL.
- Choose "Next", ScribeFire will ask for your username and password, and
should then find the blog. The API Key which appears just below the blog title
in the browser is not required.

For authentication to work the "Products.MetaWeblogPASPlugin" must be
installed via "Add-on products". The egg "quills.remoteblogging" is required
too, but does not have to (and cannot) be installed via "Add-on products".

Grüße
Jan Hackel

On Tuesday 02 March 2010 hennaheto wrote:
> Quills 1.7.0 and I am trying ScribeFire, should I try a different
> client? Do you have a suggestion?
>

Reply all
Reply to author
Forward
0 new messages