How to use play-socket.io with play 2.5.x

26 views
Skip to first unread message

Armin Ghoreishi

unread,
Feb 13, 2019, 4:17:19 PM2/13/19
to Play Framework [deprecated]
I've got this when I added play-socket.io to the libraries.
Can't we use play-socket.io with play 2.5.x?

ava.lang.NoSuchMethodError: play.api.Mode$.Dev()Lscala/Enumeration$Value;
    at play.core.server.DevServerStart$$anonfun$mainDev$1.apply(DevServerStart.scala:94)
    at play.core.server.DevServerStart$$anonfun$mainDev$1.apply(DevServerStart.scala:65)
    at play.utils.Threads$.withContextClassLoader(Threads.scala:21)
    at play.core.server.DevServerStart$.mainDev(DevServerStart.scala:64)
    at play.core.server.DevServerStart$.mainDevHttpMode(DevServerStart.scala:54)
    at play.core.server.DevServerStart.mainDevHttpMode(DevServerStart.scala)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at play.runsupport.Reloader$.startDevMode(Reloader.scala:234)
    at play.sbt.run.PlayRun$$anonfun$playRunTask$1$$anonfun$apply$2$$anonfun$apply$3.devModeServer$lzycompute$1(PlayRun.scala:74)
    at play.sbt.run.PlayRun$$anonfun$playRunTask$1$$anonfun$apply$2$$anonfun$apply$3.play$sbt$run$PlayRun$$anonfun$$anonfun$$anonfun$$devModeServer$1(PlayRun.scala:74)
    at play.sbt.run.PlayRun$$anonfun$playRunTask$1$$anonfun$apply$2$$anonfun$apply$3.apply(PlayRun.scala:100)
    at play.sbt.run.PlayRun$$anonfun$playRunTask$1$$anonfun$apply$2$$anonfun$apply$3.apply(PlayRun.scala:53)
    at scala.Function1$$anonfun$compose$1.apply(Function1.scala:47)

Igmar Palsenberg

unread,
Feb 13, 2019, 4:17:56 PM2/13/19
to Play Framework [deprecated]


On Wednesday, 13 February 2019 22:17:19 UTC+1, Armin Ghoreishi wrote:
I've got this when I added play-socket.io to the libraries.
Can't we use play-socket.io with play 2.5.x?

No, it requires 2.6, since it depends on Akka streams.

Igmar
Reply all
Reply to author
Forward
0 new messages