The error on “Recaptcha” when updating devise to version 2.1.0

202 views
Skip to first unread message

Maifa

unread,
Feb 13, 2012, 12:48:00 PM2/13/12
to Devise
The devise was completely returning a flash alert when "Recaptcha"
caught wrong keywords.

But after I updated devise version from 1.4.7 to 2.1.0, it always
says, "undefined method `render_with_scope' for #"

Does anyone have the same problem? Is this all because of
compatibility of devise 2.1.0 with "Recaptcha"?

Carlos Antonio da Silva

unread,
Feb 13, 2012, 1:08:27 PM2/13/12
to plataforma...@googlegroups.com
Devise has changed its internals and "render_with_scope" does not exist anymore. Make sure you didn't override any controller from Devise and copied code from the old version, if you did that, you'll have to check the new controller code and change as accordingly.

If that's now you, perhaps some gem you're using might have a controller doing that, you need to check your dependencies as well.

-- 
At.
Carlos Antonio

Maifa

unread,
Feb 14, 2012, 7:41:44 PM2/14/12
to Devise
Thanks. You are right!


On 2月14日, 午前3:08, Carlos Antonio da Silva
> > compatibility of devise 2.1.0 with "Recaptcha"?- 引用テキストを表示しない -
>
> - 引用テキストを表示 -
Reply all
Reply to author
Forward
0 new messages