Stack level too deep error on signup template

203 views
Skip to first unread message

tcc

unread,
Apr 15, 2010, 2:55:23 PM4/15/10
to Devise
Not sure if this is more of a Rails 3.beta3 or devise 1.1.rc1 error?

anyone see this error?

Started GET "/users/sign_up" for 127.0.0.1 at 2010-04-15 11:53:34
Processing by Devise::RegistrationsController#new as HTML

ActionView::Template::Error (stack level too deep) on line #6 of /
Users/tcc/rails_3_devise/app/views/devise/registrations/new.html.erb:
3: <%= form_for(resource, :as => resource_name, :url =>
registration_path(resource_name)) do |f| %>
4: <%= devise_error_messages! %>
5:
6: <p><%= f.label :email %></p>
7: <p><%= f.text_field :email %></p>
8:
9: <p><%= f.label :password %></p>

app/views/devise/registrations/new.html.erb:6:in
`_render_template__160276350_2202163960_0'
app/views/devise/registrations/new.html.erb:3:in
`_render_template__160276350_2202163960_0'

Rendered /Library/Ruby/Gems/1.8/gems/actionpack-3.0.0.beta3/lib/
action_dispatch/middleware/templates/rescues/_trace.erb (2.4ms)
Rendered /Library/Ruby/Gems/1.8/gems/actionpack-3.0.0.beta3/lib/
action_dispatch/middleware/templates/rescues/_request_and_response.erb
(521.2ms)
Rendered /Library/Ruby/Gems/1.8/gems/actionpack-3.0.0.beta3/lib/
action_dispatch/middleware/templates/rescues/template_error.erb within
rescues/layo

Hates_

unread,
Apr 16, 2010, 7:40:59 PM4/16/10
to Devise

Hates_

unread,
Apr 17, 2010, 5:12:15 AM4/17/10
to Devise
I cleared out my gems in /vendor, upgraded everything to the latest
version, did a fresh "bundle install" and this problem now seems to
have resolved itself.

tcc

unread,
Apr 17, 2010, 9:43:13 PM4/17/10
to Devise
thanks, i reinstalled the haml 3.0.0.beta3 gem and the problem went
away.
Reply all
Reply to author
Forward
0 new messages