plastimatch convert error

51 views
Skip to first unread message

Justin Malimban

unread,
Sep 15, 2020, 4:08:42 AM9/15/20
to Plastimatch
Hello!

When I use ./plastimatch convert --input /dicom/path --output-img /output/path/img.nii.gz, I get an error saying " Sorry, could not load input as any known type". This does not happen when I do this in platimatch installed in windows but on our cluster wherein I built plastimatch from the source, apparently I get this error. Now, I have tried other CT data that I have and it worked so I think this is problem is specific to my dataset. I just don't understand why in windows it works but in linux, it doesn't.

Does anyone know what the problem could be?

Justin

fcj...@gmail.com

unread,
Sep 15, 2020, 11:18:36 PM9/15/20
to Plastimatch
Hi Justin:
    This problem seems to be the same as I encountered in this post:

Sharp, Gregory C.

unread,
Sep 18, 2020, 5:50:22 PM9/18/20
to plast...@googlegroups.com

Hi Justin,

Could you also check DCMTK_DIR in your CMakeCache.txt as described here?

 

https://groups.google.com/g/plastimatch/c/9ZDeiSZPHag/m/b_Eyz0HvAAAJ

 

Thank you,

Greg

 

From: plast...@googlegroups.com <plast...@googlegroups.com> On Behalf Of fcj...@gmail.com
Sent: Tuesday, September 15, 2020 11:19 PM
To: Plastimatch <plast...@googlegroups.com>
Subject: [Plastimatch] Re: plastimatch convert error

 

        External Email - Use Caution        

--
You received this message because you are subscribed to the Google Groups "Plastimatch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to plastimatch...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/plastimatch/f820053d-4431-497f-9cef-fe815a82a617n%40googlegroups.com.

The information in this e-mail is intended only for the person to whom it is addressed. If you believe this e-mail was sent to you in error and the e-mail contains patient information, please contact the Mass General Brigham Compliance HelpLine at http://www.massgeneralbrigham.org/complianceline . If the e-mail was sent to you in error but does not contain patient information, please contact the sender and properly dispose of the e-mail.

Sharp, Gregory C.

unread,
Sep 18, 2020, 7:15:49 PM9/18/20
to plast...@googlegroups.com

One more thing to try.  In your build directory, type "make test", we will be able to see more generally if something went wrong with the build.

Justin Malimban

unread,
Oct 7, 2020, 9:06:56 AM10/7/20
to Plastimatch
Hello!

Sorry for the delayed response. It says DCMTK_DIR:PATH=DCMTK_DIR-NOTFOUND

Justin Malimban

unread,
Oct 7, 2020, 12:32:24 PM10/7/20
to Plastimatch
I also tried to do "make test". Out of 571, 18 tests failed.

97% tests passed, 18 tests failed out of 571

Total Test time (real) = 165.77 sec

The following tests FAILED:
186 - plm-convert-dicom-a (Failed)
187 - plm-convert-dicom-a-stats (Failed)
188 - plm-convert-dicom-a-check (Failed)
189 - plm-convert-dicom-b (Failed)
191 - plm-convert-dicom-b-check (Failed)
192 - plm-convert-dicom-c (Failed)
193 - plm-convert-dicom-c-stats (Failed)
194 - plm-convert-dicom-c-check (Failed)
197 - plm-convert-dicom-f (Failed)
198 - plm-convert-dicom-donut-a (Failed)
199 - plm-convert-dicom-donut-a-stats (Failed)
200 - plm-convert-dicom-donut-a-check (Failed)
201 - plm-convert-dicom-donut-b (Failed)
202 - plm-convert-dicom-donut-b-stats (Failed)
203 - plm-convert-dicom-donut-b-check (Failed)
205 - plm-convert-cxt (Failed)
206 - plm-convert-cxt-stats (Failed)
207 - plm-convert-cxt-check (Failed)
Errors while running CTest
make: *** [test] Error 8


Reply all
Reply to author
Forward
0 new messages