Problemy z krojem fontów pomiędzy literami ł i ń

3 views
Skip to first unread message

Baobam

unread,
Sep 16, 2006, 6:22:55 PM9/16/06
to
Cześć,

Od pewnego czasu (z rok, dwa) mam problem z fontami w Windowsie i wreszcie
postawnowiłem coś z tym zrobić. Chodzi o to, że w niektórych oknach po
literze ń czcionka zmienia się na jakąś bitmapową a po literze ł (w tym
samym ciągu tekstowym) powraca do normalności. Dzieje się tak zawsze tylko
między tymi dwoma literami, niezależnie od czcionki którą piszę. Inne
polskie znaki nie powodują tego efektu. Tak więc np. po napisaniu "Toń
głęboka" mam początkowo krój, którym pisałem (np. Courier New CE(!))
później (od ń do ł) jakieś bitmapowe fonty i (od ł) znowu Courier. Tutaj
puszczam screena jak to wygląda.
http://img54.imageshack.us/img54/2326/polskieja2.jpg
Górna część zdjęcia to jakiś edytor - pisałem w Courier New, zestaw znaków
europejski, po literze ń pojawia się ta czcionka, po ł znowu Courier New
(tego nie ma na screenie).
Fragment obrazka poniżej to szczegóły dziennika zdarzeń Windowsa XP. Jak
widać między ł a ń jest inny krój czcionki. W Wordzie i innych edytorach
mogę normalnie napisać tekst tymi czcionkami zawierający ł i ń i nie ma
tego. Niestety w innych edytorach i oknach dialogowych jest. Co mogę
zrobić, żeby się tego pozbyć?

Dzięki za pomoc.
--
Pozdrawiam,
Baobam

j_marek

unread,
Sep 17, 2006, 10:33:44 AM9/17/06
to
W wiadomości: 1w2m1xrtprcyu$.14yrzfzs8z51b$.d...@40tude.net,
Baobam <bao...@o2.pl> napisał(a):
[...]

Witam!

Witam w klubie, mam ten sam problem. Niestety nie udało mi się na niego
znaleźć rozwiązania mimo prób. A nie chce reinstalować systemu. Zatem
aktualnie musze przeboleć jakoś wygląd niektórych napisów na ekranie.

Jedyne co udało mi się, znaleźć to była informacja na grupie:
http://groups.google.pl/group/pl.comp.lang.delphi/browse_frm/thread/27eddba0246eddbc/65f11c95aded6097?lnk=st&q=Polskie+%C5%84&rnum=2&hl=pl#65f11c95aded6097

Moje poprzednie pytanie na grupie z opisem problemu:
http://groups.google.pl/group/pl.comp.os.ms-windows.winnt/browse_frm/thread/877da664f4d346bc/379482b3674278a0?lnk=st&q=Polskie+%C5%84&rnum=3&hl=pl#379482b3674278a0

Niestety jak napisałem wcześniej, nie znam rozwiązania tego problemu.

--
Pozdrawiam,
Marek Janaszewski
[ j_marek(małpa)gazeta(kropka)pl ]
[ == USUN_TO. z adresu == ]

PureNick

unread,
Sep 17, 2006, 12:37:02 PM9/17/06
to
[...]

>
> Witam w klubie, mam ten sam problem. Niestety nie udało mi się na niego
> znaleźć rozwiązania mimo prób. A nie chce reinstalować systemu. Zatem
> aktualnie musze przeboleć jakoś wygląd niektórych napisów na ekranie.
>
> Jedyne co udało mi się, znaleźć to była informacja na grupie:
> http://groups.google.pl/group/pl.comp.lang.delphi/browse_frm/thread/27eddba0246eddbc/65f11c95aded6097?lnk=st&q=Polskie+%C5%84&rnum=2&hl=pl#65f11c95aded6097
>
>
> Moje poprzednie pytanie na grupie z opisem problemu:
> http://groups.google.pl/group/pl.comp.os.ms-windows.winnt/browse_frm/thread/877da664f4d346bc/379482b3674278a0?lnk=st&q=Polskie+%C5%84&rnum=3&hl=pl#379482b3674278a0
>
>
> Niestety jak napisałem wcześniej, nie znam rozwiązania tego problemu.
>

Dołączam do groan pokrzywdzonych, oto mój dowód cierpienia :)
http://gsx.pl/~ibozaur/TEMP/font_problem.jpg
Pozdruffka

--
~~/PP/~~/SF/~~

Radosław Sokół

unread,
Sep 17, 2006, 1:09:13 PM9/17/06
to
Baobam napisał(a):

> Od pewnego czasu (z rok, dwa) mam problem z fontami w Windowsie i wreszcie
> postawnowiłem coś z tym zrobić. Chodzi o to, że w niektórych oknach po
> literze ń czcionka zmienia się na jakąś bitmapową a po literze ł (w tym
> samym ciągu tekstowym) powraca do normalności. Dzieje się tak zawsze tylko

To jest błąd jednej ze standardowych kontrolek Windows. Ktoś
widać potraktował niektóre kody unikodowe jako znaki formatujące.
Ja to u siebie widzę na chyba 40 maszynach w zasadzie jedynie
w oknach Windows Update i nigdzie indziej, choć pojedyncze
programy również mogą być "affected by this bug".

--
|""""""""""""""""""""""""""""""""""""""""""""""""""""""""""|
| Radosław Sokół | http://www.grush.one.pl/ |
| | Administrator, Politechnika Śląska |
\................... Microsoft MVP ......................../

Michal Kawecki

unread,
Sep 17, 2006, 1:43:16 PM9/17/06
to
Użytkownik "Radosław Sokół" <rso...@magsoft.com.pl> napisał w wiadomości
news:20060917...@grush.one.pl...

> Baobam napisał(a):
>> Od pewnego czasu (z rok, dwa) mam problem z fontami w Windowsie i
>> wreszcie
>> postawnowiłem coś z tym zrobić. Chodzi o to, że w niektórych oknach po
>> literze ń czcionka zmienia się na jakąś bitmapową a po literze ł (w tym
>> samym ciągu tekstowym) powraca do normalności. Dzieje się tak zawsze
>> tylko
>
> To jest błąd jednej ze standardowych kontrolek Windows. Ktoś
> widać potraktował niektóre kody unikodowe jako znaki formatujące.
> Ja to u siebie widzę na chyba 40 maszynach w zasadzie jedynie
> w oknach Windows Update i nigdzie indziej, choć pojedyncze
> programy również mogą być "affected by this bug".


Na przykład OE. Denerwujące jest to nieco.
--
M. [MS-MVP]
/odpowiadając zmień px na pl/

Baobam

unread,
Sep 17, 2006, 2:43:32 PM9/17/06
to
Dnia Sun, 17 Sep 2006 19:09:13 +0200, Radosław Sokół napisał(a):

> Baobam napisał(a):
>> Od pewnego czasu (z rok, dwa) mam problem z fontami w Windowsie i wreszcie
>> postawnowiłem coś z tym zrobić. Chodzi o to, że w niektórych oknach po
>> literze ń czcionka zmienia się na jakąś bitmapową a po literze ł (w tym
>> samym ciągu tekstowym) powraca do normalności. Dzieje się tak zawsze tylko
>
> To jest błąd jednej ze standardowych kontrolek Windows. Ktoś
> widać potraktował niektóre kody unikodowe jako znaki formatujące.
> Ja to u siebie widzę na chyba 40 maszynach w zasadzie jedynie
> w oknach Windows Update i nigdzie indziej, choć pojedyncze
> programy również mogą być "affected by this bug".

Aha. Dobrze przynajmniej wiedzieć, że właściwie nie mamy na to wpływu. Choć
szkoda, że MS nie wydał na to żadnej łatki. Ale mam wrażenie, że czysty XP
z SP1 nie robił takich numerów, więc może to wina którejś z aktualizacji?
--
Pozdrawiam,
Baobam

Andrzej P. Wozniak

unread,
Sep 18, 2006, 4:32:24 PM9/18/06
to
Osoba podpisana jako Baobam <bao...@o2.pl> w artykule
<news:1w2m1xrtprcyu$.14yrzfzs8z51b$.d...@40tude.net> pisze:

> Cześć,
>
> Od pewnego czasu (z rok, dwa)

To znaczy, że system masz od dwóch lat?

> mam problem z fontami w Windowsie i wreszcie
> postawnowiłem coś z tym zrobić. Chodzi o to, że w niektórych oknach po
> literze ń czcionka zmienia się na jakąś bitmapową a po literze ł

Nie tylko po literze "ł". Powrót do właściwej czcionki następuje po dowolnej
literze z ogonkami różnej od małego "ń".
Błąd jest we wszystkich znalezionych przeze mnie wersjach kontrolki "Rich
Text Edit Control, v3.0", czyli od co najmniej siedmiu lat lat. Najstarszy
plik, jaki znalazłem, jest w pakiecie MS Office 2000. Plik RICHED20.DLL ma
datę 1999-01-25, numer wewnętrzny wersji 5.30.11.2410.

Zwracam uwagę, że nazwa pliku jest myląca, bo pochodzi od wcześniejszej,
poprawnie działającej wersji kontrolki - "Rich Text Edit Control, v2.0",
dostępnej np. w Win98/SE czy w MS Office 97 (numer wewnętrzny 5.0.x.x).
Aktualizacja kontrolki v2.0 razem z v3.0 dla starszych systemów operacyjnych
jest opisana tu: <http://support.microsoft.com/kb/249973/>,
wersja polska dostępna np. tu:
<ftp://ftp.pitow.wroc.pl/arch/microsoft/win98/critical/pl/249973pol8.exe>.

--
Andrzej P. Woźniak us...@pochta.onet.pl (zamień miejscami z<->h w adresie)

Marsjanin

unread,
Sep 18, 2006, 5:40:08 PM9/18/06
to
Rok 2006 - wrzesień. Dokładnie to niedziela, 17-go. Nieco po 20-ej.
Nagle zza rogu Baobam wrzuca na pl.comp.os.ms-windows.winnt:

> Aha. Dobrze przynajmniej wiedzieć, że właściwie nie mamy na to
> wpływu. Choć szkoda, że MS nie wydał na to żadnej łatki. Ale mam
> wrażenie, że czysty XP z SP1 nie robił takich numerów, więc może to
> wina którejś z aktualizacji?

Witam, miałem taki problem w komunikatorze Konnekt, którego już
niestety nie używam; oto link do postu na forum:

http://www.konnekt.info/forum/index.php?showtopic=3311

Używałem wtedy Windowsa ME lub 98, a podziałał plik DLL z Windowsa XP.
Ów XP na pewno nie miał SP2, ale raczej na pewno miał SP1.

--
Pozdrawiam, Marsjanin. Gadu-Gadu : 4548104
Nie zawsze bluescreen pod windą jest przez windę !!!
Nic nie gra. Cudowna cisza... :-]

Michal Kawecki

unread,
Sep 18, 2006, 5:54:01 PM9/18/06
to
Użytkownik "Andrzej P. Wozniak" <us...@poczta.onet.pl.invalid> napisał w
wiadomości news:een3m5$rpo$1...@mx1.internetia.pl...

> Osoba podpisana jako Baobam <bao...@o2.pl> w artykule
> <news:1w2m1xrtprcyu$.14yrzfzs8z51b$.d...@40tude.net> pisze:
[...]

>> mam problem z fontami w Windowsie i wreszcie
>> postawnowiłem coś z tym zrobić. Chodzi o to, że w niektórych oknach po
>> literze ń czcionka zmienia się na jakąś bitmapową a po literze ł
>
> Nie tylko po literze "ł". Powrót do właściwej czcionki następuje po
> dowolnej
> literze z ogonkami różnej od małego "ń".
> Błąd jest we wszystkich znalezionych przeze mnie wersjach kontrolki "Rich
> Text Edit Control, v3.0", czyli od co najmniej siedmiu lat lat. Najstarszy
[...]

To w takim razie chodzi o zupełnie inny problem, bo u mnie on się pojawił
ZTCP jakieś dwa-trzy miesiące temu. W każdym razie wiosną na pewno go nie
było.

Andrzej P. Wozniak

unread,
Sep 18, 2006, 7:47:55 PM9/18/06
to
Osoba podpisana jako Michal Kawecki <kkw...@o2.px> w artykule
<news:nh4nee...@kwinto.prv> pisze:

> Użytkownik "Andrzej P. Wozniak" <us...@poczta.onet.pl.invalid> napisał w
> wiadomości news:een3m5$rpo$1...@mx1.internetia.pl...
>> Osoba podpisana jako Baobam <bao...@o2.pl> w artykule
>> <news:1w2m1xrtprcyu$.14yrzfzs8z51b$.d...@40tude.net> pisze:
> [...]
>>> mam problem z fontami w Windowsie i wreszcie
>>> postawnowiłem coś z tym zrobić. Chodzi o to, że w niektórych oknach po
>>> literze ń czcionka zmienia się na jakąś bitmapową a po literze ł
>> Nie tylko po literze "ł". Powrót do właściwej czcionki następuje po
>> dowolnej literze z ogonkami różnej od małego "ń".
>> Błąd jest we wszystkich znalezionych przeze mnie wersjach kontrolki "Rich
>> Text Edit Control, v3.0", czyli od co najmniej siedmiu lat lat.

> To w takim razie chodzi o zupełnie inny problem, bo u mnie on się pojawił
> ZTCP jakieś dwa-trzy miesiące temu. W każdym razie wiosną na pewno go nie
> było.

Może Tobie.
Obrazki przytoczone w tym wątku ilustrują właśnie to, co opisałem. Błąd
ujawnia się w programach tam, gdzie używają wspomnianej kontrolki RichEdit,
a nie MSHTML.
W przypadku OE efekt ten zobaczyć można np. w temacie wiadomości otwartej do
czytania lub powtórnej edycji w oddzielnym oknie.
W WinXP SP2 włączenie w OE ustawienia "Czytaj wszystkie wiadomości w postaci
zwykłego tekstu" skutkuje włączeniem kontrolki RichEdit również dla
wyświetlania treści wiadomości (jak już dwa lata temu pisał o tym Grzesiek
Niemirowski) - wtedy efekt jest widoczny także w oknie podglądu wiadomości.
Stosowny zrzut ekranu załączam. Czcionkę dobrałem celowo taką, żeby różnice
były rażące:
http://www.olszynka.pl/usher/usenet/czytniki/OE_RichEdit.png
Widać tu inną ciekawostkę - w temacie występuje wcześniej opisany efekt, na
podglądzie treści źle wyświetlana jest tylko litera "ń", a w oknie edycji
treść jest OK.

--
Andrzej P. Woźniak us...@pochta.onet.pl (zamień miejscami z<->h w adresie)

...przed odesłaniem kogoś do jakiejś strony zawsze sprawdzam,
czy to co na niej się znajduje jest zgodne z moją wiedzą.
-- Michał Kawecki na pl.comp.nowe-programy

Radosław Sokół

unread,
Sep 19, 2006, 2:05:03 PM9/19/06
to
Baobam napisał(a):

> Aha. Dobrze przynajmniej wiedzieć, że właściwie nie mamy na to wpływu. Choć
> szkoda, że MS nie wydał na to żadnej łatki. Ale mam wrażenie, że czysty XP
> z SP1 nie robił takich numerów, więc może to wina którejś z aktualizacji?

Prawdę mówiąc pamiętam ten błąd praktycznie od zawsze.

Andrzej P. Wozniak

unread,
Sep 19, 2006, 2:35:31 PM9/19/06
to
Osoba podpisana jako Marsjanin <08.2006...@marsjanin.tk> w artykule
<news:13hv4ktyygybq$.d...@marsjanin.tk> pisze:

> Rok 2006 - wrzesień. Dokładnie to niedziela, 17-go. Nieco po 20-ej.
> Nagle zza rogu Baobam wrzuca na pl.comp.os.ms-windows.winnt:
>
>> Aha. Dobrze przynajmniej wiedzieć, że właściwie nie mamy na to
>> wpływu. Choć szkoda, że MS nie wydał na to żadnej łatki. Ale mam
>> wrażenie, że czysty XP z SP1 nie robił takich numerów, więc może to
>> wina którejś z aktualizacji?
>
> Witam, miałem taki problem w komunikatorze Konnekt, którego już
> niestety nie używam; oto link do postu na forum:
>
> http://www.konnekt.info/forum/index.php?showtopic=3311
>
> Używałem wtedy Windowsa ME lub 98, a podziałał plik DLL z Windowsa XP.
> Ów XP na pewno nie miał SP2, ale raczej na pewno miał SP1.

Przytaczam to, co napisałeś...
/----
Niestety, a może stety - "na czuja" wziąłem od kumpla z XP...
[...]
wersja: 5.50.99.2009
opis: Rich Text Edit Control, v5.0
data: środa, 16 czerwca 2004 r., 23:36:48
rozmiar: 965 400 b
\----
...a co oznacza, że nie dokończyłem przeglądu plików, przynajmniej z
pakietów MS Office.

Ten plik nie jest bowiem z Windows, ale z pakietu MS Office 2003. Pod
Win98SE faktycznie działa, ale nie mam przekonania, czy będzie działać pod
Win95, bo MSO2k3 jako całość pod Win9x nie działa. Poza tym na forum MSFN
zgłaszano zastrzeżenia do bibliotek tej wersji (również nowszych):
http://www.msfn.org/board/lofiversion/index.php/t72448.html
/----
Surprisingly, riched20.dll version 5.50.99.2012 (from Office 2003) has the
problem of 5.3x versions corrected only partially, just accented letters
display correctly, but other signs (with code 132, 134, 135, 137, 149, 150,
151, 155, 161, 162, 178, 189, 255) change the font again.
\----
W MS Office XP jest kontrolka w wersji 4.0, którą polecano na forum MSFN
(najmniej zastrzeżeń) i która na pewno pod wszystkimi wersjami Windows
będzie działać poprawnie.

Zaktualizowane kontrolki v4.0 i v5.0 są w Service Packach i kolejnych
aktualizacjach dostępnych na Office Update, ale stamtąd nie da się ich tak
łatwo wyciągnąć.

Gwoli uzupełnienia - w Win2003 jest kontrolka v3.0 (5.31.x.x) - działająca
niepoprawnie, jak pozostałe w tej wersji.

Jak z tego przeglądu wynika, tylko zainstalowanie MS Office XP lub 2003
(ewentualnie wyciągnięcie stamtąd samych bibliotek) oznacza ustąpienie
kłopotów w dowolnej wersji Windows.
Zalecane najnowsze pliki v4.0 (5.40) są dostepne do pobrania tu:
http://www.mdgx.com/files/RICHED9X.EXE
Spośród plików zawartych w tym archiwum przydatne są również:
- aktualizacja biblioteki USP10.DLL wywoływanej z kontrolki RICHED20.DLL
(trzeba je koniecznie zainstalować razem);
- kontrolka RICHTX32.OCX dla Internet Explorera.

Jesli ktoś zechce sprawdzić działanie i podać numer wersji RICHED20.DLL
dostępnej w MS Office 2007, to będzie już chyba ostateczne rozwiązanie
zagadki.

goomish

unread,
Sep 19, 2006, 2:50:33 PM9/19/06
to
Dnia 2006-09-19, *Andrzej P. Wozniak* napisał(a):

> Jak z tego przeglądu wynika, tylko zainstalowanie MS Office XP lub 2003
> (ewentualnie wyciągnięcie stamtąd samych bibliotek) oznacza ustąpienie
> kłopotów w dowolnej wersji Windows.

Niespecjalnie. Mam MS Office 2003 (instalowany na czysto, nie jako
aktualizacja), na firmowych komputerach jest kilka egzemplarzy 2002 (XP) i
też występuje ten błąd. Najczęściej ja zauważam go w okienkach szczegółów
zdarzenia w Podglądzie Zdarzeń, czasami Resource Hackerowi też się zdarza.
W OE nie widziałem ale to pewnie dlatego, że właściwie go nie używam.

--
Tomasz Zenger (goomish)
[gg: 6653792]
[ICQ: 275830896]

Michal Kawecki

unread,
Sep 19, 2006, 2:50:18 PM9/19/06
to
Użytkownik "Andrzej P. Wozniak" <us...@poczta.onet.pl.invalid> napisał w
wiadomości news:eeph6c$ruu$1...@mx1.internetia.pl...

> Osoba podpisana jako Marsjanin <08.2006...@marsjanin.tk> w artykule
> <news:13hv4ktyygybq$.d...@marsjanin.tk> pisze:
[...]

> Jak z tego przeglądu wynika, tylko zainstalowanie MS Office XP lub 2003
> (ewentualnie wyciągnięcie stamtąd samych bibliotek) oznacza ustąpienie
> kłopotów w dowolnej wersji Windows.

Mam zainstalowany Office 2003 SP2 i opisywany tutaj problem. Poprzednio był
to Office 2000 i problemu ZTCP nie było. Być może tutaj trzeba szukać źródła
problemu, ale nie mam teraz głowy do wyciągania starych obrazów partycji.
Może kiedyś to sprawdzę.

Radosław Sokół

unread,
Sep 19, 2006, 3:02:12 PM9/19/06
to
goomish napisał(a):

> Niespecjalnie. Mam MS Office 2003 (instalowany na czysto, nie jako
> aktualizacja), na firmowych komputerach jest kilka egzemplarzy 2002 (XP) i
> też występuje ten błąd. Najczęściej ja zauważam go w okienkach szczegółów

Potwierdzam. Mam Office 2003 i cały czas błąd występuje
na kilkudziesięciu maszynach.

Andrzej P. Wozniak

unread,
Sep 19, 2006, 3:13:03 PM9/19/06
to
Osoba podpisana jako Michal Kawecki <kkw...@o2.px> w artykule
<news:6bepee...@kwinto.prv> pisze:

> Użytkownik "Andrzej P. Wozniak" <us...@poczta.onet.pl.invalid> napisał w
> wiadomości news:eeph6c$ruu$1...@mx1.internetia.pl...
>> Osoba podpisana jako Marsjanin <08.2006...@marsjanin.tk> w artykule
>> <news:13hv4ktyygybq$.d...@marsjanin.tk> pisze:
> [...]
>> Jak z tego przeglądu wynika, tylko zainstalowanie MS Office XP lub 2003
>> (ewentualnie wyciągnięcie stamtąd samych bibliotek) oznacza ustąpienie
>> kłopotów w dowolnej wersji Windows.
> Mam zainstalowany Office 2003 SP2 i opisywany tutaj problem. Poprzednio
> był to Office 2000 i problemu ZTCP nie było.

Dziwne - opisujesz na odwrót, niż jest w rzeczywistości (sprawdzałem na
Win98SE i WinXPSP2).

> Być może tutaj trzeba
> szukać źródła problemu, ale nie mam teraz głowy do wyciągania starych
> obrazów partycji. Może kiedyś to sprawdzę.

Może sprawdź też wersje pliku USP10.DLL.

Andrzej P. Wozniak

unread,
Sep 19, 2006, 3:20:23 PM9/19/06
to
Osoba podpisana jako goomish <gum12-b...@gazeta.pl> w artykule
<news:a8jr9bgk...@fqdn.goomisha.pl> pisze:

> Dnia 2006-09-19, *Andrzej P. Wozniak* napisał(a):
>
>> Jak z tego przeglądu wynika, tylko zainstalowanie MS Office XP lub 2003
>> (ewentualnie wyciągnięcie stamtąd samych bibliotek) oznacza ustąpienie
>> kłopotów w dowolnej wersji Windows.
>
> Niespecjalnie. Mam MS Office 2003 (instalowany na czysto, nie jako
> aktualizacja),

Jak wynika z dyskusji na MSFN - tu na pewno będą błędy (bo to v5.0), w
różnej ilości zależnie od wersji.

> na firmowych komputerach jest kilka egzemplarzy 2002 (XP) i
> też występuje ten błąd.

A tu zależy od wersji. Na najnowszą bibliotekę v4.0 (zalecaną 5.40.11.2218)
nikt nie narzekał, ale może to dlatego, że jeszcze mało kto ją sprawdził.

Przypominam, że część błędów może być związana z USP10.DLL, a nie
bezpośrednio z RICHED20.DLL. Testy robiłem na komputerach bez MS Offfice,
więc wpływ mogą mieć jakieś inne biblioteki z tego pakietu (np. MSO.DLL czy
tablice konwersji stron kodowych).

Poza tym problemy mogą być niewidoczne w wersji anglojęzycznej Windows lub
przy ustawieniu języka angielskiego jako domyślnego. Tego nie sprawdzałem,
więc zrobię to przy nabliższej okazji i sprawdzę jeszcze Win2kSP4 (również
bez MSO).

Baobam

unread,
Sep 20, 2006, 5:19:38 AM9/20/06
to
Dnia Mon, 18 Sep 2006 22:32:24 +0200, Andrzej P. Wozniak napisał(a):

> Osoba podpisana jako Baobam <bao...@o2.pl> w artykule
> <news:1w2m1xrtprcyu$.14yrzfzs8z51b$.d...@40tude.net> pisze:
>
>> Cześć,
>>
>> Od pewnego czasu (z rok, dwa)
>
> To znaczy, że system masz od dwóch lat?

Nie. Od czterech. :D
--
Pozdrawiam,
Baobam

Marsjanin

unread,
Sep 20, 2006, 4:00:33 PM9/20/06
to
Rok 2006 - wrzesień. Dokładnie to wtorek, 19-go. Nieco po 20-ej.
Nagle zza rogu Andrzej P. Wozniak wrzuca na pl.comp.os.ms-windows.winnt:

> Ten plik nie jest bowiem z Windows, ale z pakietu MS Office 2003.
> Pod Win98SE faktycznie działa, ale nie mam przekonania, czy będzie

> działać pod Win95, [...]

No tak, ale czy tutaj ktoś jeszcze z tym systemem właśnie walczy?

> Jak z tego przeglądu wynika, tylko zainstalowanie MS Office XP lub
> 2003 (ewentualnie wyciągnięcie stamtąd samych bibliotek) oznacza
> ustąpienie kłopotów w dowolnej wersji Windows.
> Zalecane najnowsze pliki v4.0 (5.40) są dostepne do pobrania tu:
> http://www.mdgx.com/files/RICHED9X.EXE

Zaraz, no to trzeba by instalować Office, czy wystarczy pobrac teog
exe'ka?

--
Pozdrawiam, Marsjanin. WWW : marsjanin.tk
Na nadmorskich plażach panuje syf! Najgorsze jest deptanie po niedopałkach.

Andrzej P. Wozniak

unread,
Sep 21, 2006, 1:52:59 PM9/21/06
to
Osoba podpisana jako Marsjanin <08.2006...@marsjanin.tk> w artykule
<news:10x06c9r...@marsjanin.tk> pisze:

> Rok 2006 - wrzesień. Dokładnie to wtorek, 19-go. Nieco po 20-ej.
> Nagle zza rogu Andrzej P. Wozniak wrzuca na pl.comp.os.ms-windows.winnt:
>
>> Ten plik nie jest bowiem z Windows, ale z pakietu MS Office 2003.
>> Pod Win98SE faktycznie działa, ale nie mam przekonania, czy będzie
>> działać pod Win95, [...]
> No tak, ale czy tutaj ktoś jeszcze z tym systemem właśnie walczy?

Pomyśl, jakie byś zadał pytanie, gdybym napisał, że pod Win9x *nie*
sprawdzałem.

>> Jak z tego przeglądu wynika, tylko zainstalowanie MS Office XP lub
>> 2003 (ewentualnie wyciągnięcie stamtąd samych bibliotek) oznacza
>> ustąpienie kłopotów w dowolnej wersji Windows.
>> Zalecane najnowsze pliki v4.0 (5.40) są dostepne do pobrania tu:
>> http://www.mdgx.com/files/RICHED9X.EXE
> Zaraz, no to trzeba by instalować Office, czy wystarczy pobrac teog
> exe'ka?

Zależy od tego, co chcesz mieć. Chcesz mieć Office'a, to go instalujesz.
Chcesz nie mieć problemu, to:
- sprawdzasz, co masz i jak masz;
- jeśli masz źle (również po zainstalowaniu MSO), instalujesz łatkę;
- sprawdzasz jeszcze raz, jak jest i o przebiegu całej akcji informujesz
grupę.

Gdyby instalator łatki dla Win9x się buntował, że nie ta wersja systemu,
może lepiej użyć wersji http://www.mdgx.com/files/RICHEDNT.EXE

Marsjanin

unread,
Sep 21, 2006, 4:32:10 PM9/21/06
to
Rok 2006 - wrzesień. Dokładnie to czwartek, 21-go. Nieco po 19-ej.

Nagle zza rogu Andrzej P. Wozniak wrzuca na pl.comp.os.ms-windows.winnt:

Dzięki, teraz jeąsniej. Z tym, że:

>> No tak, ale czy tutaj ktoś jeszcze z tym systemem właśnie walczy?
> Pomyśl, jakie byś zadał pytanie, gdybym napisał, że pod Win9x *nie*
> sprawdzałem.

"Win9x" a "Win95" to duża różnica. Mi chodziło li tylko o to, że Win95
to totalny przeżytek, podczas, gdy 98 i ME jeszcze nie taki totalny. :-)
A "działalność" pliku poddawałeś w wątpliwość tylko dla 95-ki.

>> Zaraz, no to trzeba by instalować Office, czy wystarczy pobrac teog
>> exe'ka?
> Zależy od tego, co chcesz mieć. Chcesz mieć Office'a, to go
> instalujesz.

No tak, zakładam, że nie o to chodzi...

> Chcesz nie mieć problemu, to:
> - sprawdzasz, co masz i jak masz;

W sumie to mnie zasugerowałeś... Nie za bardzo mogę sprawdzić gdzie co
i jak mam... Póki co problemu u mnie nie ma, *albo* jest dobrze ukryty
(czytaj: nie używam widocznie programów z RichEdit'em). W sumie sam
nie wiem. :-)

--
Pozdrawiam, Marsjanin. Gadu-Gadu : 4548104

Nigdy nie instalujcie Linuksa, jeśli macie grypę. :-|

Andrzej P. Wozniak

unread,
Sep 21, 2006, 5:12:08 PM9/21/06
to
Osoba podpisana jako Marsjanin <08.2006...@marsjanin.tk> w artykule
<news:wgqlfzdhkphx$.d...@marsjanin.tk> pisze:

> Rok 2006 - wrzesień. Dokładnie to czwartek, 21-go. Nieco po 19-ej.
> Nagle zza rogu Andrzej P. Wozniak wrzuca na pl.comp.os.ms-windows.winnt:
>
> Dzięki, teraz jeąsniej. Z tym, że:
>
>>> No tak, ale czy tutaj ktoś jeszcze z tym systemem właśnie walczy?
>> Pomyśl, jakie byś zadał pytanie, gdybym napisał, że pod Win9x *nie*
>> sprawdzałem.
> "Win9x" a "Win95" to duża różnica. Mi chodziło li tylko o to, że Win95
> to totalny przeżytek,

Ale wciąż spotykany. Informację podałem, żeby zestawienie było bardziej
kompletne.

> podczas, gdy 98 i ME jeszcze nie taki totalny. :-)
> A "działalność" pliku poddawałeś w wątpliwość tylko dla 95-ki.

Sprawa zahacza o istotne różnice między Win95 a Win98 - obsługę Unikodu i
wersję IE, więc można spodziewać się różnych wyników.

>> Chcesz nie mieć problemu, to:
>> - sprawdzasz, co masz i jak masz;
> W sumie to mnie zasugerowałeś... Nie za bardzo mogę sprawdzić gdzie co
> i jak mam... Póki co problemu u mnie nie ma, *albo* jest dobrze ukryty
> (czytaj: nie używam widocznie programów z RichEdit'em). W sumie sam
> nie wiem. :-)

Występowanie problemów możesz sprawdzić w OE, jak to wcześniej pokazałem na
obrazku. Możesz nic nie instalować, sama informacja o obecnym stanie też
będzie przydatna (występowanie błędu, wersja Windows, wersja Office, wersje
plików RICHED32.DLL i USP10.DLL).

Baobam

unread,
Sep 21, 2006, 7:00:03 PM9/21/06
to

Aktualizacja Office 2003 ze strony OU nic nie naprawiła. U mnie sprawę
rozwiązała podmiana RICHED20.DLL i USP10.DLL z łatki, do której adres jest
podany wcześniej (pozostałe pliki miałem w takich samych lub nowszych
wersjach). Dzięki za pomoc!
--
Pozdrawiam,
Baobam

Andrzej P. Wozniak

unread,
Sep 21, 2006, 8:11:47 PM9/21/06
to
Osoba podpisana jako Baobam <bao...@o2.pl> w artykule
<news:1ef41lgip7xfl$.1e1hw2r1...@40tude.net> pisze:

Czyli dokładnie tak jak napisałem - tylko wersja 5.40 (z Office'a XP) jest
OK. Teraz też mam taką i nie mam problemów.

> Dzięki za pomoc!

Bez was nie poszłoby tak gładko... Dzięki za współpracę.

Marsjanin

unread,
Sep 22, 2006, 3:02:06 PM9/22/06
to
Rok 2006 - wrzesień. Dokładnie to czwartek, 21-go. Nieco po 23-ej.

Nagle zza rogu Andrzej P. Wozniak wrzuca na pl.comp.os.ms-windows.winnt:

> Występowanie problemów możesz sprawdzić w OE,

Hmm, postawiłem sobie za kluczową rzecz nie instalowanie tego
badziewia, już raz go wywalałem ręcznie. :->

BTW: "Archiwa" MHTML, które IE obsługiwał (otwierał) *tylko* jeśli był
zainstalowany OE, już-już prawie mnie przekonały kiedyś, żeby Opluka
znów doinstalować, na szczęście Opera mnie ubiegła i rozpoznaje już
ten format bez pudła. :-P

--
Pozdrawiam, Marsjanin. WWW : marsjanin.tk

Nowy toner to czarny proszek. Używany - to czarne literki wtopione w papier.
Gra: Satyricon : /Now, Diabolical/ : 3. " The Pentagram Burns"
Brzmi: live, 44 kHz, 1411 kbps.

Reply all
Reply to author
Forward
0 new messages