Error integrating PIT Gradle plugin with a different version project

Skip to first unread message

Dabba Babu

Nov 5, 2022, 4:03:12 AM11/5/22
to PIT Users
Hi everyone,

Eventuate Tram links to a GitHub project which implements a Spring Boot/JPA based microservice, and I wanted to try out using the PIT tool on this first so that I could test for my own microservices.  Here are the errors I am facing. 

  1. First I build the Eventaute project according to the instructions provided. Then I add PITest Gradle plugin according to the instructions provided in PITest documentation, it is still able to build. 
  2. When I run gradle pitest, I run into this problem - Could not find method compile() for arguments [DefaultExternalModuleDependency{group='io.eventuate.platform', name='eventuate-platform-dependencies', version='2022.2.RELEASE', configuration='default'}] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.
  3. According to the advice given here - - I update all the required methods accordingly. 
  4. When I do this, I run into a host of errors even when building the project. I got all sorts of errors like "package javax.persistence does not exist", "cannot find symbol". It is too voluminous to post here and hopefully recreating these steps will lead to the error in a short amount of time.

My best guess is that there is a version mismatch but I do not know how to solve it and I would appreciate if anyone could guide me with testing out this project so that I can apply it to my own.

Thank you.
Reply all
Reply to author
0 new messages