Pitest version

17 views
Skip to first unread message

ANURAG

unread,
Oct 25, 2021, 6:15:43 AM10/25/21
to PIT Users
Hi,
I am using Gradle 4.6. From the change log (https://github.com/szpak/gradle-pitest-plugin/blob/master/CHANGELOG.md), I couldn't make out the Pitest version that will be compatible with gradle 4.6. Please guide. 

Thanks,
Anurag

Marcin Zajączkowski

unread,
Oct 25, 2021, 11:39:41 AM10/25/21
to 'Joni' via PIT Users
Hi ANURAG,

Usually, it should be possible to get that information from README:
https://github.com/szpak/gradle-pitest-plugin#versions

However, it's quite old Gradle version (released Feb 28, 2018) and in
addition, just before releasing 1.7.0, I made some clean up there:
https://github.com/szpak/gradle-pitest-plugin/commit/f88bb13f99cd02890cd285acb8387278c4cd7f7c

To sum up:
> Starting with version 1.4.7 gradle-pitest-plugin requires Gradle 5.6. The latest version with the Gradle 4.x support is 1.4.0.

I hope that you are able to upgrade your Gradle version in the
predictable future - Gradle introduces breaking changes in every major
version (and sometimes even more often) and it is problematic to keep
the backward compatibility to long. If not, you could try to use
gradle-pitest-plugin 1.4.0 with PIT 1.7.0, however, there could be some
incompatibilities as well.


Marcin

--
https://blog.solidsoft.pl/ - Working code is not enough
Reply all
Reply to author
Forward
0 new messages