I've been thinking about your concept of dynamically chaining the Pikas.
I think that you are right and that I forgot to add this line to FilterPika :
attr_accessor :filtered_pika
Maybe a better name than 'filtered_pika' could be used.
With these two methods added, your idea of "dynamically changing the
chaining" can be implemented without too much hassle.
wdyt ?
--
John Mettraux -///- http://jmettraux.openwfe.org