Wifi Dongle Issues

1 view
Skip to first unread message

TiberiumFusion

unread,
Feb 11, 2015, 6:43:44 PM2/11/15
to pico-S...@googlegroups.com
So I bought one of these boards a while ago to experiment with, and it runs fine except for one critical issue: no wifi dongles seem to work. I've bought and tried at least 4, and all of them fail, even though they are listed in the "compatible dongles" section of the wiki. All of them follow the same pattern. When I plug the dongle in (whether before booting or afterwards), Android proceeds to recognize it (and any activity LEDs on the dongle light up), says "turning on wifi" (in the wifi settings manager) for about 3 seconds, and succeeds in enabling it, but then just a frame later, it goes back to saying "turning on wifi" and wifi is disabled again. After doing this about 30-40 times, the OS crashes and reboots.

What is happened here and how can I fix it? I am using the ICS 4.0.3 release with kernel 3.1. Powered via a 5v battery at 2.1 mA.
I know these forums are mostly empty now, but if anyone's found a solution, please help.

Nicu Pavel

unread,
Feb 13, 2015, 2:58:03 AM2/13/15
to pico-sam9g45
I would try the Android 2.3 build, this is what I'm running. To debug further we'll need some logs namely output from dmesg and a logcat dump. Either through adb or a serial console.

Nicu

TiberiumFusion

unread,
Feb 13, 2015, 11:15:12 PM2/13/15
to pico-S...@googlegroups.com
I've tested my dongles with the 2.3 build and most of them work well, albeit slowly. One of the contributers here has a custom 3.8 kernel on google code - would that solve the problem? I don't think so, as this appears to be an OS issue, but it might be worth trying. Another possible route could be compiling a patched ICS build myself, though I imagine that to be difficult.
Reply all
Reply to author
Forward
0 new messages